TechSpot

Windows XP/File Shares Problem

By Elcarion
Feb 20, 2002
Topic Status:
Not open for further replies.
  1. I've noticed a strange behavior with the way XP handles file share names. It appears to truncate the last character when connecting to or from Win2K or Samba. In other words, I've found that if I want to connect to an XP shared named \\server\mp3 I must type in \\server\mp3\ to connect to it from Win2K.
    In network neightborhood I can't even see the WinXP shares from my Win2K box. This does not appear to be a problem with WinXP to WinXP connections. Has anyone else seen this before? Is it a bug or a feature?
  2. Phantasm66

    Phantasm66 TS Rookie Posts: 6,504   +6

    Now Shut it! - Darth Maul.

    That's really strange. Here, at work, we are running a mixed Windows NT4, Windows 2000, Windows XP and Linux environment, and I'm not experiencing any of the problems that you are describing strangely.

    Share access from Windows XP seems to be to me exactly the same as Windows 2000..... Even in Linux with Samba, I am just putting / instead of \ and stuff, and everything is working fine.

    Perhaps you could describe your problem in more detail.
  3. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,745

    I think I remember hearing about this at my school, but then all the sudden it seemed to be working fine:confused:. And I know now that it works without any problems. So I am not sure what to say. I don't know exactly what that person did to change anything, but it works now.
  4. Elcarion

    Elcarion TechSpot Paladin Topic Starter Posts: 188

    I believe the Samba experience was that when a coworker tried to connect from WinXP to Samba with something like \\server\mp3 that the Samba logs showed a request for \\server\mp. The last character was truncated. I'll clarify the Samba situation tomorrow at work. It appears that XP is truncating the last character when it makes or receives a file sharing request. I will do some more research myself to see if I can figure out anything else.
  5. Elcarion

    Elcarion TechSpot Paladin Topic Starter Posts: 188

    Yes, I verified with the guy that this is indeed what he saw in the Samba logs. If he requested \\server\mp3\ from WinXP the Samba server received \\server\mp3 and everything worked fine.
  6. Elcarion

    Elcarion TechSpot Paladin Topic Starter Posts: 188

    I solved to problem of not being able to see the shares from the Win2K box under My Network Places. I did two things:
    1) Uninstalled NetBEUI - don't think this mattered
    2) Set RPC Locator service to automatic from manual
    I believe the solution was action number 2.
  7. Phantasm66

    Phantasm66 TS Rookie Posts: 6,504   +6

    "My whole existence is flawed" - Closer, Nine Inch Nails.

    Oh, I don't know! I think that NetBEUI is the scourge of all networks!
  8. Elcarion

    Elcarion TechSpot Paladin Topic Starter Posts: 188

    I was mistaken about the Win2K to WinXP problem...it turned out to be a different problem.
    I still have the WinXP to Samba situation on two Samba servers. One is an older version of Samba running in MDK 7.1 the other is RH 7.2 w/Samba 2.2.1a-4. My Network Places freezes when trying to browse the file shares on the Samba server and refuses to connection without a trailing \ when connecting to a share on either Samba server.
    Here is an article with related info. Use these at your own risk since I haven't verified the information:
    http://www.tweakxp.com/tweakxp/display.asp?id=555
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.