Windows XP keyboard settings

By DonNagual
Jun 14, 2005
  1. I have a Japanese version of XP and a Japanese keyboard that I have been using for about 6 months.

    Now suddenly XP says I have an English keyboard and my keyboard mapping has changed as a result. None of the Japanese keys on my keyboard work anymore.

    I have tried deleting the keyboard driver and reinstalling, no luck.

    Any suggestions so I don't have to reinstall windows completely?

    I don't know if this is related, but will add this info here as well just in case. Yesterday I purchased an XP English version from an auction site, and wanted to test if the CD was OK. Popped it in, and told the CD to check my system config for compatability.

    It came back with the response that I could not install the English version since I have a Japanese version already installed. I already knew this but I just wanted to make sure the CD was working....
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Go to your control panel, and click on regional and language.

    You should be able to set your language and keyboard preferences from there.

    Regards Howard :cool:
  3. DonNagual

    DonNagual TechSpot Ambassador Topic Starter Posts: 2,404

    I have checked all the setting I could find in the regional / language settings and everything IS set to Japanese as far as I can tell.

    I am able to type in Japanese no problem.

    The problem is, it thinks my keyboard is an English keyboard (suddenly).

    For example, on a Japanese keyboard if I hit shift-2, I should get the " symbol, but instead I am getting the @ symbol.

    If I go to keyboard properties in the control panel, it says I have a 101/102 English keyboard. Well, that is not true. I have a 109 Japanese keyboard, and I can not find a way to change that setting in the keyboard properties of control panel.

    I have deleted the driver and reinstalled to no avail.....

    Thanks for any other help you can give on this!
  4. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    If you can`t resolve the problem from the regional and language settings, then I`m afraid i don`t know what else to suggest.

    Regards Howard :rolleyes:
  5. DonNagual

    DonNagual TechSpot Ambassador Topic Starter Posts: 2,404

    Well, thank you kindly for your time regardless!

    If there is anyone else out there who has any ideas.... I will try ANYTHING [said with an evil snicker].
  6. DonNagual

    DonNagual TechSpot Ambassador Topic Starter Posts: 2,404

    Anyone with any ideas here?
  7. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    On the first tab 'General' is an Advanced Button. Click that and tick the number 10001 (MAC-Japanese) and UNtick the 10000 number.
    The "shift-2=@" shows the PC has somehow reverted to US English Region.
    Try re-installng both US-English and Japanese, and set the Default to Japanese, with the Keyboard-symbol as NOT showing.
  8. DonNagual

    DonNagual TechSpot Ambassador Topic Starter Posts: 2,404

    Thank you everyone who took the time to help out, the problem has been solved.

    I whimped out and did a system roll back. :giddy:
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...