TechSpot

WinXP : Blackscreen on D3D8 use

By stratagem
Aug 21, 2005
  1. Hello,

    I play WoW, EVE, and Counterstrike. I had no problems with my ATI RADEON X850 XT Platinum Edition AGP card on any of the games listed until one day--and I vaguely remember this happening around the time I downloaded and installed AVICodecPackPlus2, Avid_2.0d2_codec, and a DivX codec.

    Nowadays, usually when I start WoW or EVE the game will completely shut down my computer or blackscreen within a few seconds... sometimes after a minute... and rarely I will get the 'green light' and the game will run successfully with no problems. Counterstrike Source is unaffected-- but maybe I just haven't let it run long enough to crash.

    I tried using the DXDIAG tool and the DirectDraw test was successful, but on the second stage of the Direct3D test--where it tests Direct 3D 8 --my computer shutoff in the exact same way as with Wow and EVE.

    I've uninstalled the ATI drivers, followed the driverclean instructions, and reinstalled catalyst 5.6, 5.7, and 5.8 and I get the same problem but I think it might have something to do with those codecs as everything was running smoothly on my graphics configuration as it was. I also reinstalled DirectX 9.0c.

    I tried uninstalling the codecs using add/remove programs but I'm not sure if something stayed behind like a .dll somewhere or what have you. I'm lost... I'm about ready to reinstall WinXP from scratch which is really frustrating.

    Any clues?

    Thank you.

    _________________________________________________________

    In the following DXdiag rundown it claims I didn't test Direct 3D, but it crashes when I do so it can't save the data at that point...

    ------------------
    System Information
    ------------------
    Time of this report: 8/21/2005, 21:10:54
    Machine name: STRATAGEM
    Operating System: Windows XP Home Edition (5.1, Build 2600) Service Pack 2 (2600.xpsp_sp2_gdr.050301-1519)
    Language: English (Regional Setting: English)
    System Manufacturer: ASUSTeK Computer INC.
    System Model: A7N8X-E
    BIOS: Phoenix - AwardBIOS v6.00PG
    Processor: AMD Athlon(tm) XP 3000+, MMX, 3DNow, ~2.2GHz
    Memory: 2048MB RAM
    Page File: 218MB used, 3215MB available
    Windows Dir: C:\WINDOWS
    DirectX Version: DirectX 9.0c (4.09.0000.0904)
    DX Setup Parameters: Not found
    DxDiag Version: 5.03.2600.2180 32bit Unicode

    ------------
    DxDiag Notes
    ------------
    DirectX Files Tab: No problems found.
    Display Tab 1: No problems found.
    Display Tab 2: No problems found.
    Sound Tab 1: No problems found.
    Music Tab: No problems found.
    Input Tab: No problems found.
    Network Tab: No problems found.

    --------------------
    DirectX Debug Levels
    --------------------
    Direct3D: 0/4 (n/a)
    DirectDraw: 0/4 (retail)
    DirectInput: 0/5 (n/a)
    DirectMusic: 0/5 (n/a)
    DirectPlay: 0/9 (retail)
    DirectSound: 0/5 (retail)
    DirectShow: 0/6 (retail)

    ---------------
    Display Devices
    ---------------
    Card name: RADEON X850 Series
    Manufacturer: ATI Technologies Inc.
    Chip type: ATI RADEON X850 XT Platinum Edition AGP (0x4B4C)
    DAC type: Internal DAC(400MHz)
    Device Key: Enum\PCI\VEN_1002&DEV_4B4C&SUBSYS_03121002&REV_00
    Display Memory: 256.0 MB
    Current Mode: 1280 x 1024 (32 bit) (60Hz)
    Monitor: SONY SDM-HS75P
    Monitor Max Res: 1280,1024
    Driver Name: ati2dvag.dll
    Driver Version: 6.14.0010.6561 (English)
    DDI Version: 9 (or higher)
    Driver Attributes: Final Retail
    Driver Date/Size: 8/3/2005 23:10:36, 205312 bytes
    WHQL Logo'd: Yes
    WHQL Date Stamp: n/a
    VDD: n/a
    Mini VDD: ati2mtag.sys
    Mini VDD Date: 8/3/2005 23:10:16, 1273344 bytes
    Device Identifier: {D7B71EE2-080C-11CF-136A-1823A1C2CB35}
    Vendor ID: 0x1002
    Device ID: 0x4B4C
    SubSys ID: 0x03121002
    Revision ID: 0x0000
    Revision ID: 0x0000
    Video Accel: ModeMPEG2_C ModeMPEG2_D ModeWMV8_B ModeWMV8_A ModeWMV9_B ModeWMV9_A
    Deinterlace Caps: {6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
    {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
    {552C0DAD-CCBC-420B-83C8-74943CF9F1A6}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
    {6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
    {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
    Registry: OK
    DDraw Status: Enabled
    D3D Status: Enabled
    AGP Status: Enabled
    DDraw Test Result: Not run
    D3D7 Test Result: Not run
    D3D8 Test Result: Not run
    D3D9 Test Result: Not run

    Card name: RADEON X850 Series - Secondary
    Manufacturer: ATI Technologies Inc.
    Chip type: ATI RADEON X850 XT Platinum Edition AGP (0x4B4C)
    DAC type: Internal DAC(400MHz)
    Device Key: Enum\PCI\VEN_1002&DEV_4B6C&SUBSYS_03131002&REV_00
    Display Memory: 256.0 MB
    Current Mode: 1024 x 768 (32 bit) (60Hz)
    Monitor: SONY SDM-HS75P DVI-D
    Monitor Max Res: 1280,1024
    Driver Name: ati2dvag.dll
    Driver Version: 6.14.0010.6561 (English)
    DDI Version: 9 (or higher)
    Driver Attributes: Final Retail
    Driver Date/Size: 8/3/2005 23:10:36, 205312 bytes
    WHQL Logo'd: Yes
    WHQL Date Stamp: n/a
    VDD: n/a
    Mini VDD: ati2mtag.sys
    Mini VDD Date: 8/3/2005 23:10:16, 1273344 bytes
    Device Identifier: {D7B71EE2-082C-11CF-136A-1923A1C2CB35}
    Vendor ID: 0x1002
    Device ID: 0x4B6C
    SubSys ID: 0x03131002
    Revision ID: 0x0000
    Revision ID: 0x0000
    Video Accel: ModeMPEG2_C ModeMPEG2_D ModeWMV8_B ModeWMV8_A ModeWMV9_B ModeWMV9_A
    Deinterlace Caps: {6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
    {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
    {552C0DAD-CCBC-420B-83C8-74943CF9F1A6}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
    {6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
    {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
    Registry: OK
    DDraw Status: Enabled
    D3D Status: Enabled
    AGP Status: Enabled
    DDraw Test Result: Not run
    D3D7 Test Result: Not run
    D3D8 Test Result: Not run
    D3D9 Test Result: Not run
    puke:
     
  2. zephead

    zephead TechSpot Paladin Posts: 1,569

    you should try updating you motherobard's drivers, as a fault therein could easily be causing your problems.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...