TechSpot

WinXP Pro Login = Logout loop

By BBoW
Mar 9, 2009
  1. Hi guys,

    Last night I must have clicked on a dodgy link and activated something. Computer was fine last night, left it on overnight (internet connected) and this morning there were lots of popups and various other spyware/malware installations captions.

    I tried to close them but no luck. Did a restart and the popups started appearing again.

    Ran AntiVir followed by AdAware. AntivIR found over 2000!!! alerts and stupid me selected the "delete - and every subsequent detection" option during the scan. This must have deleted some essential files.

    Upon restart I now get stuck during the Login stage into windows.
    I try logging in, but a few seconds later it says "saving your settings" followed by "logging out" and I'm back at the Login caption.

    I tried finding a sollution on these forums and did the boot with the XP Pro CD. This started installing a new XP on the drive, I never had a chance to select Recovery. I did not want to mess things up by interupting the install, so I let it finnish. The situation I find myself now in is as follows:

    2 XP installations on the same partition. 1 let's me login and works fine (this would be the new installation), and I can find all the files that are on the computer but I would need to reinstall everything to make it work properly. The other XP is the one that keeps looping during login. The interesting things is that if I leave the login caption for a few minutes I can hear music/news readouts. This would probably be from a popup that's working in the background.

    I would really like to get the old XP installation to work again and uninstall the new installation. Does anybody here know how?

    Many thanks,

    Bbow

    PS: it's WinXP Pro SP3 (new install is clean XP, no SP)
     
  2. Matthew

    Matthew TechSpot Staff Posts: 5,245   +92

    Can you access the old copy of XP in Safe Mode? Might be able to scan/recover your XP partition by scanning it with anti-malware apps on your new installation.
     
  3. BBoW

    BBoW TS Rookie Topic Starter Posts: 25

    Hi Zenosincks,

    Nope, when I try safemode I get the same login-logout loop problem.
    Haven't tried scanning the HD yet, will give it a go.
     
  4. BBoW

    BBoW TS Rookie Topic Starter Posts: 25

    Just to give more info and hoping that someone out there knows what to do...

    2nd XP is installed in Partition D: , 1st XP (the faulty one) is installed on C:.

    I have tried expanding userinit.ex_ from the XP CD to C:\Windows\system32 but this hasn't made any difference, still the same problem.

    I scanned the C:\windows folder with CC Cleaner but it wants to delete the WHOLE folder, so no luck with that.

    Any ideas what else I could try? Adaware perhaps? Malware remover?

    The good thing is I haven't lost any files so far....I think.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...