WinXP Pro network/file access/sharing problem

By jsnorton
Jun 12, 2007
Topic Status:
Not open for further replies.
  1. I used to be able to share files across my local workplace network. Some how that failed in the last two weeks. By now, I have tried so many permutations that I need an uncluttered mind help me straighten out my mess.

    Ok ... I am dealing with 2 WinXP Pro systems, with all the latest MS updates and patches. One is a laptop, that I synch with the desktop, such that I maintain one master set of files on the desktop.

    1. Configured workplace names to be same on both systems
    2. both connect to a router/gateway via ethernet for connectivity and DSL
    3. simple file sharing is set on
    4. I can ping either system from from either system
    5. have set specific folders for file sharing
    6. Both computers can see the workgroup name (most of the time)
    7. either computer can see it's own shared files
    8. neither computer can see the other computer using network places
    9. Oh ... forgot to mention, I disabled Norton Anti... and firewalls

    It is entirely possible that there is still something inhibiting the access or somehow got changed in the last few weeks. I get the message that say "computername is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions."

    I expect this has come up before ... but I didn't find a similar issue or

    I am stuck ... could use some help. thanks
  2. mikescorpio81

    mikescorpio81 Newcomer, in training Posts: 574

    I would start by pinging both PC's from one another; IP address and hostname. If you can't do both, a firewall may still be interferring.

    Then I would disable simple file sharing on both PC's, so you can configure permissions manually. Check both the share and security permissions on the folders you are trying to share. Share permissions should be set to allow the Everyone group "Full Control". Security over the files you want to share (at the top level of the folder structure), I would add whatever your logon is and make sure it is also set to "Full Control".

    To keep it simple, ensure the username/password is the same on both PC's, that way you won't be prompted to type in a username/password to authenticate.

    If you want to re-enable your firewall you could do, but you may still have to configure them (Windows: Exceptions - Norton IS: Alot more options!)
  3. jobeard

    jobeard TS Ambassador Posts: 13,353   +301

    if you see system names only periodically under Network Places AND both systems
    are running, then you have a network reliability problem somewhere.

    file/print sharing require both systems to allow ports 135(system names),
    139,445(data ports) to be open.

    Personally, even with XP/PRO I still opt for Simple File Sharing which uses the
    Guest Account to access the shares.
    1. enable the Guest Account
    2. set a password (you will give this to those trusted for sharing)
    3. then disable the Guest Account
    the disable only stops keyboard logins, and a good password stops other Internet
    accessors from getting access. The Guest Account pw can be changed anytime
    and becomes effective on the next Map Drive or Mount of the share.
  4. jsnorton

    jsnorton Newcomer, in training Topic Starter

    Mikescorpio81,
    can you point me to a "deeper" reference for setting permissions manually?

    i looked at this but was unable to see or reference the other name.

    also, while i can ping the ip addresses of the other systems from each system, i can not ping using the other system's hostname.

    truly appreciate your help but still seem to be stuck :)
  5. jsnorton

    jsnorton Newcomer, in training Topic Starter

    jobeard,
    turned on the guest id but did not see a way to set a password?

    did not see port 135 (names) when editing the file sharing ports ... i saw the other ports --- is there some other place that i should be looking .... also saw port 137 which you did not mention

    can you give me a little more insight into this area ... and maybe that is why i am not seeing the hostnames on the remote systems?

    appreciate you help ... but still stuck :)
  6. jobeard

    jobeard TS Ambassador Posts: 13,353   +301

    1) as your systems are not registered on a dns, you wil never be able to PING
    one of your LAN systems by name. You see names via the View Network because of names being exchanged on port 135 (BIOS Names).

    forget ping-by-name, it's of no consequence it you can ping by address :)

    2) Using the default Windows Firewall, all you need is the Exception tab,
    and check Print/File sharing. It will do the trick.

    Any other firewall,
    allow tcp/udp in/out any-source-ip, dest=your-lan-ip-range, ports, 135,139,445

    >turned on the guest id but did not see a way to set a password?
    3) reenable Simple File Sharing :)
  7. mikescorpio81

    mikescorpio81 Newcomer, in training Posts: 574

    For the novice user, simple file sharing would be advised (I guess).
    But I prefer not to use it, so I can set my permissions manually.

    If you turn it off, you notice when you look at the properties of a folder you get a 'Security" tab. That's what it's all about :)

    Take Jo's advise on this one. You need to be more familiar with share and security permissions to start to configure them manually.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.