TechSpot

Wireless Problem on Vista

By wayneskate89
Feb 26, 2009
  1. Hi, I was just wonderin wether someone could help me out.

    When I boot my laptop up the wireless comes on for about 20 seconds or so and then the green light to show that it's on just goes off along with the wireless card.

    When i'm at home it will connect to my home network & display a webpage within this time. Then go off.

    However, booting up in Safe Mode with Networking...it works fine, no problems with it atall.

    Any ideas?

    Thanks,

    Wayne.
     
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Could you be more specific about your laptop make/model and wireless card (if the card was an add-on to the laptop)
     
  3. wayneskate89

    wayneskate89 TS Rookie Topic Starter

    standard wireless card.

    Sony Vaio VGN - NR32L

    Can Anyone help me?
     
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Sony documentation on the problem is awful.

    But my first guesses
    1) It's related to power management. Where Windows turns off power for the device or
    2) The wireless card has its own configuration manager but
    => the Windows wireless configuration manager is still running and probably grabs control (and doesn't manage the card correctly)
    => the Windows wireless configurator may not get started in Safe Mode


    So here's a couple things to try (and are easy to undo if they should have no affect). Test after each change see if problem is fixed or not
    Turn off Power Management for the Wireless Adapter
    1. Start->Run, enter: devmgmt.msc to Open Device Manager
    2. Scroll to Network Adapters, expand the list of adapters
    3. Rt click on your wireless adapter, select Properties, Click Power Management tab
    4. Uncheck "Allow the computer to turn off this device to save power"
    5. Click OK

    Turn off Windows configurator (as the wireless card probably has its own)
    Method A
    => Start->All Program Files
    => Look through all programs to see if you have a program folder for your wireless card
    => If you do, look closely for a program that configures your card. If offered a choice, turn off/choose not to use Wireless Zero Configuration

    Method B
    => Start->Run, enter: services.msc
    => Scroll down to Wireless Zero Configuration, rt click Properties. Change Startup Type to Disabled.
    => Reboot

    Hope either (or both of these) help.. Let us know
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...