Wireless Vista? problem

By ptitterington
Mar 26, 2007
Topic Status:
Not open for further replies.
  1. Hope this is the right place for this.

    I had a Drayteck Vigor wireless router worked fine for 3 years, I thought it was faulty and replaced it. It turned out that it was a totally unconnected telecom fault.
    So. I signed my dad up for broadband, took it around set it up and connected to the ethernet caple it works a treat.(XPsp2 desktop)

    Unfortunately, he got my mum a shiny new Asus laptop with Vista and it cannot connect wirelessly.
    PC says good signal and connected to internet but when I click on a link it is not connected.
    I get excellent signal strength and the router can see the MAC address of the Laptop.
    Is it a security setting in Vista that I have not found? I just find the settings in Vista too hard to track down.

    I had the laptop working fine with its dial up modem.

    The laptop did not connect either using a lan cable direct to the router

    Just a bit baffled! (plus mum is annoyed)
  2. Tedster

    Tedster Techspot old timer..... Posts: 10,074   +13

    Windows Vista is an unproven OS with many driver issues. A lot of peripherals will not work with vista. I suggest trying XP.
  3. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,428   +281

    Have you tried Vista's help files? I found them to be considerably better than the ones in XP. They often have clickable spots which open up exactly what you need, which is a timesaver compared to going through all the renamed and repositioned settings in Vista.
  4. ptitterington

    ptitterington TechSpot Maniac Topic Starter Posts: 376

    Thanks, I had been following the help but just chasing myself around in circles. If only she would let me wipe her system and put XP on it.

    I was hoping it was a siple change this setting and there you go.

    Going to try another laptop that has vista and works on my router and then the other way round before I get har a new router.

    Thanks anyway
  5. ptitterington

    ptitterington TechSpot Maniac Topic Starter Posts: 376

    Well update for any future readers;

    Tried with another vista laptop, same problem.

    The router was just not Vista friendly. New router solved the problem.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.