TechSpot

Wrong Keyboard Layout at Logon Welcome Screen

By paradak
Feb 15, 2005
Topic Status:
Not open for further replies.
  1. Hi!

    I installed WinXP from a French (France) version of WinXP SP 2 Titanium.

    Living in Montreal (Quebec), I have a US-type keyboard, so I have selected the regional language settings to English AND French (Canada), which both use typical "QWERTY" keyboards. But French keyboards are "AZERTY". :rolleyes: I made sure to completely "zap" the French (France) Layout, because many letters don't fit with my keyboard anyway.

    When I try to log in after booting the computer, the Welcome Screen seems to be "stuck" with the French (France) keyboard layout. For example, lets say my password is 6 letters long: "qwerty", the wrong layout at the Welcome Screen makes it so that I have to type "azerty" instead to be able to log in. :dead:

    After logging, I get English (or Canadian French) as my default language (just as it should). If I then log-off by closing the session (not by shutting down the computer), then I get the US layout and I can re-log back in again without having to guess which letters the France layout really uses.


    I change passwords regularly, so telling me to "simply avoid using password with letters that are not the same on both layouts" is not such a great idea.

    How do I change the keyboard layout for the log-in step?


    Thanks!


    Pax
  2. Nodsu

    Nodsu TS Rookie Posts: 9,431

    Start->Settings->Control Panel->Regional and Language->Languages->Details->Default input language
  3. paradak

    paradak TS Rookie Topic Starter

    That dialog box tab panel is exactly how I did this:

    Added kbd layouts:
    English (United States)
    Added French (Canada)
    Added French (Quebec custom kbd layout)
    Deleted French (France)
    Set English (United States) as the default language.

    When entering the user password in the welcome screen (or at the log-on popup if that screen is turned off), the keyboard layout used is *STILL* French (France). Once I' have logged in, then thetreafter its okay and I am not troubled anymore by French (France), even if I log-off and re-log in again later (i.e. as long as I don't use "shut-down").

    So what gives?

    From "scratch", my Edition of XP starts only with French (France) in the languages keyboard and regional settings.

    So, I ask again, just *how* can I "select" the log-on screen language?

    Thanks in advance.

    Pax.
  4. Nodsu

    Nodsu TS Rookie Posts: 9,431

    Run the muisetup.exe utility under \windows\servicepackfiles\i386 and see what is the default language set there.

    I trust you did not upgrade XP from 98 or Me?
  5. paradak

    paradak TS Rookie Topic Starter

    Strange, but I have no such "muisetup" utility on my system. I don't even HAVE a "servicepackfiles" folder in my windows folder. I checked with a recursive folder search both on my C drive and on the WinXP install CD.

    When I installed, I did not "first" install WinXP, "then" install the SP2. It was all done on one single step.


    I installed my system this way:

    C: is a 80 GB hard disk, with only one NTFS partition that I renamed from "Disque Local (C)" to "MySystem (C)".

    D: is a 200 GB hard disk, split into 2 partitions, one of 80 GB called "MAIN_DATA (D)" and the rest called "XTRA_DATA (F)".

    Finall a third hard disk E: ith another 80 GB named "BACKUP (E)".

    And of course as DVD Burner, which falls on drive G

    Note that I always separate "system" files (applications, etc.) from "personal" stuff (images, video, word documents, work related stuff, downloads, backups, etc.). So basically drive C is supposed to be "system" only. If I format drive C, I lose nothing (I never put anything in folders such as "My Documents" and such)

    So basically what I did was, I set the boot option in the AMIBIOS setup to boot from the CD-ROM, and from the WinXP installation screens (directly from the WinXP installation CD) I then selected the option to delete the drive C partition, then re-created the C partition in NTFS using the simple "non-quick" formatting provided in the WinXP installation screens, and then installed WinXP in that "new" C partition.

    Question: Is that kind of "brute-hammer-force" thing sufficient to really zap all existing viruses? In understand that this won't affect viruses that would be inserted in my user files in my D, E and F drives, such as for example Word document macro-viruses, but for MBR and such viruses, will I really get a "full"-cleaning or not? I'm going to run AVG Anti-virus and I wondered if MBR viruses will be "found" by such programs even tough windows is already started.

    Anyway, even if I'm still with the same "log-on" problem, thanks a *LOT* for your help. It's very cool to see people helping each other like that.

    I'll go check now if I can manage to get muisetup in another way, then post a 2nd message right under this one to tell you what I found out in muisetup.

    Thanks.
  6. paradak

    paradak TS Rookie Topic Starter

    Ok, checked the microsoft site extensively.

    In particular, these pages:

    http://www.microsoft.com/resources/...Windows/XP/all/reskit/en-us/prff_mul_utpc.asp

    So muisetup.exe seems to be for multilingual installation, and I seem to have a French (FRance) localized version of WinXP, not a MUI Package version (and everything in my OS, down to the names of services that are displayed in services.msi, and all help files, its all in french, too... (arg!)

    Since the Titanium edition is a silent install, this all seems logical, but still I seem to be stuck.

    As soon as I have enough money, I'll buy a TRUE version of WinXP, box and all, but right now I'm a bit broke, so I'm still in a bit of trouble. It's more of an "annoying" problem than anything else, but I really hate not being able to select any password for my machine. I just know that one day I'll screw up and not be able to log-in anymore... ;-)

    Pax
  7. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 8,165

    Even while you are broke, you probably could afford a "Canadian French" keyboard, rather than the US-keybord. Pick one up on a fleamarket or from a skip. Use that until you get an English Windows.
  8. paradak

    paradak TS Rookie Topic Starter

    I already have a canadien french keyboard.

    There is a BIG difference between Canadien French keyboards and France French keyboards:

    The first are QWERTY keyboards with accentuations for french characters added in, and the seconds are "true" AZERTY keyboards.

    Asking someone like me to re-learn fast-typing on another type of keyboard at my age, after 20 years of practice in the local standard of Montréal city would be exactly like... like if I was asking you to learn another language that you do not currently know, like say german or mandarin, and then start watching your favorite soaps in that language instead of in the English that you are extremely familiar (and born) with... Not such a great idea...

    Pax.
  9. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 8,165

    Get a printout of the French keyboard and the Canadian French keyboard.
    Then move the keyboard-keys around so it matches the French layout.
    Those keys should pop off without too much hassle. Watch for possible springs underneath them.
    Then load the French KB-drivers. An hour's work on a rainy afternoon I guess.
  10. joejoe4

    joejoe4 TS Rookie

    i think the solution is very simple

    i had a similiar problem that drove me mad. I logged on as local administrator, set the language settings like i wanted, and on the advanced tab under "regional language options" , i checked the box under "default user account settings".. that's it. the log on screen was also affected...
    good luck
  11. Laurentm

    Laurentm TS Rookie

    Essaie ceci...

    Salut,

    I often encountered the same problem here in belgium. Here's my solution under windows xp (i believe it works on other win platforms):

    1) launch regedit (I assume you are familiar with registry editing, if you're not contact your local admin)
    2) navigate to [HKEY_USERS\.DEFAULT\Keyboard Layout\Preload]
    3) Edit the "1" key: its value should be "00000c0c" (I believe it's the keyboard layout code for french(canada), it's 00000813 for a belgian-dutch keyboard).

    Bonne chance et bon travail.

    Laurent
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.