X700 pro no video signal, help needed!

By scotczech
Jul 11, 2006
Topic Status:
Not open for further replies.
  1. Hi I have a asrock 775twins motherboard and a xpro700 pcie gfx card.
    I get no signal from card, upon hitting power on, the "no signal" msg dissapears but only for a few secs, then it returns.
    Card is lit up , fan turning etc.
    how does one disable the onboard vga? maybe this stopping card being detected??
    Asrock website is useless on this like the manual that came with mb.
    I see no MB bios setting to disable the onboard vga, so im lost here.
    is PCIE connected with gfx card?? i see frequency thing in bios but isnt that to do with CPU setting?
    any help appreciated, asrock ill never buy again.
  2. wolfram

    wolfram TechSpot Paladin Posts: 2,605   +9

    Hello and Welcome to Techspot!

    Did you uninstall all the drivers related with the onboard video?
    Also, check that you have connected the monitor to the X700PRO, maybe you have connected it to the onboard video. That could be the cause.
    New motherboards automatically disable the onboard video when you insert a new graphics card.

    EDIT:

    Here you go, I found it:
    http://www.asrock.com/PRODUCT/775Twins-HDTV.htm. Download the manual from here. Then, go to page 32, and check "Northbridge configuration". Then look at "Primary Graphics Adapter". You now know what to change in your BIOS.

    Now in your BIOS, (using the onboard video of course, remove the X700 card), go to Advanced, then to Chipset configuration, then to Northbridge configuration, and look for the "primary graphics adapter". Change the current setting to "PCI Express".
    Now go to the main BIOS menu, go to the exit menu, and select "save changes and exit".

    Turn off the PC, install the X700 card, plug the monitor to it, and it should work now!

    Hope this helps!
    Good luck! :)
  3. scotczech

    scotczech Newcomer, in training Topic Starter

    thanks but made no difference, it was set to pcie as primary.
    the x700 is not being detected, primary just scans for a card there 1st, it surely does not find the x700.
    I read elsewhere about ati cards not giving out a signal.
    this is last time i get a board with onboard gfx.
    seems weird the card dont use any external power, just the slot.
    its probably some silly bios setting, but i am damned if i can work it out, wish i could just disable onbaord via jumpers, why bios just dont let you disable onboard though?? even with primary set to pcie the onbaord still runs,,grrr
    neway thank you........ill get a abit mb i guess, damn annoying though!!
  4. wolfram

    wolfram TechSpot Paladin Posts: 2,605   +9

    Ok, If you think that's a BIOS setting, reset the BIOS. Remove the battery found on the motherboard for 10 minutes at least. Then the mobo should say something like "CMOS error, defaults loaded" or something like that.

    I´ll try to check if there's a jumper to do the trick easily.

    EDIT: Found it!

    Go to your manual again, to page 9. Look at number 22. Locate the number on the mobo layout. It should be next to the mobo's battery. Move the jumper and let it for 2-3 minutes. Then put the jumper to its original position and boot again (with the X700). Now it should beep and say a "CMOS error, defaults loaded".

    Now, if the problem was a BIOS setting, it should be solved now. If not, probably you have a DOA GFX card :dead:
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.