XP Home Edition suddenly is super slow and hangs

By NoComputerGeek
Nov 13, 2004
Topic Status:
Not open for further replies.
  1. Hi. Anyone please help.I just recently bought my pc last summer, and it was running ok until 2 days go when it went suddenly slow as in too slow likedownloading would take half an hour, if not that, it hangs...I can't click anything, or I get this blank blue screen. Please help I am new to this thing :( Thanks.
  2. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +19

    Hello and welcome to Techspot.

    In order to help you we need to know your system specs and what was happening before the slowdown occured I.E have you recently installed any new hardware or software?

    If you would enter your system specs in my.TS.forum at the top of this page(click on edit profile)

    Regards Howard :grinthumb
  3. RealBlackStuff

    RealBlackStuff Newcomer, in training Posts: 8,165

    When was the last time you did a Chkdsk or a Defrag on that computer?
    How much space is left on the harddisk.
    Is your Temp directury filled to the brim?
    Did you ever clean your temporary internet files?
  4. NoComputerGeek

    NoComputerGeek Newcomer, in training Topic Starter

    Hi Howard.
    Hello realblackstuff.

    Thanks for the replies. I have to check first the specs (I only know so far is that it is Pentium 4 :confused: ) but as for recent installations, none.

    Well, I just turned it on as usual and suddenly nothing happens when I click my mouse, a few minutes later the mouse even quit working. That's how it happened. . .very sudden. And it keeps happening now. Downloading takes ages so I have to reboot once in awhile then it will be ok, then. . .back again to the problem.

    Uh I haven't done any "defragging" yet since then, or done any cleaning yet, I'm afraid. Is it possible the problem has been caused by that? I guess I'll try that first, and I'll also put the specs when I find out where they are :giddy:
    Thanks .

    Regards.
  5. m@artin

    m@artin Newcomer, in training

    Did you check for spyware and viruses on your PC? This might also slow done your PC extremely.
  6. NoComputerGeek

    NoComputerGeek Newcomer, in training Topic Starter

    System Specs

    Hi, Howard. It's me again. I have just now entered the specs of my pc, I hope you can look into it? I still pretty much have the same problem...I tried defrag but it's still slow. Thanks very much.


  7. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +19

    Have you done all that Realblackstuff suggested?

    Also As Martin suggested you should do a full check for spyware and adware and run your antiviral softwear.

    Take a look at the following thread By RBS

    Pay particular attention to the first part of the thread.

    http://www.techspot.com/vb/topic17297.html

    Regards Howard :grinthumb
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.