TechSpot

XP; unable to connect to DSL Router or Internet

By videobruce
Jun 1, 2004
Topic Status:
Not open for further replies.
  1. Running XP w/sp1 I can't get to my DSL Router let alone connect to the internet.
    My system has 2 bootable HDD's; XP on one and 2k on the other. The 2k HDD is fine and has been.
    I just started expermenting with FP, er.....XP and I get 0.0.0.0 for both the IP address and the Subnet Mask when I check the Status tab under Network Connections or using ipconfig at a command prompt.
    There are only 2 boxes on the Network, nothing fancy. No firewalls and that XP Firewall is disabled.
    All the settings are on auto as they are on the other O/S as far as the NIC goes. I am using the Administartor account.
  2. RealBlackStuff

    RealBlackStuff Newcomer, in training Posts: 8,165

    If you use the same settings as in your W2K, it should work.

    Let us know your router- and W2K- and XP-settings.

    In the command-prompt you could try and enter: ipconfig /renew to teach XP manners.
  3. Goalie

    Goalie Newcomer, in training Posts: 703

    In your properties for your XP network connection, be sure you ahve the device configured to use DHCP. If it gets set to use a static IP without actually setting the IP you can get settings as you describe.

    Please let us know what the connection properties for the network connection contain, so we can help you diagnose this.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.