Your browser doesn't accept cookies. Cookies are required to use this site

By vinit005
Dec 8, 2008
Topic Status:
Not open for further replies.
  1. i have downloaded x-cart demo version from the website and installed it on my localhost. but when I try to get into the website by providing credentials, I'm getting an error message from the browser saying "Your browser doesn't accept cookies. Cookies are required to use this site".

    I have set the Internet options -> privacy settings to low. but still I'm unable to get into the website. whenever i select any item and click on "add to cart" button, I'm facing this error dialog!!!!!

    Anyone got an idea what it could be, or how to solve it?

    Any suggestions are welcomed....[:)]

    Thanks!!!
    Vinit
  2. Tedster

    Tedster Techspot old timer..... Posts: 10,074   +13

    you failed to state what browser you're using. Some websites are not HTML compliant and insist on using IE as a browser. Even then, newer versions of IE don't always work.
  3. vinit005

    vinit005 Newcomer, in training Topic Starter

    >>>you failed to state what browser you're using. Some websites are not HTML compliant and insist on using IE as a browser. Even then, newer versions of IE don't always work.

    Oops sorry for not providing full information. Actually I have used browsers IE(6.0,7.0) and Mozilla Firefox(3.0).

    Any suggestions are welcomed...

    Regards,
    Vinit
  4. CCT

    CCT TechSpot Evangelist Posts: 3,556

    If using XP, in IE7 click Tools, Internet Options, Privacy, Advanced and make sure you have the 'overide', 'accept', 'accept' and 'always allow' boxes checked.
  5. Bobbye

    Bobbye Helper on the Fringe Posts: 16,392   +36

    But DON'T check 'Accept third party Cookies'. You do not need these to access any web site.

    This is some duplication of what CCT said, but it's what I use when checking the tracking cookies in logs
    Reset Cookies:
    For Internet Explorer: Internet Options (through Tools or Control Panel) Privacy tab> Advanced button> CHECK 'override automatic Cookie handling'> CHECK 'accept first party Cookies'> CHECK 'Block third party Cookies'> CHECK 'allow per session Cookies'> Apply> OK.

    For Firefox: Tools> Options> Privacy section> CHECK 'accept Cookies'> UNCHECK 'accept third party Cookies.

    I have a bank site that occasionally displays this Cookie message, although my setting are okay. hitting the Reload button will usually let the site display. You should understand that things like this don't necessarily ,mean something is wrong on our system. Not all sites have all their programming perfect.
  6. CCT

    CCT TechSpot Evangelist Posts: 3,556

    Nice Bobbye - but, I wanted the poster to respond - I don't have third party enabled either - I just wanted to clear the field.
  7. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Why not reset everything!

    How to use Reset Internet Explorer Settings (RIES)

    To use RIES in Internet Explorer 7, follow these steps:

    1. Click the Tools menu, and then click Internet Options.
    2. On the Advanced tab, click Reset.
    3. In the Reset Internet Explorer Settings dialog box, click Reset.
    4. When Internet Explorer 7 finishes restoring the default settings, click Close, and then click OK two times.
    5. Close Internet Explorer 7. The changes take effect the next time that you open Internet Explorer 7.

    Note for users who cannot start Internet Explorer 7 for some reason, use RIES from Internet Options in Control Panel.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.