Lucent WinModem v.90 version 6.00

May 8, 2001
modem600.exe
834 KB
Windows 98/Me/NT/2000
979
Note: This software upgrade will not work with DSL capable modems.

You can upgrade your LT Win Modem to version 6.00, which supports Windows 9x, 2000, ME and NT for ISA and PCI. The generic 6.00 modem driver update for LT Win Modems and LT Win PCI Modems is available for download.
Alternative drivers to Lucent WinModem v.90 version 6.00: