No IE 7.0 for Windows 2000

By Derek Sooman on February 16, 2005, 3:09 PM
Until you hear any better, forthcoming IE 7.0 does not support Windows 2000. This could mean that many corporate users will open themselves up to various security issues, when they miss out on the security enhancements promised by this new browser.

The news that IE 7.0 will be available only to Windows XP SP2 (Service Pack 2) customers isn't likely to sit well with security experts who argue that the threat from the Firefox browser is at the center of Microsoft's aggressive anti-spyware and anti-virus plans.




Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...
Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.