200 GB External HD Problem

By volcomstoner ยท 6 replies
Oct 12, 2004
  1. I ordered a NTFS formatted 200 GB Maxtor External HD from this company and I am having problems getting the HD to be seen as a drive in My Computer. The device was installed successfully through Windows XP and it says it functioning properly. I have read that I need to format it through Disk Management in the Computer Management control panel. The drive is not recognized there so I cant partion or work with it there. In the device manager it says sees it as a "USB 2.0 Mass Storage Device" Any suggestions?

  2. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    You can format a drive in explorer highlight it and right click if it is there.and you are logged on as an administrator
  3. volcomstoner

    volcomstoner TS Rookie Topic Starter

    I dont think you read the description of my problem where I am not able to see the drive in My Computer nor Disk Management. So how do you suppose I format it?
  4. Justin

    Justin TS Rookie Posts: 942

    In the Disk Management snap-in you don't see the drive at all?

    Also, have you tried on another computer?
  5. volcomstoner

    volcomstoner TS Rookie Topic Starter

    yah thats what i am saying. I know the hd works cause I formatted and partitioned it in my desktop. when i connect it to the case it doesnt work. it must be the cass, but its weird that windows detects and successfully installs the USB device as a mass storage disk drive. any other suggestions?
  6. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    Can you get DOS drivers for USB support and Format the drive at a prompt window .
    Or put the drive back on your desktop's IDE channel delete the partitions re-install the drive in the USB case and see if your computer will recognize the Drive ,If it does you will be able to format it in My Computer or Explorer
  7. talison

    talison TS Rookie

    I had a similar problem. I had tried to reformat a Maxtor (Lacie branded) 250 GB USB hard drive using NTFS. Something bad happened during the reformat and it did not complete. Windows XP would still recognize the USB drive when it was plugged in (it showed up in "Safely Remove Hardware"), but it would not assign it a drive letter and Disk Management would not recognize it either.

    The solution was to run killdisk on the drive. Then it was recognized by Disk Management but after all of that I decided to go back to FAT32 which required that I download a special utility from Maxtor called MaxBlast because Windows XP refuses to format a drive larger than 32 GB with FAT32.

    Hope this helps.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...