250gig WD only recognized as 120gig

By foozy ยท 6 replies
Dec 23, 2006
  1. So i'm building a system with a Biostar GeForce 6100 AM2, Athlon 64 3500+, and WD 250gig SATAII HDD. The system boots fine, I load windows fine, the only problem is that the hard drive is half as big as it should be. Something is only seeing a 120gig hard drive instead of a 250gig. I was thinking perhaps BIOS needs to be updated, but the board model is less than a year old. Thoughts?
  2. kitty500cat

    kitty500cat TS Evangelist Posts: 2,154   +6

    Maybe the manufacturer decided that 1GB=500MB; not much worse than the existing 1GB=1000MB :D

    Is the drive partitioned for some reason? I'm no expert on hard drives though.
  3. foozy

    foozy TS Rookie Topic Starter Posts: 139

    No, it's a brand new drive. I stuck in an identical 250gig WD hdd and I had exactly the same problem. I browsed around the forums a little more and found some junk about Windows not recognizing anything greater than 137 gigs. I *thought* that the BIOS was seeing it at 137gb also, but now i'm not totally positive.
  4. foozy

    foozy TS Rookie Topic Starter Posts: 139

    Updated the BIOS, installed Service Pack 2, still the same problem.
  5. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    Didn't you run the CD that came with WD drive? Also there is a tool out there that does a low level format that will give you more than 250GB. Remember though a 250GB is just a little over 230 to 240GB.

    The problem you're having I did the samething for this guy kids computer it only came up what you had. But you need to run the CD that came with the drive so it can unlock the size or something like that. If it still doesn't do it take the drive back to where you got it. How come you didn't get 320GB they're dirt cheap now. 298GB is the correct size.
  6. foozy

    foozy TS Rookie Topic Starter Posts: 139

    Its an OEM drive, no CDs. I loaded Debian and the problem was gone - drive came up at 232gb, i'm assuming the rest is in the boot sector.

    So apparantly it's a windows problem, but installing SP2 doesnt' fix it. Hmm.
  7. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    read the GUIDE's forum about BIG hard drives.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...