4 gb of Ram is only showing up as 2 gb in Windows XP

By jonisaksson ยท 23 replies
Dec 28, 2005
  1. Hello,

    You might have seen a number of post from me other the last couple of days as I have been struggling with building my new pc :blush:

    Anyway, my PC is now running fine and I have installed more or less the programs I need.

    Now I have just one "problem" left, I have put in 4*1 Gb of RAM in my computer and in the boot up sequence it all shows up.
    But in Windows I can only see 2 Gb?
    I have never had the opportunity before to have this much RAM in one computer.
    So I dont know if there is anything I need to do to get Windows to recognise RAM above 2 gb (I am thinking of the 2 gb limit per process, which is obviously not the same thing but got me thinking) or if this is caused by a real problem.

    I ran memtest-86 and everything came up OK.

    Sorry for being such a n00b
  2. Ruder

    Ruder TS Rookie Posts: 98

    PC hardware specs?
  3. jonisaksson

    jonisaksson TS Enthusiast Topic Starter Posts: 83

    Sorry forgot to add that.
    My motherboard is a 939Dual-SATA2 (bios version 1.50)
    Processor AMD X2 4400+
    2 * Corsair TWINX2048-3200C2 DDR-DIMM 2048MB

    And the version of Windows is Windows XP Professional SP2
  4. Rage_3K_Moiz

    Rage_3K_Moiz Sith Lord Posts: 5,443   +38

    Maybe its ur CPU or mobo that doesn't recognize that much RAM. Does it show up when it POSTs? If not chances are that ur CPU or mobo is not recognizing the RAM. I personally think it the mobo.
  5. DragonMaster

    DragonMaster TS Rookie Posts: 327

    Can WinXP handle more than 2GB of RAM? Is it like Win98 that can work with 512MB max?

    I found a bit of info about the max. Windows can give to an app and it is 2GB. you can add the option /3GB /USERVA=2700 to your boot.ini file to give 3GB. I don't know if it's your problem or not tho.
  6. jonisaksson

    jonisaksson TS Enthusiast Topic Starter Posts: 83

    This is the strange thing, in post it shows up correctly as 4 GB.

    Memtest recognise it as 4 gb

    But in windows it says 2 gb....very strange
  7. DragonMaster

    DragonMaster TS Rookie Posts: 327

    And if, like I told in my last post, you add /3GB to your boot.ini file, does it see 3GB?
  8. jonisaksson

    jonisaksson TS Enthusiast Topic Starter Posts: 83

    Hi, i tried the pae setting but that didnt make any difference. Which is not so surprising.

    I had the suggestion from one guy to look in msconfig and make sure the /maxmem setting wasnt set to a value.

    It wasnt but the highest value I can set it to from within Windows is 2048, which is exactly what I am seeing.
    But I guess that could just because that is the "available" amount of memory to Windows
    Or should I go in and manually add a line to boot.ini with /maxmem=4096 ??
  9. jonisaksson

    jonisaksson TS Enthusiast Topic Starter Posts: 83


    Now this problem is starting to really drive me mad.

    If I run msinfo32, it says that my total physical memory in the machine is 4096 Mb so it clearly "knows" it is there but Total available is 1,66 Gb.

    I found this article on MS webpage, so I shouldnt expect to see all 4 gb. But there is still something weird going on as I should see 3 gb at least
  10. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    It's a feature in 32-bit XP.

    XP x64 would display it fine.
  11. jonisaksson

    jonisaksson TS Enthusiast Topic Starter Posts: 83

    Yes, but if I understand the article correctly I should still see at least 2,7 gb not 2 gb, correct?
  12. jonisaksson

    jonisaksson TS Enthusiast Topic Starter Posts: 83


    Just to let you all know, that I reported this problem to Asus and after a lot of emails back and forth it turns out it was a bios defect. So they sent me a fix which resolved the issue
  13. Obscura

    Obscura TS Rookie

    I am having a very similar problem. I also have a new ASUS motherboard. The A8N-SLI premium. I have 4 x 1Gb DDR400 memory modules. I can see 3Gb, but the system utilities and MB say 4096 Mb. Can you please let me know what they told you, or at least who you contacted.

    Any help is much appreciated.

  14. jonisaksson

    jonisaksson TS Enthusiast Topic Starter Posts: 83

    Obscura, this is not the same problem. At least it doesnt sound like it.

    If you read through the thread you will see the answer to your question is here

    If I have misunderstood you problem my apologies, but yours basically sounds like the Windows XP 32 reporting of memory problem, which is just a display issue.

    If you see exactly 2 gb, then you have the same problem we had which has been resolved by a bios service fix. This service fix isnt public yet

  15. Obscura

    Obscura TS Rookie

    Okay thanks anyway.

    Mine shows 3 Gb, with that address extension thing on.

    I am upgrading all the Bios's and drivers and chipsets etc... just in case.
  16. Wim

    Wim TS Rookie

    4 MB showing as 3 MB in WinXP 64bit


    Did you already find a solution to your problem ? :confused: I have the same motherboard and the same problem. I'm using Dane Elec Memory though.
  17. Obscura

    Obscura TS Rookie


    The guys from ASUS reckon that it is only solvable by upgrading the OS to 64 bit. Which leaves me with a problem because it is very hard to get device drivers for sound card and games don't run well on Windows XP 64 bit. YET.

  18. Wim

    Wim TS Rookie

    3 MB while 4 GB RAM installed


    I have installed a multiboot system, but even under Windows XP 64 I see only 3 GB. This is when I have software DRAM remapping enabled in the BIOS. If I dare to enable hardware remapping, then my Windows XP 64bit system crashes while booting. :knock:
    If I put only 3x 1GB RAM in it, then it boots. I tried swapping slots for the Dane Elec memory already, and I use the standard (auto) BIOS settings for the memory timings. I tried upgrading to the latest beta BIOS 1011.001 without luck.
    any suggestions ?
  19. keese

    keese TS Rookie

    I heard you can open a folder in bitmap and do all this right?
  20. LinkedKube

    LinkedKube TechSpot Project Baby Posts: 3,486   +45

    My sysytem only recognized a little over 3G until I upgrade to xp 64, now it recognizes all 8
  21. nitaish

    nitaish TS Rookie

    Just add the /PAE switch in the boot.ini file and reboot the system. The system should then recognize the 4 GB RAM. It has worked for me on a windows system.
  22. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    This issue has been debated quite a few times (& in more recent threads than this zombie one) & you simply cannot use all 4GB of memory with a 32-bit Windows operating system no matter how hard you try. Use a 64-bit version & get it over with.
  23. robin_bga

    robin_bga TS Rookie Posts: 171

    Follow Mictlantecuhtli's and supersmashbrada advise.

  24. flycpd

    flycpd TS Rookie

    Hi there!

    The reason you only see 3 gigs in windows is that you are running a 32 bit OS. It has to do with memory addressing, but the short version is that any 32 bit OS can only see around 3.2 gigs of memory or in some cases as much as 3.5. To use all the memory you have installed you need to use a 64 bit OS (XP X64, VistaX64, or a Linux 64 bit if there is one).
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...