4gb sd card shows up as 1gb, please help!!?

By awsskater892
Mar 3, 2007
  1. Hi, Ive had this 4gb sd card for about 3/4 of a year and about a month ago it stopped showing up as 4gb, but as 1gb. I have windows vista, but also tried in xp, and recieved no differnt results. I can format it fine and everything, but when I format it, It only formats to 996mb, and I cant change it because tehre are no other options and I can not type it in either. If anyone knows of a free program that I could use to fix this, or a simple way. Ive also tried formating it in 2 differnt cameras (one a canon gl2 video camera adn the other a digital camera, dont know the brand). Thanks for the help! -Nick
  2. maniacgeorge

    maniacgeorge TS Rookie Posts: 19

    have you tried putting more than 1gb of stuff on it- it might work but display incorrectly.
  3. MetalX

    MetalX TechSpot Chancellor Posts: 1,388

    Yea, try putting more than 996MB on it. If that doesn't work, some of the internal memory might be broken, and only 1GB still works.
  4. conradguerrero

    conradguerrero TS Rookie Posts: 310

    I bought a flash mp3 player from hong kong that was hacked to show 4GB instead of what it actually had - 1GB. I used the faq at this site - http://www.mympxplayer.org/how-to-removing-memory-hack-vt2400.html There's a link to the program on the first post.

    Otherwise, sounds like a warranty issue and should be returned to the store.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...