56K Robotics External Modem Driver

By Mamut0o1 ยท 7 replies
Jan 17, 2008
  1. Hello, I removed XP from my PC and decided to Install Ubuntu and everything works good exept that I'm stuck with my external modem. This is a robotics model 5686 and Ubuntu for some reason is not seeing my device. When I do wvdialconf...I get no modems installed. Can anyone help me out and tell me if there is a driver or what I'm missing...I've been trying to resolve this issue for 4 days now; im sinkin here

  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    56K modems are cheap and nearly obsolete (except for paper faxing)

    Ask at the Ubuntu forum for a Linux capable 56K modem
    And remove yours from your system

    4days does not equal ~ $15
  3. Mamut0o1

    Mamut0o1 TS Rookie Topic Starter Posts: 45

    Thanks for the Reply

    I was hoping to get it to work but I guess your correct, I'm speding way too much time on this. The only reason I need a modem is to fax.

  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Bollocks. Serial modems are the most standard piece of equipment on the planet and they work with everything made from sth like 1970s. It's the internal "winmodems" that never work properly.

    Your assumption that every device needs to be "detected" is wrong. Just set up dial-up networking/faxing and give it the serial port device your modem is connected to (/dev/ttyS0 or /dev/ttyS1 most likely)
  5. Mamut0o1

    Mamut0o1 TS Rookie Topic Starter Posts: 45

    Admin>network configuration

    Nodsu thanks for your help, I already tried to setup a dialup configuration using Admin>network then setting up a "number" using /dev/ttyS0 and I also tried /dev/ttyS1 and it didn't dial at all. is there a file I can vi and get this done...it's the first time I install an external modem and I'm a little bit lost.

  6. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Obvious things first.. Does the modem even work? Did it work in Windows and is it connected exactly the same way as before? Is it turned on? :p

    Then you could check if your serial port is detected at all by Ubuntu and what device node it gets. See the output of the dmesg command. It should say something about /dev/ttySX where X is a number. Might detect it as a /dev/modem device too.

    Install a program called minicom. This will let you talk directly to the modem and see if it responds at all.
  7. Nodsu is 100% correct. You don't need a driver for a serial modem, as effectively Linux deals only with the COM port and sends standard commands to the modem through that. It's ages since I've used a 56K modem of any kind but I remember buying my Hayes 56K specifically for Linux at the time, because the rubbishy winmodems wouldn't work. I think I just used ppp or a gui front end for it (kppp?) and simply set up my connection and used /dev/ttyS0.
  8. Mamut0o1

    Mamut0o1 TS Rookie Topic Starter Posts: 45

    Broken modem

    Nosdsu thanks for the advise; I plug in the modem into a windows machine and it didn't detech it eather so I returned the Modem and got another one so I did wvconfig and it came up as ttyS0 right away no drivers needed as you mentioned before. I was able to send a fax =) .
    thank you all.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...