1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

A7N8X-E Deluxe, Help!!

By engel_wolf ยท 16 replies
Oct 19, 2004
  1. I got my new A7N8X-E Deluxe mother board today, just finished installing it, but I'm not getting any video what so ever.
    I'm using an ati radeon 9700 pro, 512mb of ram and an athlon xp 2600+ cpu. I also tried a radeon 9800 pro, just incase, also no video. Does anyone have any idea what could be wrong? Thanks.
  2. Justin

    Justin TS Rookie Posts: 914

    Any beeps? (I'm assuming you have it plugged into the case speaker) Tried reseating the RAM and video card? Also, double-check the jumpers on the motherboard and also try closing the "Reset CMOS" jumper, leaving the machine unplugged for 30 seconds, then moving the jumper back.
  3. bones

    bones TS Rookie

    providing you have the bios version 1.70 and not below this, you can rule out the bios being the problem, if it is below 1.70 goto the link below this will fix the said video card you are using.

  4. Didou

    Didou Bowtie extraordinair! Posts: 4,182

    Hmm, he's not using the ASRock K7S8X to which you linked Bones.

    The first time I installed my A7N8X Deluxe the ClearCMOS jumper was actually set to Enabled. I overlooked it while looking for the problem & when I finally decided to do a ClearCMOS, it's only then that I noticed it was already on the Enabled position. I got lucky I didn't fry the motherboard, for Asus says turning the system on with the ClearCMOS set to Enabled should fry it.

    I set the jumper to Disabled & like magic, it powered on without a problem.;)
  5. engel_wolf

    engel_wolf TS Rookie Topic Starter Posts: 24

    Yes, I have tried the ClearCMOS jumper and re checked all other jumpers. I have also tried removing and reinstalling the gpu, cpu and ram, still nothing, not even a beep.
  6. Didou

    Didou Bowtie extraordinair! Posts: 4,182

    Have you tried removing the motherbord from the case & getting it to power on outside the case ? It could be that the motherboard is grounded with a bad contact somewhere.
  7. bones

    bones TS Rookie

    sorry mis read the model number wont happen again. :knock:
  8. engel_wolf

    engel_wolf TS Rookie Topic Starter Posts: 24

    I will try removing it from the case and powering up.
  9. Damins

    Damins TS Rookie

    Sounds alot like ya might have gotten a DOA board :(
  10. xtrmn8r

    xtrmn8r TS Rookie Posts: 51

    can we have some more details on the ram? the a7n8x is very specific when it comes to which ram it will work with.

    if not, see if you can get a replacement under warranty :(
  11. engel_wolf

    engel_wolf TS Rookie Topic Starter Posts: 24

    The ram came as part of a package deal with an Asrock K7S41GX I have, 512 DDR 2100. I'm mostly sure it should work in the Asus... Am I wrong? Please let me know if I am, it will save me the cost to ship the board back. Thanks.
  12. Didou

    Didou Bowtie extraordinair! Posts: 4,182

    Your 2600+ which very likely used a 166mhz FSB, will need at least PC2700 Ram to function properly. PC2100 is meant to be used with CPUs using a 133mhz FSB.

    Have you tried powering on the system without the Ram to see if you get an error beep ?
  13. Charles Hammond

    Charles Hammond TS Rookie Posts: 57

    To reset the BIOS on an A7N8X-Deluxe you have to remove the battery according to the manual. I have the A7N8X Ultra 400 and that is what my manual said.

    Often when a motherboard will not disply anything on the monitor it is due to grounding.
  14. engel_wolf

    engel_wolf TS Rookie Topic Starter Posts: 24

    I tried removing the battery, and I also tried running the board out side the case, nothing worked, I sent it back and am waiting for a replacment which should be here any day now. Thanks.
  15. Ares

    Ares TS Rookie

    Initial install

    I posted earlier regarding a problem installing this board with an AMD 3200+ Barton chip. The install went smoothly but when I went to install XP Pro, I hit a wall. The machine started up with a single beep, yet seemed somewhat slow in detecting drives. I get a nice looking Asus screen with the graphics on it and the post (tab) command. It lets me access the menu where I can change all the settings and save, yet I cannot run a disc.

    I haven't gotten around to stripping it down to the bare essentials and booting, but I think I need to do that.

    I am not savvy to computer acronyms and such, yet confidant that my problem is simple to fix. I hate to think that the components I bought are not proper.

    Please help so I can go about gaming on this machine like I thought I could!
  16. Ares

    Ares TS Rookie


    I replaced the Hard drive I got from newegg with another 80 gigger I had. Machine is up and running. Whew...

  17. engel_wolf

    engel_wolf TS Rookie Topic Starter Posts: 24

    I got the new mobo today, and its working just fine.
    On a side note, when I bought this computer, it was supposed to come with an AMD Athlon 2800+, but the ASRock K7S41GX has always been reading it as a 2600+. I always assumed that the people I bought the computer from just put the wrong CPU in, but now the A7N8X-E Deluxe is telling me that it is a 2800+. Why would the ASRock mobo be reading the CPU wrong? Its BIOS is flashed to V1.9, which is the newest there is...
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...