Abit AN8 'Fatal1ty' Mobo Technical Help

Jun 22, 2005
  1. Recently i attempted to build my new system. The components i added were:

    a) Geforce 6800 Ultra
    b) AMD Athlon 64 3700+
    c) Abit AN8 'Fatal1ty' Motherboard
    d) Antec 550w PSU

    Ok once i had finished assembly, i tried to power up, pressed the power button.... and nothing happened. Checked everything, and found out there are several LED's on the motherboard that indicate main power. These were not light up. So i took out the psu and replaced it with an older 400w one. Ok good job, its powering up now.... interesting... there is no signal comming into the monitor.

    Consiering that it was only a 400w psu, on a seriously thirsty system i disconnected all but one of my HDD's and all my other devices, leaving only the GPU, motherboard cpu 1 HDD and a DVD reader.

    Hey Presto! We have an Image! WOo ok. Next i tried adding another HDD, and no image.. ok take it back to just one HDD... UH OH, no image now. So it worked before i attempted the second HDD, now it doesnt.

    Decided to go and purchase the crappiest cheapest PCI-E gpu i could find, cost me £27 lol! ok swapped my 6800 round with this new one, powered up, and it still doesnt work.

    What should i do? the only conclusion i can reach is that its the motherboard? I have reset the bios though so it can only be hardware related. One thing i noticed though, was that the Antec 550w psu was the new power type for servers, not the ATX needed by this motherboard, so that explains the origional psu not powering anything!

    Anyone got any suggestions? Will add updates as they come. This is killing me, BF2 arrives tomorrow and im not going to be able to use it ahh!

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...