Access denied to a folder merged with Partition Magic

By SDJM123 · 39 replies
Jun 3, 2003
  1. Im having this problem with one particular drive specifically after i merged two partitions together. My original configuration for the machine was my WD 80Gig that had Windows XP Professional on it and a WD 120Gig that had Windows Server 2003 Eval Edition. I had A LOT of crap on both drives and decided i was going to reformat both drives and start clean. I got through backing up most of it but then decided that i was just going to make a 40 gig partition on my 120gig drive that had Server on it. So I made the partition, dumped all the data that i wanted to keep onto it and decided to reformat both drives that had OS's on them. When it came to installing the OS's i decided to take a different approcach, I put the OS's on there own partitions, on just the 80Gig drive and decided i was going to use the 120 gig exclusively for data. I loaded back up partition magic onto the XP drive because you cant run it from server. Decided that i was going to merge the partitions back, it asked me what folder i wanted to put all the data that was on the drive into on the newly merged partition, it went all the way through no problems. Went to sleep and let it run, woke up this morning, the drives were merged i had all of my drive back in one, but........ the folder that i moved all the data to is giving me "Access Denied" errors, i right click on the folder and it tells me 0 Bytes as if nothing is in the folder, but if i click onto the properties of the drive it tells me that the drive still has 27 gigs used up, so i know the data is there somewhere i just cant get to it. I did a thorough scandisk and went to work and it ran, still having the same problems, I didnt want to really try anything else in fear of losing the rest of the data and not being able to get it back

    ANY suggestions would be much appreciated
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    "Access denied" would suggest that you are not using and administrator account or you have denied yourself (administrator) access to the folder.
  3. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    You might have corrupted permissions on the files and folders. Try taking ownership of them, and also removing and readding all of the security permissions.

    Right click, properties, security, should be. Might he hiding in XP (I am in Linux right now) but the security settings are there. Now, it will be something like this:-

    administrator FULL CONTROL
    everyone READ

    Make a note of all of the settings, remove them, apply, then open properties again and re-add all of the permissions settings. This should solve the problem I would think.

    Also, have you ran a good, old fashioned chkdsk?

    open command prompt,

    chkdsk c: /f

    where c: is the drive you wish to scan.

    Good luck.
  4. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Yeah, SDJM123, you ARE logging in as administrator or with an account in the administrator's group, aren't you?

    If not, you may find that the problem is that the data has no everyone permission on it. add one (full control is fine unless its data to which others you don't trust have access).

    This all assumes that your drives are formatted with NTFS, which I guess they must be for you to get the access denied message, but I could be wrong. If its FAT32 then there will be no permissions to set, only file attributes.
  5. SDJM123

    SDJM123 TS Rookie Topic Starter

    i couldnt have locked myself out because im logged in as administrator, plus im the only one who uses this computer so my user account is administrator, im going to try resetting the permissions and ill post a reply as to what happened
  6. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    best of british luck!
  7. SDJM123

    SDJM123 TS Rookie Topic Starter

    okay, i just looked at all of the permissions and everything is fine, there isnt a deny on anything, im on server now because in xp the security tab wasnt showing up and i couldnt remember how to make it appear, but again everything looks good, unfortunatley i left this out before, it doesnt just say "access denied" the actually box says Folder is not accessible - Access Denied, so im thinking that it COULD be a physical problem with the disk but i really hope not, if anyone has any more suggestions based on what i've done so far i would more then appreciate it
  8. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    OK, apart from CHECKING the permissions, did you REMOVE AND THEN ADD THEM AGAIN??? If you have corrupted permissions, just looking at them isn't going to solve anything. They may appear to be fine but are infact not right at all under the hood.

    Also, try running a chkdsk on the volume, with the /f flag used as I said in my previous mail.

    I don't think you can call it a physical problem just yet. It may in fact be only a smaller software settings glitch which you can fix. if there is file system damage, a chkdsk should tell you.

    NTFS is good at recovering from disasters, so please don't flip out and format the partition thinking that all of your data is lost, or anything. I don't think it is yet.
  9. SDJM123

    SDJM123 TS Rookie Topic Starter

    THANK YOU very much, I removed the permissions and added them again and it worked, once again thank you very much, i must say that I feel really stupid right about now since I just came home from an Active Directory class and SHOULD KNOW THAT PERMISSIONS CAN GET CORRUPTED. What im going to do right now is cut myself off from the world, and keep reading my book so that when stuff like this happens, I dont have to bother people I dont even know on a message board about something that I should have known better myself, lol. Once again thank you
  10. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    No problem. Glad that the problem was finally fixed.
  11. M@Xx

    M@Xx TS Rookie

    Access to PG Magic merge folder

    I've just signed into this group but I tell ya, I wish I had done it a few days ago. I have just fixed exactly the same problem, however, not the correct way (although now, I do know the correct way) anyway, just so you can have a laugh, here's how I fixed it.

    I left the "erge"created by PQ magic in the new partition (just in case) I also had a ack up ghost image sitting in the same partition. I was going through the motions of re-installing the image (via the boot disks) when I accidently clicked on my "merge" folder whilst browsing for the .gho file and guess what?....there sat all my data, all 30Gig of it... :D what I did was to make a ghost image of that partition, and then used the Ghost image browser to extract all my 30gig of data. A right royal pain in the *** but hey, at least I got all my vital stuff back. Lesson 1 Do not attempt to fix PC's at 2am when half asleep!! :mad:
  12. martellko©

    martellko© TS Rookie

    a BIG Thank You!

    Hey guys I'm so glad that I met this forum!
    I just had the same problem and I solved it only because of You!
    I'm so Happy! I did it in safe mode because I couldn't change the security settings otherway, but anyway...
    Once again Thank You guys!!! :bounce:
    What I'm going to do right now is go to bed :slurp:
  13. erniel

    erniel TS Rookie

    Thank you, thank you, thankyouthankyouthankyou


    I thought I had totally fubared my HD when I did the exact same thing as sdjm123...I was starting to accept that I would either have to bite the bullet and forget about my 45 GB of data or shell out $1500 for a professional data recovery service when I came across this page....

    I got access to my folder again and I'm sooooo happy!!!

    Thank you soooo much Phantasm66!

    I've learned my lesson...backup before doing anything in Partition Magic! :)
  14. IronDuke

    IronDuke TS Rookie Posts: 856

    Back up regularly NOT just before using PM.

  15. erniel

    erniel TS Rookie

    Ya, thanks Boots, I guess I should backup more often...I guess I didn't expect PM to be so flaky. Lesson learned.
  16. Alex Chelu

    Alex Chelu TS Rookie

    Thanks guys you just saved my live i was desperate i had merged partition and i was about lo lose 200 gb of data
  17. r68tgs

    r68tgs TS Rookie

    File Access Denied. You Do Not Have Permission.

    I recently copied files from my old Windows XP hard drive onto a new hard drive. Thinking I had all the files, I reformatted the old hard drive to use as a second drive for extra storage. Turns out, I didn't get all my files!! So, I downloaded a program to recover deleted files and was able to recover a .pst file (microsoft outlook email) from the old drive that I had erased. The problem is, I can't access the file or import it to Microsoft Outlook. I keep getting this error: "File access denied. You do not have the permission required to access the file."
    Does anyone have any suggestions? I can't seem to go back and grant access to the file. Thanks!
  18. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    right click on file, is the read only ticked ?
    untick it.make copy if you can change extension to .txt or try to import to firefox.
    may need to find a better recovery app.
    or the app may have been demo and will not let you use the recovered files.some of these demo's only let you view the fact they have recovered something
    or it could be a outlook encryption that only works with original computer ID that it was written to,I don't think so ,but with M$ you can never tell
  19. Risingphoenix

    Risingphoenix TS Rookie

    hi, Im in deep doo doo. Any devine beings able to fix this?

    I had the same problem as the first guy. I made a partition and dumped all my files in. I then created another partition so I could install another OS not using the option "partition for another OS". I then clicked on install another OS from partition magic. I realize that I needed to remove one of the partitions I created moments earlier. I have a 150 gig hard drive which was partitioned to 50/50/50 within 10-30mins. I dumped 20 gigs of data in 2nd partition and merged 2nd and 3rd so I could partition again from that 100gig to create another OS partition. I then realized that I couldnt access the files so in a scrabble to restore with the "restore" function from windows. This made it worst that I lost the partition magic 8 from my computer. I then did a few more restores but nothing. I gave up and merged the final 1/3 back to my 150gig hd. I then went to format my computer but I couldnt since my computer wouldnt recognize C: in dos prompt. I then went into fdisk and deleted the partition and formated again. I then found out I had 127gigs. I deleted the partition again with fdisk again, but I gave up and installed xp. It then hit me to read the manual of partition magic. I could have fixed it by undoing function from partition magic. Well that opportunity was gone since I formated, delete partition with Fdisk , reformated, deleted partiton, reformated again, and one more time to install winxp pro. I then went online to see if I can find some help and I came to this site. By god can anyone fix this. Sures a challenge. Please someone help me.

    Can this weirdiest problem be fixed? I must have been the first with this kind of problem.
  20. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    what is the problem ,again ya lost me
    are you trying to get data back or just access the drive???
  21. Risingphoenix

    Risingphoenix TS Rookie


    Yeah im trying to reclaim the data and fix the partition. please if you can help, please.
  22. Ruder

    Ruder TS Rookie Posts: 98

    Win XP has an issue with > 120 Gigs. Install Xp with SP2. To fix the drive - delete all partitions including the extended. Then recreate a primary only. Do a normal format - not just a quick.

    To recover the data ... there is a tool that can read data up to 7 levels deep. Get it, use it.
  23. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    I would try to use the recovery tool first
    see what it does or see's on drive
    O&O data recovery and file scavenger are my 2 top choices for middle range user
    there are more expensive sopis,, software out there with using high end algorithms.
    or if you had enough PM me
  24. Risingphoenix

    Risingphoenix TS Rookie

    I have a problem.

    I cant locate the missing files. Since I deleted the partition, my OS doesnt recognize the lost partitioned space. I had 150 gigs but now my computer recognizes only 127gigs. How do I recover what my windows OS doesnt recognize or have any idea about it?
  25. kurbads

    kurbads TS Rookie

    I also had problem with inaccessable folder. PQMagic complained about mismatching headers during merge process.

    What is the best way to "rapair permitions"? Windows help center does not have a word about "permitions". Maybe it is called "security" somewhere.

    Thats how I did it:
    I chose to share the invalid folder on network. When asked selected "just enable" filesharing. Explorer last time complained about denied access, but then displayed progress of doing something. And then folder became accesible. I just had to disable sharing again afterwards. I did it through network wizard.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...