Acer 5588-6432 laptop. USB mystery.

By jungleexplorer
Sep 20, 2007
  1. Okay, to says that this laptop is a piece of junk would be an understatement, but I spent $1100 on it so I have to try and make it work. I bought it in February and it has spent of 4 months with Acer's Tech Support (LOL! What a joke!). It has been back and forth from me to the support center 4 times. They actually broke the LCD and sent it back to me that way, TWICE!. I could go on and on about how bad Acer's tech support is, but that has nothing to do with this post. Well, I guess it does because the unit is still under warranty, but I would rather try and fix it myself than send it back to Acer and spend another 4 months of nightmares trying to get their monkeys (Techs) to fix it. I ended up fixing it myself last time anyways.

    Okay here is the problem. After much hassle (as you can see from above), I have finally got this system to boot up. It is running fine in all other respects but one, the USB ports. Now what makes this hard to figure out is that the USB ports are working, but only for certain devices. For instance, I can plug in an optical mouse and it will work fine. I can plug in a new external HD and it will detect it and install the drivers for it with no problem. But last night when I tried to install my canon i550 printer drivers, it does not recognize the device. All I get is an error that say "One of the USB devices attached to his computer has malfunctioned, or Windows does not recognize it". I have tried everything for hours and it will not install the print driver. Canon has an automated driver install program that you can run from their web site. I have run it 4 times. During the process it tries to detect the printer and tells you to plug the printer in and turn it on. I do this but the program cannot detect the printer no matter what I do.

    I have checked the device manager and the printer shows up as an "Unknown device" in the USB controllers section.

    The problem is that this is not the only device that has done this. There are other devices, all of which work fine on my desktop, that will not install on this laptop. The error is always the same and they all appear as unknown usb devices in the Device Manager. But at the same time, I can unplug them from the laptop usb port and plug another device in the same port and it will work fine.

    This is very frustrating. If I had not wasted $1100 un this laptop I would throw it in the garbage. I bought it because it had a core 2 duo and 2GB of ram, but it runs slower then other models I have owned with far slow processor and way less memory.

    Anyway, if you could help me solve this problem I would be very grateful and maybe help me resist the temptation to get my 12 gauge and shoot this thing.
  2. lamo

    lamo TS Rookie

    try to upgrade BIOS to a newer version. may be they will fix these problems.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...