ActiveX Madness: Spread your knowledge

By Vigilante ยท 8 replies
Feb 4, 2006
  1. Everybody knows IE sucks right now. Stay away, use something else. Use Firefox. But the one redeeming feature of IE, and in the same respect, its one destructive feature, is ActiveX control support. The proprietary technology MS thought was so cool.
    Well thanks to it, we get cool online tools like Windows updates, and online-based virus scans, games etc... However, this is also usually the number one way viruses and spyware get in your machine. Thus you want to use a NON-activex supported browser for 98% of your web browsing.

    In my experience, when I see a PC that is infected/infested with some kind of crapware, the first thing that gets screwed up is ActiveX support in IE, thus stopping me from doing online virus scans, windows updates, and so forth.

    I have just a couple tools for fixing AX, and they have worked thus far for the bulk of cases, until now.

    I have a simple batch program, which uses regsvr32 to reregister a handful of DLLs related to Activex and cryptography and so forth, which fixes ActiveX 95% of the time.
    If that doesn't work, I have another script with basically runs IE.inf from the %win%\inf folder. This will reload IE from the XP CD itself. Which usually fixes IE, or at least lets me run the AX fix batch.
    In extreme cases, something will be wrong with a security certificate, or the cryptography service is screwed up, or something to that effect.

    But now I've come across a system, which makes me think it's time to upgrade my ActiveX related tools. The system had viruses, spyware, the usual drill. It has NAV2005 which is now up to date. But IE, which works for everything BUT Activex. I've done all the stuff I know how to check this and that and the other.
    IE is acting like it can't even process ActiveX. There is NO SP2 drop down box, there is no error messages, there is NOTHING. It simply doesn't do anything at all.

    Refer to this page:
    This tests your browser ActiveX support. When the box pops up to allow the control (which doesn't pop up for this one), click NO or cancel. The page will then say "ActiveX is not supported". This is what IE does on this other PC. It shows that immediately, with no error, warning, popup, block, nothing. The security settings are fine, I've checked all kinds of IE settings. I've reloaded IE through control panel. I've A small handfull of things that usually work in most cases. But it would seem now the story goes deeper.

    So the question becomes, what is the best way to troubleshoot ActiveX problems? And how can you RELIABLY and FULLY reload IE? Because I find it interresting, if you use control panel windows features and UNselect IE, it will unload then ask to restart. Upon restart Windows says "IE has been removed..." But if I try to run IEsetup from a download, it will then say "You have a later version of IE installed..." Hmm, XP said IE was gone, how can I have a more recent version installed? Typical MS lies.

    Needless to say, ActiveX is toast in IE, reregistering DLLs and reloading IE doesn't do anything. My googling isn't turning up much. What I'm looking for is a script or program which "knows" all about Activex and can search the registry, services, dlls, check version numbers, and so forth, to find any problems. And be able to fix them.

    So then, what say you? Or what should I check to AX working again? Note that I'll probably fix this before I get any responses, but I'd still like to know of any tools you guys have or use when ActiveX is being screwy. thx
  2. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    Note also that "secure" pages work fine. Encryption is set to 128bit, you can view any https site.
    Also, the "infobar" does not pop up for anything, it also seems to be just gone. As part of AX I'm sure.

    I'm currently checking for any rootkits.
  3. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    no rootkits
    removed all Norton
    installed Internet Explorer 7 beta 2 hoping it would fix something or work. It took forever to install when it reach 45-55%. But IE7 does exact same thing, which is a big NOTHING!
    This is starting to make me mad. I did a search on the Microsoft knowledge base just for "activex", reading every article that had to do with problems, nothing at all lead me anywhere. And just about every solution on the net starts with "go into internet security settings, find enable activex script". Like duh. What else is new? Doesn't any place have any advanced solutions for when IE doesn't work?
  4. iss

    iss TechSpot Chancellor Posts: 1,994

    The only method I know of for repairing IE is to run System file checker.

    if that doesnt work there is a method for uninstalling IE so you can download and reinstall it.( I havnt tried it mysefl so I cant verifiy that it works.

    Start the Registry Editor
    Go to HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Active Setup \ Installed Components \ {89820200-ECBD-11cf-8B85-00AA005B4383}
    right-click the IsInstalled value, and then click Modify
    Change the value data, from 1 to 0
    Close the registry editor
    Download and install Internet Explorer 6.
  5. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    Still no luck. I'm pretty sure SFC has been run more then once. 3 techs have worked on this PC so far and no one can fix it.

    As for the registry key, that is one of the things my "script" does, along with the IE.inf file. The problem there was that, when XP went to "reinstall" IE, it would ask for the "Windows XP Home SP2" disk. However, it would not accept ANY disk I put in there. It would just say it's not the right disk. I tried like 6 CDs. I copied the i386 to the hard drive and it still wouldn't take it. I can't tell you how frustrating THAT was! I HAVE the right friggin disk! Stupid XP.

    Since last post I have reloaded Java, the Windows scripting host, VB runtimes, SFC. Uninstalled 3 more applications on there PC. Nothing worked, no change whatsoever.
    Well I take that back. In IE7, on 2 pages, I got the info bar saying that some page may need "msxml" so I said yes. Some other page said that it need the microsoft certificate authority or some dll.
    Neither seemed to do anything, load anything, say anything, install anything. Nothing, no change. Activex still doesn't do squat.

    I'm at my wit's end here.

    What exactly 'IS' activex anyway? Surely it must be in some dll or dlls someplace. Surely there must be an "installer" for it, as it is a standalone technology not necessarily just a part of IE.
  6. iss

    iss TechSpot Chancellor Posts: 1,994

    From what I have seen and read "activeX" is so deeply intertwined with widows it is virtually impossible to remove it. what few apps that are available will only remove or temporarily disable a particular active X control. I have never run across anything that functioned on the actual Active X component.
  7. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    Oh I will figure it out! Rest assured. I heard about this technique where, if you take the pc and put it on the road, some traffic will squash the bugs out!

    If it helps in research, I believe the "main" virus that started it all was "Vundo". Not sure if it's W32 or Trojan or what. But that is what he originally thought it was, and downloaded a Vundo fix program from Symantec. But it didn't fix it.
    Though earlier I ran that program and it said it found 1 process! Not sure where this is leading, but it sure ain't helping Activex any.
  8. iss

    iss TechSpot Chancellor Posts: 1,994

    I hear ya. I have run into more than a few machines that is what I wanted to do with them.

    there is another Vundo fix out. it's on the front page of majorgeeks (yesterdays downloads) might want to give it a whirl.

    I think you have reached the point where your client has about two choices, a complete reformat and reinstall of windows, OR that nice little custom windows boot screen that says....Please wait windows is crashing.
  9. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    Finally fixed this son of a motherless goat.

    The last SFC that I ran didn't do it. Neither could I finish an offline virus scan from housecall. So I finally gave up and tried a Repair install, hoping for the best.

    During the install, as I feared, it popped up saying it couldn't copy this file and that file and there was about 15 files all together it failed to copy. I had to cancel them, not knowing if they were bad or good files, oh well, hope for the best.
    When it finished and restarted, XP didn't load, it just staying at the loading screen with the progress bar and I had mouse movement, but it never did anything. Had to hard reset it.
    But that time it did go in, I could log in. At first, all looked well. The IE icon on the desktop was the IE6 style not IE7 which I loaded, so I figured it reloaded IE6 of course. I ran IE but it popped up an error in wininet.dll. CRAP!
    So I checked that file, it was good. Then I checked IE and it seems that, while IE6 was reloaded, the IE7 executable was still the main one. So I replaced iexplore.exe off the XP CD.
    I then ran my activex fix script again (which just reregisters about 8 dlls). And ActiveX worked again!

    So anyways, haven't heard back from the customer so that's a good sign. And to think it was all very likely caused by just some dll somewhere. But who knows which? Stinkin Windows :(
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...