Tech Stocking Stuffers: 18 awesome gifts under $50

Add/Remove programs not displayed correctly - Win2K

By GeForce
Oct 5, 2002
  1. Apparently, being ignorant, I didn't notice until recently that my add/remove programs in the control panel went kaput... now I've lost the ability to uninstall many of my prog's automatically, through this panel.

    Error message: "An unexpected error occured. Class not registered. res://appwiz.cpl/ line 225."

    I've tried fixing the applet through REGSVR32, as well as check the registry for any missing values; tried filling in the values as directed from M$'s site, but it didn't work either. 'Upgrading' my current 2K Pro configuration over another didn't even help either. If anyone can point me to the correct registry settings, in the form of a config file, that would be swell. :)

    thanx in advance
  2. Tarkus

    Tarkus TechSpot Ambassador Posts: 621

    Well if you tried the KB article at;EN-US;Q266668& and it didn't work you can try to repair your Windows installation with the Windows 2000 CD. Skip over over the first Repair option (that one is almost useless) and continue to install windows 2000, select to install it in the original directory. you will then be asked if you want to install a fresh copy or repair the original installation. Select repair. You will lose your SPs and Hotfixes but it should keep all your programs and their registry entries, with the exception of MS Office. (It won't work at all after this. You also won't be able to uninstall or reinstall Office.) To fix the Office problem you'll need to get 'Windows Installer Clean Up' to remove the old Office installation entries in order to reinstall Office.

    I've fixed many serious problems (that I've either created or had) in Windows 2000 this way. It seems to work as well as a total reinstall and takes much less time.
  3. uberkiwi

    uberkiwi TS Rookie

    Problem caused by missing MDAC files

    I also had the error

    Class not registered

    Following MS support note Q266668 I found that these files did not exist:
    Program Files\Common Files\System\Ole DB\Oledb32.dll
    Program Files\Common Files\System\Ado\Msado15.dll

    I downloaded and installed MDAC 2.8 from and problem was solved.
  4. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    Thank you very much for posting your solution. It will help others in the future.

    :wave:Welcome to TechSpot:wave:
    Hope to see you around TS ;)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...