Add/Remove programs not working

By KentGOP ยท 38 replies
Jan 13, 2005
  1. I just did an HP System Restore on my computer and I want to get rid of a lot of the factory installed programs that I don't use. Only problem is when I open add/remove programs, there is no way to remove programs. On the right side, it just shows how often the programs are used; it doesn't give me the option to remove them. Any ideas on how to get it to work the right way and I'm hoping I don't have to run restore again...Thanks a lot for your help.

  2. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 3,874

    Is it as simple as clicking on a file? If you just look at the initial screen there is no change/remove button. You have to click the line first.

    :wave:Welcome to TechSpot:wave:
  3. KentGOP

    KentGOP TS Rookie Topic Starter

    not that simple

    I clicked on the different programs and it still doesn't show the add/remove option. It just shows me how often the program is used. Thanks for your help,

  4. Paul

    Paul TS Rookie Posts: 56

    I dont know the programs you have installed but it sounds to me it does not have an uninstall on the program or it is not registered,You have to manually remove these your self.
  5. KentGOP

    KentGOP TS Rookie Topic Starter

    manual removal

    There's no add/remove option for any of the programs that are installed; even the factory ones. I'm not going to worry about it for now, I think eventually I'll have to reformat again, but for the meantime, could you explain how to manually remove programs? Thanks a lot for your help,

  6. Paul

    Paul TS Rookie Posts: 56

    This how to do manually remove programs in xp.

    Click Start, and then click Run box.
    In the Open box, type regedt32, and then click OK.
    In the Registry Editor, locate the following registry key:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall ,In the left pane, click the Uninstall registry key, and then click Export on the File menu. ,In Export Registry File dialog box that appears, click Desktop in the Save in list, type uninstall in the File name box, and then click Save.
    Each key listed under Uninstall in the left pane of Registry Editor represents a program that is displayed in the Currently installed programs list of the Add or Remove Programs tool. To determine which program that each key represents, click the key, and then view the following values in the details pane on the right:DisplayName: The value data for the DisplayName key is the name that is listed in Add or Remove Programs.UninstallString: The value data for the UninstallString key is the program that is used to uninstall the program.
    After you identify the registry key that represents the program that you removed but which is still displayed in the Currently installed programs list of Add or Remove Programs, right-click the key in the left pane of the Registry Editor window, and then click Delete.
    Click Yes in response to the "Are you sure you want to delete this key and all of its subkeys?" message.
    On the File menu, click Exit to quit Registry Editor.
    Click Start, click Control Panel, and then click Add or Remove Programs.
    In the Currently installed programs list, verify that the program whose registry key you deleted is no longer listed.
    If the program list is not correct in Add or Remove Programs, double-click the Uninstall.reg file that you saved to your desktop in step 5 to restore the original list of programs in the registry.
    If program list is correct in Add or Remove Programs, right-click the Uninstall.reg file on your desktop, and then you can click Delete.
  7. anoblenate

    anoblenate TS Rookie

    add/remove programs as gone crazy for me, too

    i was away for a few days. shortly after starting up again i went uninstall some software, but the option to change/remove them in my add/remove programs listing disappeared. every program listed is now missing that button and it seems some programs are not listing, as well. It worked fine before i left because i was clearing out some old, unused programs.

    i searched a little bit and came across a similar post where someone mentioned a 3rd party add/remove tool ( it displays itself and macromedia shockwave as the only installed programs. The regular XP add/remove shows the change/remove button as well for only those 2 programs.

    I tried a system restore to no avail, and ran updated spybot, adware, and avg to see if any bugs are onboard, but all is clean.

    this is quite frustrating, but i can do the manual way until i'm ready to reformat. i wonder if my registry got screwed up, or something similar. i don't have it backed up right now, though... : (
  8. mraymus

    mraymus TS Rookie

    Add Remove Programs menu items missing

    I am seeing a similar problem. I've been having a Symantec install/uninstall problem from hell. I had Norton 2005 installed and then installed Symantec Small Business on my server and it went out and trounced on my Norton so I couldn't uninstall it. So, I went to install 2005 again so I could uninstall it and it said it couldn't install it until I got rid of the small business version! Ahhhh! So, I uninstalled the server version, reinstalled the client version, and then when I went into Add/Remove programs, everything was whacked.

    ***This is where the real problem begins*****
    When I go to Settings, Add REmove programs, all the contral panel buttons are squished up on the left hand side of the window with a scroll button right down the middle. So, I thought, that's wierd and I clicked on Add Remove Programs and when it came up, all I saw was the text that is usually along the left hand side, all across the top, and nothing below that. Just an empty box. So, I've got 2 problems. 1- I can't uninstall Norton piece of doodoo and 2-I need to get my add/remove programs window back!

    Any suggestions?

  9. mraymus

    mraymus TS Rookie

    reply to self

    By the way, I saw on another board that if you have items that are more than like 62 characters it does this, but 1. I looked in my registry and couln't really tell if there were any menu items there that were too long and 2. It was working just before I installed NOrton Antivirus the 2nd time. In fact it was working fine when I installed NAV the 1st time. Why would control panel and add/remove programs all of a sudden dive off the deep end?
  10. smatty

    smatty TS Rookie

    On launch add/remove control panel (WIn XP Pro, SP2) the list of apps is present, but only programs installed roughly after June have the button to remove them. There is no list of the XP updates or service packs in the list however.

    I remember there were windows updates around that time (June) that I installed. (Windows Malicious Software Removal Tool and Security Security Updates)

    I do not see the manual regedit as an acceptable long term solution. Anyone heard from Microsoft on this? Any solutions to get my uninstall CP to work the way it should? Thanks!
  11. dpc1l

    dpc1l TS Rookie

    Remove button disappeared


    I've just discovered the same thing on my computer. I uninstalled some applications yesterday, but now no programs in the "add/remove programms" box have the uninstall button. This wasn't the case yesterday.

    Any ideas what's happened?
  12. smatty

    smatty TS Rookie

    re: Missing uninstall button

    I finally wiped the system and started over. It did not seem evident that there was a systematic solution that would solve the issue.

    I would just be diligent to create restore points before patches and application installs, and to check that control panel to see if the prob happens again, so I can rollback before too much time passes.

    Good luck. Perhaps some entrepreneur can create a utility to simplify the manual registry edits!
  13. scronk74

    scronk74 TS Rookie

    Same here

    Wow..i never would've thought this many people are having the same problem as me..i.e. no option to remove any of the programs listed in myadd/remove programs list. I have tried a CD restore as well as XP System Rollback, and didnt fix it. I guess I had the problem before i created those silly system recovery CD's. Looks like this has been going on for a while and no one has a fix..or if they do they have not posted it yet.

    My guess is that there is a software conflict between some application we all have in common and the Window's programmer uninstalller. Let's see if we may be able to come up with a few commonalities and come up with a fix of our own.

    Here are the specs on mine:
    PC Manufactuer: HP Pavillion
    Operating System: WinXP Media Center Edition Version 2002 SP2
    Anti-Virus Software: Norton AV 2005
    Firewall Software: Norton FW 2005

    Norton System Works 2005
    Office XP
    WD External USB Drive with RetroSpect as sync software
    MicroSoft ActiveSync 3.8.0

    Here is a template you can copy/paste and post your pc specs and help everyone else out.

    PC Manufactuer: {i.e. Dell, HP,...}
    Operating System: {i.e. Win XP Home Edition Service Pack 2}
    Anti-Virus Software: {Norton AV 2005, McAfee, EZ AV}
    Firewall Software: {Norton FW 2005, Black Ice v3.6.7}
    Other Applications you can think of that you think may have caused this.
  14. Surendipity

    Surendipity TS Rookie

    Add/Remove woes

    I'm wary of Norton, or a bug that has attached to Norton.
    Also wary of uninstalling via the registry which could cause other fatal errors to occur. You should have alot of technical savey before attempting any changes in the registry.

    Also wondering about a virus that has attacked the system and is waiting for me to delete the files to which then creates the bug to drive forward.
    Like turning the GO on when you delete the programs manually.

    They can sit there for all I care for eons. If it aint broke dont fix it.
    I have a ton of memory so no worries.

    But in the end, Norton seems the number one suspect.
  15. ignacio_p

    ignacio_p TS Rookie

    Same Problem

    I have exactly the same problem with the remove program button,... and its impossible to remove Norton, im gonna format, and never use norton again
  16. Surendipity

    Surendipity TS Rookie

    Norton hear's a What?

    Norton sucks. I think the people working at Norton are as outdated as their program. MacFee is best all round, but my service Provider has virus and antispam ware for free. So it works great, catches tons of stuff.
    And there is tons of it out there.

    Norton never fixed anything ever, nada.

    There is a program that you can download to help you fix Norton so you can uninstall it. Many people like myself couldn't uninstall it. Another fancy Norton trick...

    Anyways, I forget what it was and I've cancelled the ex.but you can search for "norton uninstall fix"

    Most service providers have there own for free now because people were complaining. Most people don't know it because they don't read there SP email.

    Try you SP and dump Norton.

    Good luck
  17. N3051M

    N3051M TS Evangelist Posts: 2,094

    i'd agree that norton sucks.. but anything pre-2003 era is still good, as well as corprate versions as told by other members... they did get older, but not wiser...

    get rid of norton, download AVG Free, Sunbelt Kiero Personal Firewall, and Spybot/Adaware and you're set for life (of the pc :D)...
  18. Char_X

    Char_X TS Rookie Posts: 170

  19. WinDoWsMoNoPoLy

    WinDoWsMoNoPoLy TS Rookie Posts: 237

    Norton always has something wrong with their programs. Remember Norton Crash Guard? Lmao.
  20. wiresnagger

    wiresnagger TS Rookie

    I find it odd that this is happening to so manny people, including myself, right before the release of "Windows Vista"

    I have had this problem with the no "Add/Remove" buttons for quite some time (2 Months). I have no clue on how to fix it.
  21. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,231   +234

    I always hear this complaint, "Norton Sucks"... Why is it that I see crashed systems that were using AVG, other firewalls, and Adaware and Spybot all the time! Why? Because NO protection programs/schemes provide 100% safety!
  22. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 21,238   +17

    Hello and welcome to Techspot.

    That`s a nice conspiracy theory,;) but I believe the problem of missing change/remove buttons in the add remove programmes applet, goes way back, at least to Windows 2000 and possibly beyond.

    A possible fix for this can be found HERE.

    Regards Howard :wave: :wave:
  23. Sjbrand99

    Sjbrand99 Banned Posts: 260

    Still stuck (or just for searching reference).

    1.) Go to your /WINDOWS/Resources/Themes directory, or wherever you may have your themes located.
    2.) Go into the directory of the theme your currently using.
    Example: Using 'Semplice' by KoL? Navigate to /WINDOWS/Resources/Themes/Semplice
    3.) Go into the folder called 'Shell" within the previous directory.
    4.) Inside you'll find a folder with a file called 'shellstyle.dll' inside. Now remember the name of the theme your using? (Example: Semplice). You need to rename this folder from Shell to the name of the theme your currently using. If you don't know the exact name, go to Display Properties, and try to Display/Show the theme, the name you see in Display Properties is the name you need to change the 'Shell' folder to.
    Example: Using Semplice as an example, the Shell folder for that theme is called 'Shell', in this situation you'll need to rename the folder to 'Semplice'. Easy enough, right?
    Note that for multi-part themes, aka themes with more than one variation or color, you'll need to rename each corresponding 'Shell' folder to what is displayed in Display Properties when you try to apply the theme.
    5.) Now that you've changed the 'Shell' folder name to correspond with the visual styles name, reapply the theme.
    6.) Go to Add/Remove Programs, and voila!

    Not my work don't give me any TechCred.
  24. wiresnagger

    wiresnagger TS Rookie

    Tried and success!!!!! thank you so very much.
  25. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 21,238   +17

    That`s great news.

    May I ask for future reference which fix worked? Was it the possible fix I gave or the fix Sjbrand99 gave you?

    Regards Howard :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...