Add/Remove programs problem

Status
Not open for further replies.

fanuilos

TS Rookie
Hello. I cannot see my installed programs in the Add/remove programs window. I see there only a list of 10 rarely used programs, the change/remove button is missing and proper icons, too. I tried restore point and everything was allright, I saw all my programs again, I could Add/remove them, but after a while the list was incomplete again. I use Windows XP Home.
Thanks a lot for help,
Michal
 

Sjbrand99

Banned
Could you tell us which programs they are that are doing this. Obviously we need to know what they are before assessing your problem.

Cheers
 

fanuilos

TS Rookie
I've attached the picture of the add/rem list. I mean I cannot see any programs (installed on my computer) on the add/remove list except for those you see on the picture .
 

Attachments

zerocoolzz66

TS Rookie
The only thing I can think of that is causing this problem to occur is a virus of some sort, or spyware. So I would try running your virus scan and spyware scan in safe mode, after updating of course.
 

Sjbrand99

Banned
Have you ever had any other programs installed. Sometimes uninstalling them can leave bits behind that cause problems. And if not, than this is also a problem for it leaves you open to viruses and you have no firewall. You are using software but it is weak scanning programs that can be dodged, are free, and consequently are not very good. I am not saying dont use them, because I do, but you must get a decent piece of protection software.
 

alidabiri

TS Rookie
anyway.
do this:
find a file named: sysoc.inf. this file should be in the windows directory.
you will see entries like this:
Pinball=ocgen.dll,OcEntry,pinball.inf,hide,7
this line is for pinball. find your program name that's not showing up in add/remove programs. and delete the "hide" option. and make it look like this:
Pinball=ocgen.dll,OcEntry,pinball.inf,,7
make sure the two commas are present and only the word "hide" between them is gone.
good luck.
 

fanuilos

TS Rookie
I scanned with avast and found and removed Troj/Zlob-RM and his family. Then I followed the instructions in howard_hopkinso´s thread Viruses/Spyware/Malware, preliminary removal instructions and found no other viruses. But the problem is still there. I forgot to mention I use windows firewall.
I tried the suggestion with Pinball but I think nothing has changed. The only observation I´ve made is when I install a new program, it appears normally in add/rem window, with the right icon and the button change/remove.
The problem bothers me because it prevents me from uninstalling programs and I can´t do it manually.
Thanks for your help, michal
 

YairHoek

TS Rookie
i cannot offer u much help, except that using the windows firewall would protect ur computer as using firewalls such as ZoneAlarm, Outpost, Kerio, etc.

i suggest u d/l one of them and give them a try in protecting ur computer.
 

alidabiri

TS Rookie
i've had this problem with norton. norton will not let you "uninstall" their crap. to get rid of it, i had to find all references to it on my hard drive and delete them. then i had to go to the registry and delete any reference to them as well. only then, was i able to get rid of norton for good.
if you decide to mess with the registry, please back it up first. so, if you make a mistake and hose it, you can re-load the reg to its original state.
 

bloodyrose

TS Rookie
Hello, My add/remove button is suddenly missing tonight. I don't know if the fact that i removed the iexplore from my task manager. Does anyone know if that could be the problem, and how i might get the iexplore back into my task manager in case that would bring back my add/remove button? Or if you know a simple way to get back the add/remove button that would be great. I am not sure if i need the iexplore in my task list, does anyone know? My computer is so slow and i was unaware that once you take something out of your task manager you can't get it back, i thought i could just click a button and i could get it back but i guess i have deleted it. I am not a computer person so i hope there is somewhat a simple answer i can do to fix this. Thank you for any help!! Bloodyrose
 
Status
Not open for further replies.