Add Switch into Network

By Bloo Ice ยท 68 replies
May 2, 2005
  1. Hi. I have just set up my home for network. I ran 1 wire from the router to this room, where I have a computer, TiVo, and Xbox, all which I want to connect. I bought a Linksys 5 port switch. I hooked the wire comming in into the computer to test it out, and it works, connects to the internet and other computers connected to the router. Then, I unplugged it from the computer and plugged the incomming wire into Port 1 on the switch, and the computer into Port 3, TiVo into Port 4, and Xbox into Port 5. None of them can connect to the internet, my computer can't see the other computers, or even get an IP. It just defaults to the 169. The lights on the switch all came on, but the incomming from the router activity light is constantly blinking. What is wrong?
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Is it fast or slow blinking?
    If it's fast then it probably means data transfer and is normal. If it is slow then it means the switch is trying to establish a link but fails. You may have to use a crossover cable between the switch and the router to make it work.
  3. Bloo Ice

    Bloo Ice TS Rookie Topic Starter Posts: 63

    Its fast blinking, but it never lets up. I swapped the switch out and the router, and connected only 1 computer to start with. It couldn't get an IP or connect to the internet, so I tried a different one, same problem, then I tried them both, and same problem. I'm going to take the switch back today or tomorrow.
  4. dgower2

    dgower2 TS Maniac Posts: 238

    No Crossover Cables

    "Switches, hubs, and similar network devices are uplinked to your Switch
    with straight-through Category 5 cabling." From the user guide. Check if you have an uplink setting for the first port on the switch.
  5. Bloo Ice

    Bloo Ice TS Rookie Topic Starter Posts: 63

    I exchanged it for the same model. Brought it home, plugged it in, and the exact same problem. No IP, no internet, and the port the incomming [from the router] is constantly blinking really fast. I've tried different ports on the router as well, but nothing seems to work.
  6. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    check your nic cards to see if the values have changed
    This has happened to me when unpluging hot
    does the switch have a (switch for crossed connection)
    if using the 1st port to uplink to router do not use the uplink for anything and visa versa 1st port and uplink port cannot be used at same time.
  7. Bloo Ice

    Bloo Ice TS Rookie Topic Starter Posts: 63

    There is no switch. I am not using the uplink port. But when I tried it, I did not use port 5 [the one next to it]
  8. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    with all the network cables pluged in
    power down the router and switch ,if there is a reset button on router reset it
    turn the router on then the switch
    go to one of the pc's and type in the default ip of the router
    your manual should tell you the default password
  9. StormBringer

    StormBringer TS Maniac Posts: 2,244

    what model are these router/switches or whatever you have?
    You may need to set up port forwarding for TiVo, and I know that you will need to do so for X-Box.

    You may want to plug the router and the TiVo and Xbox into the switch, then the computers into the router. Then you will need to set static IPs for the router, Tivo and Xbox, you could then let DHCP handle the comps from the router.

    It would help greatly to know the model of the router and the switch, that way we could tell what features they have, such as whether the switch has its own DHCP server(some do, some don't) whether it has a separate uplink port(this was mentioned earlier) or if one port is used in uplink mode(would have to be set to do so)
  10. Bloo Ice

    Bloo Ice TS Rookie Topic Starter Posts: 63

    Router: BEFW11S4
    Switch: EZXS55W
    Samstoned, I'll try that when I get home.
    StormBringer, maybe I didn't understand your post, but I only have 1 cable coming into this room, that is why I got the switch. I have to plug the computer in this room into the switch as well, because I only have 1 wire comming in. I'm not so much worried about the TiVo and Xbox right now as the computer. Once I get the computer running, then I'll worry about the Xbox and TiVo.

    Again, thanks for all of your help so far!!
  11. Bloo Ice

    Bloo Ice TS Rookie Topic Starter Posts: 63

    I tried this, but it still didn't work. It goes to the Windows default 169 IP. I tried putting in the IP information still didn't work.
  12. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    hook direct to the router again(if its still working)you had mentioned it worked like this
    type in the address now (
    if you are on the net with this config you now should be able to get to the admin address of router.if this works find status write down the info from wan IP ,dns should be 2 sets of numbers check your default lan ip here as well
    go to Local Area Connection right click go to properties open you should see the nic card enabled here.
    right click go to properties go to tcp/ip highlight click on properties
    set the ip manualy last 3 digits can go to 250
    default ip is routers default
    use the dns numbers you got, put them in dwn below
    if you still cannot get into the router ,but you can get on internet
    the default ip has changed,I don't think unmanaged switchs can handle other
    internal ip address's I will check on this.
    when or if you have reset the router it should have gone back to this address
    I'm gonna have to build a pc with XP on it try blown it up
  13. Bloo Ice

    Bloo Ice TS Rookie Topic Starter Posts: 63

    I have all the information. I put the information in. If it's hooked directly to the router, I can get into the router AND the internet AND the other computers on the network. Then, if I go through the switch, it's back to not being able to access the router, net, or any other computers.
  14. jobeard

    jobeard TS Ambassador Posts: 11,166   +986

    uplink port required

    be sure that the cable FROM the router is plugged into the UPLINK port of the switch. The PCs can go anywhere ELSE.
  15. Bloo Ice

    Bloo Ice TS Rookie Topic Starter Posts: 63

    I tried go
  16. jobeard

    jobeard TS Ambassador Posts: 11,166   +986

    sorry; it sure works for me. can you ping both ways a-> and b->a?

    this has GOT to be a port blocking, dissimilar WORKGROUP name or malconfigured SHARES issue
  17. Bloo Ice

    Bloo Ice TS Rookie Topic Starter Posts: 63

    Nope, I can't ping anything from the PC connected to the switch, and I can't ping that PC with a different computer connected to the router. I don't have any port blocking on, since I've reset the router to defaults.
  18. REB_ElMagnifico

    REB_ElMagnifico TS Rookie

    Since this is an unmanaged switch...the symptoms mentioned make it seem like the switch has a defect. Try and isolate the problem to the switch. You said you have two computers right? Forget about the router for right now. Plug both computers into the switch. Manually assign the ip address on both computers...
    on the first pc: ip address =
    subnet mask =
    on the second pc: ip address =
    subnet mask =
    (if the ip address and subnet mask are a little different from what someone else mentioned...don't worry because a variety of ip address would work...for right now just use the ones mentioned on this post to prevent confusion)

    Leave the default gateway and dns server address blank for right now.

    When you have both computers connected to the switch and the ip addresses and subnet masks configured properly go to start-->run-->type "cmd"-->hit enter-->type "ipconfig"
    Here you just need to make sure the ip address matches the number you typed in before. If the ip address listed is the same one you typed in on that particular computer then everything would seem fine.

    Now it is time to test the switch...
    From the the first computer type: ping

    If you get a reply from then the switch is ok and the problem is elsewhere. If you do not get a reply from then tell us what it says when you try to ping that ip address.

    After knowing whether the switch is the cause of the problem (or not) we will be able to troubleshoot further.

    Good luck
  19. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You can easily detect if it is a switch issue with the arp command.

    Try to ping the other end. Doesn't matter if it fails.
    Then run "arp -a" and see if you have got the MAC address of the other computer listed. If yes then the ethernet layer (= the switch, cables, etc) is working fine and you have a computer configuration issue.
  20. Bloo Ice

    Bloo Ice TS Rookie Topic Starter Posts: 63

    C:\Documents and Settings\Brian>ping

    Pinging with 32 bytes of data:

    Reply from bytes=32 time=2ms TTL=128
    Reply from bytes=32 time=3ms TTL=128
    Reply from bytes=32 time=2ms TTL=128
    Reply from bytes=32 time=3ms TTL=128

    Ping statistics for
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 2ms, Maximum = 3ms, Average = 2ms

    I pinged my router
    Pinging with 32 bytes of data:

    Request timed out.
    Destination host unreachable.
    Destination host unreachable.
    Destination host unreachable.

    Ping statistics for
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss)

    C:\Documents and Settings\Brian>arp -a

    Interface: --- 0x2
    Internet Address Physical Address Type 00-06-25-e6-47-07 dynamic 00-e0-18-25-52-56 dynamic
  21. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Well, as you can see your router has responded to the ARP request giving you the MAC address matching its IP ( and 00-06-25-e6-47-07). This means that the ethernet works. Your cables are OK and the switch is working too. You have a problem with TCP/IP configuration or a firewall or routing tables.

    The TCP/IP configuration problem is quite apparent from the NICs IP address too - you have a 169.254.x.x addy there which just can not work if your other devices have addresses from another network.
  22. REB_ElMagnifico

    REB_ElMagnifico TS Rookie

    Have any of the default configurations on the router been changed? Usually a home router will come configured and ready to go. If any changes have been made, set everything back to default. And with all of the posts that have been made and the tests you have tried, it is hard to get a picture of what your network looks like currently. Can you summarize which devices are connected where, leaving out the tivo and xbox?
  23. Bloo Ice

    Bloo Ice TS Rookie Topic Starter Posts: 63

    Ok, I attached a quick MS Paint drawing of it. If you want more detail [IP's Subnet ect] just ask, and I'll do it. Thanks for all your help so far!!

    Attached Files:

  24. IronDuke

    IronDuke TS Rookie Posts: 856

    It might make things easier if you were to enable DHCP as mentioned earlier by StormBringer. Then see where we go from there.
  25. Bloo Ice

    Bloo Ice TS Rookie Topic Starter Posts: 63

    DHCP is enabled..that is why on the second time I pinged it had an IP of 169.....
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...