After Fdisk and format CD-ROM not reading

By bumfuzzled ยท 6 replies
Aug 27, 2004
  1. Our homeschool coop had several used computers donated to us and I have gone through the fdisk and formatted 7 of them with no problem. I have two that have me *bumfuzzled*.

    After running the fdisk and formatting the hard drive, my CD won't access. I know it is working as the light comes on and the door opens and closes. The problem is that when I put in the Win 98 CD, and go to the D: and type in setup, it says it does not recognize E: drive. I know they sometimes bump letters, so I go to E: and type in setup and it says invalid command or filename.
    This is really weird.

    Any suggestions?

    I have tried taking out the drive itself, putting it back in, checking all the cables to make sure they are secure and reinstalling the drivers for the CD (TEAC-532E).
    The only problem I can find is that the drivers don't go to the directory where the sys files are.
    D: has all the sys files on it when I run a dir, and C: is empty except for the TEAC drivers.

    I am open to any suggestions.
    Thank you so much for your help.
  2. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Welcome to TechSpot Forums

    Try with setup /is parameter, it bypasses running scandisk (unless you want to install 98 to E ).
  3. bumfuzzled

    bumfuzzled TS Rookie Topic Starter

    I tried the setup /is
    It came up not reading drive D:
    Same thing for drive E:
    I can run a dir on drive D and it shows all the sys files and drive C as only having the command com files
    I am very puzzled.
    I know there has to be a way to do this, I am just not knowledgable to know how.
  4. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Did formatting end up ok?

    It could be a faulty IDE cable or wrong device settings for drives, or wrong CD-ROM driver, too. If oakcdrom.sys doesn't work properly, try searching for other drivers (assuming it is an IDE drive).

    Also, try turning DMA & smartdrv off for the drive and verify on ("verify on" as a command) to make sure data is read & written correctly.
  5. bumfuzzled

    bumfuzzled TS Rookie Topic Starter

    Here is what I just tried.

    I changed the bios to read the CD-ROM first and the WIN98 cd came up so I know the drive is working.
    It said
    There is already an operating system installed on the computer and this version of setup is designed for computers with no operating system. It is recommended that you exit, reboot from your hard disk, and then run setup.
    Press F1 for more instructions.
    If you continue with Setup, your current Config.sys and Autoexec.BAT files will be replaced by basic wersions of those files.

    I hit F1 and got this:

    This version of Setup cannot continue. You need to run Setup from Setup Disk 1 or the Windows CD-ROM.
    1. Remove teh floppy disk from the drive and then restart your computer.
    2. Insert the Setup Disk 1 or Windows CD-ROM into the drive
    3. If Windows is running, click Start button, click Run, and then type the following (if Windows is not running, type this at the MS-DOS Command Prompt.)
    Where 'a' is the letter of the drive containing the windows disk.
    If you are installing from a CD-ROM, type a:\Win95\Setup

    Note: If you are reinstalling Windows 98 and Windows won't start, pres F8 when the message 'Starting Windows 98...' appears and tehn choose command prompt only.
    If you are installing from a CD-ROM, type DOSSTART to load teh real-mode CD-ROM driver before running setup.
    I hit escape to go back to the dos prompt and the prompt read D:\Windows 98>
    I left it there.
    What do you suggest?
    If I just restart the computer and then try to access the D:drive, it won't recognize it.
    I will wait for your reply.
  6. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    When you partitioned the HD with FDisk, did you set the C-partition to "active"?
    I think that is your problem.
  7. me(who else?)

    me(who else?) TS Rookie Posts: 387

    I had a problem like this installing Win 95. I just booted to a floppy disk, then copied the WIN95 folder to the HD. Then I booted from the disk and when it said it couldn't find a file I told it to look at the HD.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...