1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

AGP X1600 Pro Not Responding On My Monitor

By Arjuna ยท 9 replies
Nov 23, 2007
  1. Hello I recently purchased a Radeon X1600 Pro AGP because my old 9800 Pro had literally fried out and died trying to play Crysis. It did play it but it basically put the nail in the coffin for it.

    Anyway so I purchased the card, it's an HIS. I even bought a new power supply since it demanded at least 450W. I bought a 500W PS. After hooking everything up I turn it on awaiting success.. my monitor wasn't turning on. The card itself had turned on, the fan and all. I could tell my computer was loading up too like it should have. I take the card to my buddies house who also has an AGP slot.. and what do you know it loads up. I thought it was my monitor so I hooked my PC up to his monitor and well still had the same results.

    Is the AGP slot in my board too weak? I mean it's 8x like it demands, I have the power supply and all. I really don't know what's wrong :(

    I tried asking a few friends they said try to change the AGP Apriture and I did.. is there anything else that I possibly need to do in BIOS? I recently bought this motherboard last year, I know they aren't mass producing AGP based motherboards nowadays so I know it can't be out of date..

    Here is a link to the card itself


    and a link to my motherboard


    I hope someone can help me out here. Thank you for your time.
  2. pdyckman@comcas

    pdyckman@comcas TS Rookie Posts: 527

    When your card went out it may have been as a result of the agp slot going out. Try some other agp card in your slot to check it out.
  3. Arjuna

    Arjuna TS Rookie Topic Starter

    I'm using my back up low profile card right now.. and it's working just fine. ; ;
  4. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

  5. Arjuna

    Arjuna TS Rookie Topic Starter

    Well after doing ridiculously extensive research I am pretty sure it's my mobo. I have tried everything. I need to find a socket 754 mobo with 0.8v 8x and 1.5v 4x or 3.0 4x/8x like it says in the manual. The manual says this one has 3.0 4x/8x though...

    A similar thread was on the sapphire forums though and the dude ended up getting a new mobo and it worked. Anyone recommend a good mobo?
  6. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    did you uninstall drivers and install 7.7? Whether this is causing your problem or not you wont be able to do anything 3D rendering or anything unless you get the correct drivers. and 7.8 7.9 7.10 7.11 won't work for AGP slot ATI cards

    Just realized you had one card which quit working. then you got a new card which doesn't work either. Did you update your drivers? Both ATI. But a no name card works. Still sounds like ATI driver problem

    If you do get new mobo I would get a new graphics card too - that doesn't use AGP. All the new ones are pci-e
  7. Arjuna

    Arjuna TS Rookie Topic Starter

    My low profile card I am using right now is an old nVidia with the drivers installed so I am fine. I guess I will try those old ATi drivers.
  8. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    yea just make sure to uninstall what you have first. then install 7.7 they arent really that old. July 2007. All it is - ATI quit offering drivers at that point that 100% support AGP cards at that point. Stupid in my opinion. But what is even more stupid is they don't tell you that or differentiate when you look up your driver on their site. They suggest their new drivers even if you select a non-supported card
  9. Arjuna

    Arjuna TS Rookie Topic Starter

  10. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    You really want to get a new motherboard don't you.

    Completely uninstall anything that you have from ATI (CCC, drivers)

    Do this by going to Control Panel -> Add/Remove Programs ->Select Catalyst Control Center ->remove/uninstall Go to the driver also, and same thing remove/uninstall

    Your resolution might get thrown off and it may ask you to restart your computer.

    Go to the link that I first posted and install Catalyst 7.7, CCC whatever you want from there
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...