Amalgamy of CD-RW problems with a laptop. Sony DRM! EZCD!

By Vigilante ยท 4 replies
Mar 28, 2006
  1. Hello folks, this one is starting to get on my nerves. Please take a breath, clear you mind, and try not to read this in a rush. Tell me what you think. I have tried everything that would be considered "obvious".

    Basically the laptop, a Gateway Solo 1415, came into my care to fix a problem with some funky Windows behavior.
    But upon repairing it, I saw evidence of the Sony DRM crap, you know the Aries driver and $sys$ folder, etc... Although it was curious why the $sys$ folders were visible, meaning something had already been removed, or maybe she had the Sony "upgrade" which makes it work just the same, but becomes visible.

    In any case, I removed the service, the $sys$ folders, the driver, etc... Until I couldn't find any more traces. Didn't have any problems at this time though, it seemed fine. I finished the work, and sent it away.

    However, we found out the next day that the built-in CD burning of XP went caput. So I had her try to burn with EZ CD Creator, which had always been installed, but she never used it cause she always used XP. And EZCD apparently worked. So she brought the system back to me, and here it where it gets interresting.

    The drive will read any disk, retail, burned, it auto plays things I believe. And I saw that the IMAPI burning service was set to manual, so I started the service and set to automatic start. But, as was her problem, you can add files to the CD when a blank disc is in there, but when you click to burn these files to CD, it pops up an error saying to insert a disk. It just doesn't see a blank disk in there.
    So I checked the registry, deleted the lowerfilter and upperfilter drivers, didn't help. I downloaded a Roxio EZCD 5 update, didn't help. So get this, I uninstalled the cd-rom from device manager, and restarted after all this.
    When it came back up, the error changed. Now instead of just saying "insert a disk" it doesn't get that far. When a blank disk is in, you can't go "in" to it. Now I get a popup saying:

    "D:\ is not accessible.
    Incorrect function."

    Now this error, in google, produces **** loads of so-called "fixes", having everything to do with, "if you have roxio ez...." BLA! Roxio is gone, and so is any other burner. Sony DRM is gone. But I get this message. And nobody has an answer that doesn't start with Roxio.
    This is only when you try to copy a file to be written, or double-click the D: drive when a blank disk is in. If you have a disk with data, it works fine. But not blanks, it doesn't know there is a disk in there.

    The driver files for the CD rom are:
    cdrom.sys, imapi.sys, redbook.sys, storprop.dll
    They look normal.

    So then I figured it's worth a shot, I installed CDBurnerXP Pro. It pops up and I choose the data project, then the program just freezes at that point, and ends up not responding and I have to close it.

    You can guess, this is very frustrating. Mostly because they are on my neck about fixing it, and also because it is in worse shape then before. Because before, Roxio was actually able to burn, but not XP. And now I've removed Roxio, and nothing works and nothing can burn. It's very bad. I don't know if it's some stupid reg key, or a driver file somewhere.

    I found a "real" uninstaller for the Sony DRM, and ran that. I ran a command to remove the aries driver again, maybe in case I didn't get it. I checked win updates. I looked for an IMAPI cd burn update. Nothing works. I've deleted the drive again and looked for duplicate drivers in the registry and more random tries at fixes. And nothing works at all.

    My suspicion is that there may be a reg key with bad permissions, or possibly a folder. Who knows.
    My thoughts are:

    Is there a way to "reinstall" XP CD Burner subsystem?
    What could this error mean if NOT upperfilters and lowerfilters and roxio?
    What part could Sony have played in this if all the parts were removed? I had searched the hard drive and registry for any more $sys$ entries and got rid of any traces.
    Could something of Roxio be hanging around? If so I wouldn't know what beyond a driver file and filters keys.

    Oh, and the first person who suggests a reload will get a virtual slap in the face. You know me better then that :)

    What say?

    P.S. It's XP Pro and SP2.
  2. Spike

    Spike TS Evangelist Posts: 2,168

    I've got a similar problem with my drive telling me to insert a blank disk when using the built in windows burning. I just use Nero instead, though it should be mentioned that I've never been "infected" with the sony DRM rubbish.

    However, assuming I have the issue for a different reason, I know that the sony DRM rubbish intercepts kernel level requests. Last thing I heared, was that an improperly removed sony rootkit would render the drives useless.

    I don't know if that has changed, but apparently Windows Defender from MS has removal signatures for the rootkit these days -

    If the current problem isn't rootkit related, I'll see about trying to repair the native CD buring on my XP and if I manage (or not) I'll let you know.
  3. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    Cool beans.

    As for the two things you mentioned.

    The rootkit. Rootkitrevealer should show you if any pieces still exists. If you read the sysinternals blog, the original one, you'll see in his screenshot that is gives pages of info.
    When last I ran RKR, I had NOTHING. So if you have been infected with the DRM, run RKR.

    As for the ROM being useless, that part, along with EZ CD, has to do with bum upperfilters and lowerfilters keys that are abandoned or corrupt. If you remove those keys as per the MS article, that should allow the CD-ROM to work again.

    So like our problems dictate, the CD-ROMs work to a degree, reading disks and normal stuff. But XP built-in burning is trashed, and I get the Incorrect Function error when a blank disk is in.

    For an update: Like I said earlier, I tried CDBurnerXP Pro, but it froze. Later I tried Nero Express, the OEM suite, and was able to burn, just like you can.
    So as of now, the customer has the laptop and is burning with Nero. But she will be bringing it back for me to try to fix proper. So more info is certainly good.
  4. Spike

    Spike TS Evangelist Posts: 2,168

    Interesting. I've never had that rootkit, so given that the nero suite works for you also, then it would appear we both have the same problem currently.

    I guess I'll have to try and fix it :p If you get there first, let me know. lol
  5. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    See this Roxio knowledge base article. Click here. While the problem it describes is not exactly your problem, it is similar. I've had problems in the past where Roxio would give me a message that no supported recorder drives were detected. However, Windows Explorer would show the drives. Anyway, my problem wasn't exactly what the article described either but one of the utilities fixed it nonetheless.

    One utility is for when Roxio is uninstalled and the other is for when Roxio is still installed. Might be worth a try.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...