Analyzing BSODs with Windows Debugger (Page Fault 50 Error)

Not open for further replies.
First time on this forum, and looking for some help with a problem that's been happening for a while...

I built a new Athlon 64 system about 10 months ago. 6 weeks into the initial build, I got my first BSOD. I would average another BSOD every 3 weeks or so, with no apparent problems in between. The basic info for the machine is as follows:

Athlon 64 3500+ (Newcastle) w/stock HSF
Asus A8V Deluxe (Rev 2)
2x512MB Corsair VS PC3200 (2.5-3-3-8), dual channel
Enermax EG475P-VE PSU
2x160GB Hitachi 27K250 SATA in RAID0 on VIA controller
80 GB Hitachi 7K250 SATA on Promise controller
Plextor PX-712A DVD+-R/RW
Radeon 9600XT 128MB
SB Audigy 2

I put up with the problem for a while, but finally decided a few months ago to get serious about trying to fix it. Problem is, I can't recreate or predict the problem. I've run a number of different diagnostics...memtest, docmem, Prime95, CPU burn-in, Super PI, drive utilities, etc., and nothing reported errors or crashed the system. Never had a crash during gaming, either. The BSODs seem more likely to happen when the system is idling or at light load, actually, although I haven't find an identifiable pattern. About 2 months ago, I decided to start fresh with new drives and Win XP SP2. Made sure to get the latest drivers, BIOS, etc. I got about 4 weeks out of it before another BSOD, and have had several since--the fresh install didn't do the trick, either.

This past week, I've spent some time trying to see if the windows dump files can yield any clues. Here's where I need some help, since I really don't know how to process the info in the files. I've managed to open the files with the Windows debugger, and performed a basic analysis, but I'm not able to interpret the info. I don't have a dump file for every crash (a few of them didn't give a BSOD, but just rebooted), but the three I do have contain very similar info. Here's one example of what Debugger is reporting:


* Bugcheck Analysis *


Use !analyze -v to get detailed debugging information.

BugCheck 50, {be80f1d4, 8, be80f1d4, 2}

Could not read faulting driver name
Probably caused by : ntkrnlpa.exe ( nt!KiTrap0E+cc )

Followup: MachineOwner

kd> !analyze -v

* Bugcheck Analysis *


Invalid system memory was referenced. This cannot be protected by try-except,
it must be protected by a Probe. Typically the address is just plain bad or it
is pointing at freed memory.
Arg1: be80f1d4, memory referenced.
Arg2: 00000008, value 0 = read operation, 1 = write operation.
Arg3: be80f1d4, If non-zero, the instruction address which referenced the bad memory
Arg4: 00000002, (reserved)

Debugging Details:

Could not read faulting driver name


be80f1d4 ?? ???





LAST_CONTROL_TRANSFER: from a11a4d64 to be80f1d4

WARNING: Frame IP not in any known module. Following frames may be wrong.
a11a4d08 a11a4d64 010ffed4 bf80f1ad 00000000 0xbe80f1d4
a11a4d4c 8053c808 00bd6e1c 00000000 00000000 0xa11a4d64
a11a4d4c 7c90eb94 00bd6e1c 00000000 00000000 nt!KiFastCallEntry+0xf8
010ffee0 00000000 00000000 00000000 00000000 0x7c90eb94

8053f6ec 85c0 test eax,eax



SYMBOL_NAME: nt!KiTrap0E+cc


IMAGE_NAME: ntkrnlpa.exe


STACK_COMMAND: .trap ffffffffa11a4c98 ; kb

FAILURE_BUCKET_ID: 0x50_W_nt!KiTrap0E+cc

BUCKET_ID: 0x50_W_nt!KiTrap0E+cc

Followup: MachineOwner

The one thing that strikes me as particularly odd is that the value in the second argument doesn't make sense. Debugger list 1 or 2 as valid results, but the returned value is 8. So far, I haven't been able to get any more info about that.

I'm hoping that someone here can help me interpret this information and try to discover the cause of the problem. I'll try to upload the actaully minidump files as well, in case someone wants to try to analyze them directly. Thanks for the help!


Posts: 74   +0
did you happen to find a solution?

i have a very similar setup Asus A8V Deluxe, AMD 64 3500+, 2 SATA drives, Plextor DVD burner, Corsair XMS dual channel RAM, etc.

i'm getting BSOD frequently and examination of the minidumps show it to be "ntkrnlpa.exe" as the root problem, a core Windows kernel.

figured since our systems and problems are so closely related, what fixed yours would fix mine. i'm on the latest BIOS 1015, btw


Posts: 1,994   +0

I don't have a dump file for every crash (a few of them didn't give a BSOD, but just rebooted)

Answer: This is the symptom of faulty PSU or RAM. What is the wattage of your PSU? Maybe it has inadequate power or it is faulty. Some faulty ram can pass memtest. You had better remove one memory stick. If your windows does not crash for about 1 week, the removed memory stick is faulty.


Posts: 74   +0
Stahm, who began this thread, i'm guessing is no longer having a problem. i wrote in b/c our setups and problems are similar.

Howard Hopkins has seen my minidumps...this is what he said about them:

"All your latest minidumps crash with a bug check of 8E. They all reference the same driver ntkrnlpa.exe."

Any idea what this could point to? It seems hardware related, I just bought brand new Corsair XMS RAM, I'm guessing maybe my video card or Power supply. Does any of that sound likely to you??


Posts: 1,994   +0
Hi Dugawug,

Howard is good at analysing at minidump and I believe that his recommendation is based upon his best knowledge. As you know windows debugging is very technical and no one can guranteer the answer is 100% correct. Especially for hardware related to problem, it is very difficult to find out the culprit.

You can report the problem to Microsoft to ask for second opinion.


Posts: 74   +0
indeed, it is very hard to find!!

can i ask you this, if i choose "disable" in the device manager for a hardware item, is that just as good as completely removing it physically so far as the OS is concerned?

i was going to start by disabling one hardware piece at a time
  • Thread Starter Thread Starter
  • #9
Hi, dugawug and cpc2004,

Noticed in my webmail that this thread has suddenly gotten active again--sorry about the delayed response. No, I still haven't found a solution. I've had several more crashes in the past months--ntkrnlpa.exe has been referenced multiple times, as has win32k.sys several times, and also an ATI video driver (ati2cqag.dll) once or twice. At this point, I'm crashing every couple of weeks--enough to be frustrating, but just long enough in between to make you hopeful that maybe you somehow fixed it. Interestingly, if one crash happens, I sometimes get a second or third within the next 24 hours. After that, the system will be "stable" for another few weeks. Makes it a pain to figure out if what I tried actually did anything or not.

My PSU is an Enermax EG475P-VE rated for 470W. It was new at the time I built the system about a year ago. I have not suspected the power supply to this point, since "stressing" the system doesn't seem to cause the problem to happen--at least, I can't make it happen on purpose by gaming or running benchmarks. This PSU has two +12V rails, one rated for 15A and the other for 16A--I think I read somewhere that AMD recommended 18A on +12V, so maybe this is a bit low (not sure how to apply AMD'S recommendation for dual rail PSUs, though). RAM is also possible, although I can tell you that I did swap out my memory for some identical sticks about two months ago, and that didn't fix it. I'm currently using the original sticks in a different system with no apparent problems.

All of which leaves me still wondering where to go next. Since the video driver has been referenced a few times in the dump files, I wonder if it would be worth it to swap that out (I might have an aged PCI video card lying around somewhere). My BIOS is at 1011, but I see that Asus has the 1016 beta bios available now--that might be worth a shot, too. I've also wondered if it's possible that the memory controller in the CPU is flaky--I don't know of a way to test this, short of swapping it out and sending it back to AMD.

dugawug, you mentioned Howard's analysis of your minidumps, but I didn't see whether he suggested a cause or not. Maybe the minidumps don't really yield any more clues. If I start pulling parts, though, I think I'll probably physical remove them from the system. I'm not sure I completely trust just disabling them in device manager.

If anyone has any other ideas, I'd appreciate hearing them. Thanks to all for the help.
  • Thread Starter Thread Starter
  • #10
Since I have a few more of these, I figured I'd go ahead and upload them in case someone had a chance to take a look at them. These are the latest minidump files from this problem. Please note these files include the dump files I posted when I first started this thread--no need to download those separately. Hopefully someone can mine more information from them than I can. Thanks!



Posts: 1,994   +0
Hi Stahm,

The first three minidumps is 4 months ago. Your latest dumps have more information. Upgrade ATI display card driver may resolve the problem as one minidump crashes at ATI display card driver. If it still does not work, it is faulty ram or display card.

The following problem is similar to your problem.

Summary of your debug report
Mini100605-02.dmp BugCheck D1, {30, 7, 0, f7692878}
Mini100605-02.dmp Probably caused by : viamraid.sys ( viamraid+6878 )

Mini070705-01.dmp BugCheck 50, {fefffff8, 0, 80543c1d, 0}
Mini070705-01.dmp Probably caused by : ntkrnlpa.exe ( nt!ExFreePoolWithTag+237 )

Mini072505-01.dmp BugCheck 50, {be80f1d4, 8, be80f1d4, 2}
Mini072505-01.dmp Probably caused by : ntkrnlpa.exe ( nt!KiTrap0E+cc )

Mini072505-02.dmp BugCheck 50, {be80f1d4, 8, be80f1d4, 2}
Mini072505-02.dmp Probably caused by : ntkrnlpa.exe ( nt!KiTrap0E+cc )

Mini091505-01.dmp BugCheck 1000008E, {c0000005, 80543c1d, b71495dc, 0}
Mini091505-01.dmp Probably caused by : win32k.sys ( win32k!HeavyFreePool+bb )

Mini100605-01.dmp BugCheck 1000008E, {c0000005, 80623a10, b875c728, 0}
Mini100605-01.dmp Probably caused by : ntkrnlpa.exe ( nt!CmpDoOpen+176 )

Mini111405-02.dmp BugCheck 1000008E, {c0000005, 806203ef, b80305b0, 0}
Mini111405-02.dmp Probably caused by : ntkrnlpa.exe ( nt!CmpFlushNotify+13 )

Mini101105-01.dmp BugCheck 1000008E, {c0000005, bfa19b30, b7a9b840, 0}
Mini101105-01.dmp Probably caused by : ati2cqag.dll ( ati2cqag+bb30 )

Mini101905-01.dmp BugCheck 1000008E, {c0000005, bf80e570, b7c63614, 0}
Mini101905-01.dmp Probably caused by : win32k.sys ( win32k!HMFreeObject+7c )

Mini110105-01.dmp BugCheck 1000008E, {c0000005, bf802501, b736bc98, 0}
Mini110105-01.dmp Probably caused by : win32k.sys ( win32k!SleepInputIdle+29 )

Mini111405-01.dmp BugCheck 1000008E, {c0000005, 806233a0, b882e918, 0}
Mini111405-01.dmp Probably caused by : ntkrnlpa.exe ( nt!CmpCacheLookup+ba )
  • Thread Starter Thread Starter
  • #12
Thanks for the help, cpc2004. Might be overkill, but I think at this point I'll try to isolate the problem by pulling the current video card, uninstalling the Catalyst drivers, and putting in a non-ATI spare I have. Will post again with a progress update after a while...
Not open for further replies.