Another (different?) 137Gig HD Issue - and other issues

By SNGX1275 ยท 4 replies
Feb 23, 2006
  1. To get this out of the way up front:
    Athlon 1Ghz
    Asus A7V Motherboard with onboard Promise UltraATA-100 controller.

    A while back I bought 2 200Gig WD ATA-133 Hard Drives. I had one in my older comp and had Gentoo Linux on it, it showed up as full size and all was well.

    After some time I decided I didn't have the knowledge or time to screw with getting MythTV working on it, espically since KDE was crashing anytime I tried to do much outside of konsole. So I pulled that hd out and layed it to the side (so its physically not in the computer at this point).

    I then put in the other 200 gig hd and I don't remember what the process was, but I got XP installed on it and had a full 200 gigs (or 187 or whatever it turns out to be). Everything was fine, it was 1 partition NTFS.

    Now a couple weeks ago, after an Avast update which required a restart, the computer never came back to life. It would stop say some error, not windows related, probably something about invalid system disk or not found and press ctrl alt del to restart. After several reboots and it still not comming up I checked the cables. They were fine, still had problem. So I switched the drive over to the Promise UltraATA-100 controller. This time it displayed the splash screen and got about 2 scrolls of those green dots and hung. This continued, so I tried safe mode, same thing. Hangs at mup.sys. So I tried a repair of Windows, before even getting the option to install, when the setup says "starting windows" down at the bottom (still the text based install part) it hangs.

    So now I decide that I'm done screwing with that, and I put that Gentoo hd back in, and proceed to install XP SP2 directly to it, I delete all partitions and then notice its not seeing the full size of the hard drive. So I think maybe its just a setup thing, and I create a 100 gig partition and leave the rest unformatted. After windows is done installing, I check disk management, and its got my 100gig partition, and then 27 or 28 gigs of unpartitioned space. Where the hell is the rest of my space?

    As I say the computer had XP installed on a 200 gig partition earlier, so I don't believe this is that BIOS limitation, hell I think that problem was probably addressed by the time the A7V was released, even if its not I have bios revision 1007 or 08 or 09 on it (don't remember for sure) and it surely was addressed by then. Also as I said this was a clean install of XPSP2 so Windows had addressed the 137 barrier by that point too. So whats wrong?

    So in summary I really have 2 seperate problems here.
    1. Any ideas on why the computer refused to boot the OS when on the regular ide controller, then boots the os on the ata100 but hangs, and hangs on 'loading windows' during the text part of the install before I can do a repair?
    2. Where is the rest of my space? BIOS shouldn't be an issue and Windows shouldn't be either (remember I had 200gigs working on this just a month ago).
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You should double-check in registry just in case Windows hasn't bothered to enable large disk support: HKLM\SYSTEM\CurrentControlSet\Services\atapi\Parameters\EnableBigLba value should be 1.
  3. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,742   +421

    Interesting. That fixed it Nodsu, but not right away.

    First off, that key wasn't there. I had to add it. Then I rebooted. Still wasn't fixed.

    So I shut down, put it on the regular IDE controller, booted back up, and then it saw the full size. So I'm formatting it now, I have to get back to work, but after I get back home I'm going to shut down and put it back on the ATA100 controller. Apparently it won't naitively recognise 200 gigs on that promise controller.
  4. PanicX

    PanicX TechSpot Ambassador Posts: 669

    Congrats on the fix. I'd be careful though as the systemboard sounds unstable. It's possible you had some dust or oxidation causing a bad connection which was corrected by fiddling around with the connectors. Perhaps just a glitch in the BIOS, but I'd try resetting the CMOS and updating the BIOS to be sure everything's kosher at that level.

    Just a thought.
  5. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,742   +421

    PanicX - It is entirely possible something may be going wierd with the board, it is a good 6-7 years old now. I built that system in Jan 2000 and it wasn't top of the line by any means then, decent, but not top.

    I think though, the most probable cause here is something with my copy of XP and Slipstreaming SP2. My XP disk is one of the originals, and I had to slipstream SP2 into it. I've done this 3 times, and had problems every time I've installed with the Audio/Video codecs (2 different computers). I haven't even attempted to see if its problems now, I just slapped SageTV back on and record tv. I haven't even tried to play anything that I've recorded back yet.

    So I'm leaning more towards a problem with my XP install on why it didn't deal with the 200 gig disk. Rather than a hardware issue. Time will tell I guess, but soon enough I'm going to get a wireless NIC for it and a remote and put it in a cabinet under my TV. If it can survive til then, it will never get turned off :)

    I may be wrong, and it could be a motherboard issue, but my gut feeling is I got unlucky with something in Windows when Avast wanted a reboot, and the wierd slipstreamed SP2 issues I have were the cause for it not dealing with 200 gigs.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...