1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Anybody familiar with memtest and memtest86 programs? Advice

By Vigilante ยท 8 replies
Jul 28, 2005
  1. Hi. Thanks for reading this fine looking thread puke:

    I use two different memory testing programs. The well known memtest86 which is run off a bootable CD.
    And I use a program called "memtest" which is a little app that runs in Windows. As it scans it goes by "cycles" and "percent coverage". Or something like that. You know what I'm talking about if you use the program.

    Anyhoo. Here is what happens, I can run memtest86 all day and night and it won't give any RAM errors. But if I open memtest in Windows, it will have memory errors within a few seconds and continue to have errors non stop.
    Now, assume the program is not corrupt, I trust both programs vehemently.

    So in Windows/programming terms, why would a memory test pass outside of Windows (memtest86) but fail continually inside Windows (memtest)??

    Note that the system DOES have problems. It crashes and restarts. So I trust that the memtest failing is what the issue is. But it couldn't be the physical RAM because that tests fine in memtest86.

    Lastly, we HAVE swapped RAM in the system, at least 3 other sticks. And always memtest86 passes and memtest fails right away, and the system is not stable.

    Some ideas I had was HDD, mobo or CPU issues. What could this mean? What can I try?
    I only have 2 days to figure it out!

  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    You could try moving the pagefile.sys to another partition or (better) another drive.
    Control Panel/System/System Properties/Advanced tab/Performance Settings button/Advanced tab/Virtual memory Change button
  3. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    That would be a good guess. But they only have 1 HDD and 1 partition. I'll probably try turning the swap all the way off and see if that helps.

    I going to run a chkdsk in Recovery Console and a defrag also.

    I'm wondering, with the way than memtest works, it must be using the hard drive. But I'm sure it's also using the CPU to some degree to test with.

    Hopefully it's something simple with the hard drive. The system is practically new with XP that is probably only a couple months old or thereabouts.

  4. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    Here is what I have tried since I got it:

    Tried turning off swap - no

    Tried CHKDSK followed by a defrag in Safe Mode - no

    Note that system is baby-**** queaky clean. Don't even TRY to guess spyware/viruses. There is but ONE startup for quickbooks and ONE non-microsoft service for Nero InCD. There is only like 7 apps listed in add/remove. The system is close to new and is used as a server of sorts. So no kids playing with it or game play.

    Okay, I went through the whole file structur and through the registry looking for odd things and clearing things out - no

    Turned off System Restore
    Turned off Time Syncronization
    Turned off automatic updates
    Turned performance to high-performace minus a few settings left on
    Turned off Remote Assistance
    All still no good (still throws errors with memtest)

    Next I uninstalled NAV and searched for and removed any traces of it in file system and in registry.
    At this point I did not run memtest, but I had selected to NOT index drive C:. And while it was turning off indexing for all the files it threw a BSOD with the the file "NTFS.SYS" to blame.
    When I came back into Windows, the index check box was not checked. Though I assume it never did finish turning off index for all files.
    At this point because of the BSOD I thought there might be new file corruption. So before running another CHKDSK I decided to run a SFC /SCANNOW. That also threw a BSOD blaming file "PCIIDEX.SYS" and the message was "IRQL_NOT_LESS_OR_EQUAL"

    I restarted and am now in Recovery Console doing another CHKDSK.

    Seems to me it is seeming like HDD/IDE/mobo issue. Rather then a RAM issue. Even though memtest tests the RAM, Windows is still swaping data back and forth, and may be corrupting data, causing memtest to detect errors.

    Any thoughts? I will keep posting my results until this is fixed!
  5. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Run a Tuff-test on it:
    The light version tests already quite thorough.

    Try the harddisk-utils as described in the Read in the Storage/Networking forum.
  6. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    Okay, here is what I did next.

    I noticed that the CD-RW was plugged into same cable with HDD. I put the CD-ROM on its own cable on 2nd channel.

    Next I checked MSI and downloaded the 4in1 driver and the RAID driver from the site. Also downloaded the BIOS though I don't want to temp that fix.
    I tried to load the 4in1 but it crashed again. Upon restart it just had a black screen saying c:\windows\system32\drivers\isapnp.sys is missing. I went in Recovery Console and the file actually WAS there. I ran yet another CHKDSK and it was able to load Windows again.

    Loaded the 4in1 driver again, this time it took, and restarted.
    Loaded the RAID driver, it took.
    Checked Windows update, needed Windows verifier, but no updates available except 2 recommened which I did, and two drivers for NIC and Sound which I did NOT do.

    I also set, in Device Manager for the HDD itself, to NOT use write caching.

    Next I went on WDs web site and downloaded the DLGTOOLS program for Windows as per your suggestion. I ran through the quick test and extended tests and both went through and didn't crash or error, testing past.
    Ran memtest again - STILL ERRORS after all that. ARRRGG.

    Next I went through properties of IDE in Device Manager and set mode to PIO only (It was running UDMA5). Set those on both channels and restarted. Memtest - ERROR

    Unplugged CD-ROM from PC completely. Memtest - failed again. Memtest crashed while closing at this point and the system threw a BSOD while trying to restart.
    STOP: 0x050

    While it was off I put RAM from slot 2 to slot 1. Memtest - failed.
    Also it booted up saying recovered from serious error. I sent the error report and it came back blaming a driver. Didn't say what. I can guess. I ran SIGVERIF and the only things it found were a couple DLLs from QuickBooks.
    Note that the drivers loaded for IDE and controller are MS drivers dated 2001 and thereabouts. With the updates I've done, still no newer files loaded for some reason. Will try to find updated drivers.

    Went onto VIAarena.com and download the 4in1 Hyperon driver and also the IDE accelerator. Installed the 4in1 and restarted. Memtest still failed. But no updated drivers were loaded to IDE.

    Since previous fixes didn't work. I turned drive cache back on. Set mode back to DMA, plugged CD-ROM back in to 2nd channel.
    Restarted and installed the IDE accelerator from viaarena. Restarted again. I checked Device Manager and now the drivers ARE updated ones. There are new drivers for both IDE channels AND the controller. Went I exited DM it said settings have changed and wanted to restart so I did.
    Memtest - still failed on 6th cycle.

    I've tried every bloody thing I could try in Windows. Unless it is some obscure driver (how can I find it?), OR it is still hardware.

    I will try the tufftest next and see. But the free version doesn't scan more then 200MB of HDD space, so it won't be a very good HDD tester. But I'm crossing my fingers.

    Some more info:
    There is just the one HDD, a Western Digital WD800BB (80gb) on IDE.
    Also one CD-RW drive on 2nd channel
    Motherboard is an MSI PT880Neo V.2 (MS-7043)
    Intel P4 3ghz
    XP Home with all updates and SP2

    Thanks, any more advice anybody?
  7. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    Alright, I couldn't run tufftest on it for some reason. I downloaded it and installed it FROM this PC. But when it boots up it goes to the tufftest screen and blinks "LOADING" but just stays there and doesn't get any farther.

    Anyhoo, we took a completely different HDD and quickly loaded a fresh copy of XP (same version) on it and ran memtest, it STILL failed! With the other HDD disconnected, of course. So now it MUST be a hardware issue. Right?

    Well I'm going to try to find another P4 CPU to stick in here and test with next...
  8. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Going back to the start, exactly WHICH memtest program do you run from WITHIN Windows?
    Memtest86 is not made for that.
    There is another memorytester available here: http://oca.microsoft.com/en/windiag.asp
    The M$ version also runs from floppy or CD, so I am really wondering what you use to test.
    You sure that is a legal, proper program?
  9. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    The memory tester I use, and have used for a long time, is called just "memtest" and does run in Windows. I really like it and find it to be accurate not only as a plain-jane RAM tester, but also BECAUSE it runs in Windows, it acts sort of like a stability tester.

    See when it runs it allocates ALL free RAM for itself and then churns it around. The longer you let memtest run, the more RAM it covers. Because XP will continue to swap bits of RAM back and forth to page file and so forth. Eventually memtest will test ALL RAM minus what cannot be moved. Anyways, you may or may not have used it, I suggest you download it and run just to see it in action. Only a single EXE file, no installer, small footprint. Get it from (as well as read about it) here: http://hcidesign.com/memtest/
    If you type "memtest" in Google, it's like the 2nd or 3rd down under memtest86 in the results.

    Okay, that said, the problem is now over with. I had my 2 days to check it out and it turned out to be the CPU after all.
    Replacing bad hardware was not an option, so I had to at least try to exhaust all software based ideas first. But I found another P4 2.8 to use (his is 3ghz), and bingo, no errors at all with memtest.

    This is obviously why memtest86 (DOS) always PASSED the RAM. While memtest (WINDOWS) always failed. Because it wasn't RAM, it was CPU. Likely internal cache or somesuch. Which is also why I always run BOTH Windows based and DOS based testing tools. Because the DOS based tools test hardware directly, they can't exactly find Windows instability issues. Unless you run tests from Windows and find out what makes it tick.

    But the question still is, memtest is a RAM tester, so how does a faulty CPU come into play by causing the RAM test to fail?

    Thanks for your interest, I think I've played with that MS diag thing but maybe I'll take another look at it and see if I should include it in my arsenal of tools.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...