ASUS Bios update-wrong model

By rbuck ยท 4 replies
Jun 25, 2003
  1. I have tried to replace the 1003 bios on my A7V8X-x board using the 1005 download from Asus. I have tried both Aflash and EZ falash. In either case I get that the download is not the same model as the one currently in use.

    I am not a complete novice and have flashed the bios on several boards. What is wrong here? Asus tech is totally unresponsive as usual.

    Bob B
  2. JSR

    JSR Banned Posts: 592

    depending upon your board's revision

    if it's ver 2.0....then the update is C1004.........if ver. 1.03/04/06.......then it's 1004........that should do it
  3. Tarkus

    Tarkus TechSpot Ambassador Posts: 621

    JSR, he has a a7V8x-x not an a7N8x.

    rbuck, Maybe you got a bad download from the Asus site.
  4. JSR

    JSR Banned Posts: 592

    my bad

    thx tark.........most recent is ver.1005
  5. Tarkus

    Tarkus TechSpot Ambassador Posts: 621

    Only times I've seen that type of message is when you try flashing a BIOS with RAID features in a non RAID board or vice versa. Now they are smarter and combine the two and flash the correct version.

    I also had flashed a generic nForce2 BIOS once and had to flash back and it told me that I had the wrong board type for the Asus BIOS I was trying to go back to. I switched from Awdflash to NVFlash and it let me go back. Maybe there's a VIA equivalent to NVFlash.

    Could also be the same type of thing with the A7N8X. Two different BIOSes depending on motherboard revision but they usually clearly indicate that on their site when that's the case.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...