1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

ASUS K8S-MX not powering up!

By mickey79
Jun 3, 2005
  1. Ave,

    I recently purchased different parts to assemble a new computer.

    I have an ASUS K8S-MX motherboard and i got a Socket 754 AMD Athlon 64 2800+ for it, alongwith the recommended Corsair ValueSelect 1 GB DIMM's. I got a Rosewill Case with 400W Power Supply for it, and other peripherals like HDD etcetera.

    The problem is, the computer is not powering up.
    The Motherboard comes with a Led... when i connect the unit to a power source, the Led goes on, which tells me the Power Supply is ok. Even the Lan Led goes on if i plug in my network cable. In fact i even tried another power supply from another computer, and still the same results. So the power supply in my case is OK.

    I have connected the Power Switch and other switches very appropriately, from the Case to the MOtherboard.

    My most prominent guess is that the Power Switch on the Case is faulty.

    I noticed the on the Motherboard there is a USB Wake-up device, but to the best of my knowledge i have it disabled, with Jumpers set to 1, 2 on both jumper switches.

    So basically when i hit the Start/Power switch on the case, Nothing Happens! The system stays still... the Led on the Motherboard stays on, but computer doesn't power up.

    Anyone got any suggestions?

  2. DashClone

    DashClone TS Rookie

    Could try swapping round the connections for reset/power switch to see if the switch if faulty.
  3. mickey79

    mickey79 TS Rookie Topic Starter

    I did try that... it didn't work.
  4. mickey79

    mickey79 TS Rookie Topic Starter


    Gosh! It was the screws!! Somehow the screws i used were grounding the Motherboard to the metallic base of the inside of my case... which didn't allow the motherboard to power... i guess because of the grounding issues!! I changed the screws to another set of longer screws, made of a different material.. and everything works great!!! :)

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...