Asus K8V Motherboard Dead

By vol53 ยท 8 replies
Nov 26, 2004
  1. Asus K8V AMD Athlon 64
    Seagate 200GB HD
    2 - 512mb PC3200DDR
    400 watt ATX Power Supplly
    Windows XP

    I tried to update the bios using ASUS EZ Flash update, followed user manual to download update to floppy, it read floppy, started erasing, and then failed to flash, then it did nothing. I tried to recover the bios using crashfree bios 2, i inserted my motherboard cd nothing happens, my monitor has no power from motherboard, screen is black. Can anyone help me i am a newbie, probably should not have done this.
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    As far as I am aware there are only two possible solutions to your problem.

    1 Ask the manufacturer of your mobo if they would be willing to supply you with a new bios chip.

    2 Get a new mobo.

    I`m sorry that I can`t give you any good news but there it is.

    Regards and good luck Howard
  3. vol53

    vol53 TS Rookie Topic Starter

    Motherboard Dead

    Would taking the battery out of the motherboard and putting back in do anything?
  4. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    I wouldn`t have thought so but it`s worth a try.

    Regards Howard :grinthumb
  5. vol53

    vol53 TS Rookie Topic Starter

    Motherboard Dead

    Thanks for the help, I think i will try taking the battery out, what do I have to loose.
  6. AtK SpAdE

    AtK SpAdE TechSpot Chancellor Posts: 1,495

    :knock: =vols mobo
  7. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

  8. vol53

    vol53 TS Rookie Topic Starter

    Motherboard Dead

    Thanks Howard for the post, I used the right file i made double sure before i did this. We took the battery out, still nothing. The User Manual said that if there was a problem we could could recover the bios using crashfee bios 2 built in motherboard. Guess what is doesnt work. Thanks for all the help, I have contacted asus by email, they confirmed receiving email. Hope they get back to me soon, motherboard is only 2 weeks old.
  9. Masque

    Masque TechSpot Chancellor Posts: 1,058

    Did you pull the battery, set the bios jumper for 10 seconds and set it back, insert the battery and boot up? I had what I suspected was a bad bios flash a short time ago and the system wouldn't boot. Scared the $hit out of me with just a black screen. Did the steps outlined above and all is well. Had to re-tweak a few of my bios settings but that's it. BTW, it was pretty much the same system you've got.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...