ASUS mobo problem

By newbi3
Oct 1, 2005
  1. Hie. My aunt had a problem with her PC so she called me over to check it out. The PC won't on after pressing the power button. I had checked the wiring inside and all looks fine. The motherboard was an ASUS ( forgot to check what chipset was it ). It had 4 banks for memory modules, and five PCI slots if I'm not mistaken. The processor in it was a P4 (unknown speed).

    Thinking the power supply's faulty, I replaced it. After replacement, it still won't power up. I diconnected all drives and left just the soundcard and GPU intact. I took out all other memory modules and left one 128MB DDR inside. Still no power. But the green LED on the motherboard is on. It's on even with the previous power supply. I push the power on button, the LED comes on, the internal fan moves a way little bit, then it stops. The power supply fan doesn't even rotates.

    Thinking the lead from the power button to the motherboard was loose, I had tried shorting the two pins with a jumper and a screwdriver, but still no power.

    I'm out of ideas. Someone help me out.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...