ATI catalyst trouble! Can somebody please help me?

By computerfr2789 ยท 17 replies
Jun 23, 2005
  1. Hey Guys,

    I've got a little problem here for about three months now. Three months ago I bought an ati radeon 9200 SE with 128Mb ram agp version. I first had a radeon 9000 but it was the pci version, and my motherboard, an ecs elitegroup L7vmm3, didn't always boot with it. It was always or the onboard that worked or my radeon, but you never knew it for sure which card it would be. I have already tried everything in the bios but it didn't work. But whatever.
    When I bought my Agp card, these problems were gone. But now my drivers won't install. I already searched a lot of forums for an answer, but i found nothing that worked. When i start Catalyst setup it says "warning!"
    "Setup was unable to find components that can be installed on your current hardware or software configuration. Please make sure you have the required hardware or software." I already booted it in safe mode and everything and I have deleted all ati software. But in safe mode, i can open the setup for the display driver and the control panel. But with the display driver i get another of those annoying errors. It was something like:"Severe: Try to setup a standard vga driver before running setup" And this is the point where i got stuck. I can't install the drivers manually because windows doesn't find drivers in the .inf files. And my driver is already vgasafe. But i did discover that the vgasafe is in conflict with my Via CPU to Agp 2.0/3.0 controller. But when i disable it, nothing changes. Can somebody please say what i have to do to let the stupid card work?

    :( And sorry for my bad english :(



    P.S And also sorry for the long mail.
  2. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    ATI has had some severe problems with their drivers for their cards lately. I had to completely get rid of my ATI cards after both my old and new drivers stopped working.
    Apparantly it doesn't like VIA chipsets.
  3. LegendaryU2K

    LegendaryU2K TS Rookie

    I have a ati Radeon 7000 64MB PCI and it works fine. JUst cant play the gta games, for some strange reason.
  4. computerfr2789

    computerfr2789 TS Rookie Topic Starter

    Is there then nothing i can do?

    Isn't there anything to do to solve this?

    Look, i've got some new idea's but i don't know if it could work.
    - I will put my hard disk and my radeon in another pc, delete all drivers, and i try to install the radeon drivers on that pc, because u said that the problem was with the via chipset.
    -I will downgrade to windows me, 2000 or 98('cause that's a fast, stable windows version) and i hope that that doesn't give me the same trouble.

    Can somebody please tell me now which one's probably the best or if there r other possibilities?

  5. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    I was never able to figure out a solution. I switched to NVIDIA based cards and haven't had a problem since.
  6. computerfr2789

    computerfr2789 TS Rookie Topic Starter

    I think I found the solution, but i need another solution to make the solution work

    Hi guys,

    I think i finally found a solution. I discovered that VgaSafe was in conflict with each recource of my VIA CPU to Agp controller. But my problem now is that i can't change my recources. Is there a way to make it work?
    Because if I delete my stupid Via thing then my computer doesn't recognise the videocontroller (vga). Is there maybe another driver that uses other recources for my Via stuff? Then i finally can make it work.

    thnx already
  7. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Download the free Drivercleaner programme from HERE, and read the instructions.

    I know you said you`ve already deleted the ATI drivers, but just in case, go to add remove programmes and uninstall anything to do with ATI.

    Now run the cab cleaner, followed by the driver cleaner, for ATI, and reboot your system.

    Windows should now install the generic vga driver. Install the correct drivers for your card, and hopefully it will work.

    Regards Howard :wave: :wave:
  8. computerfr2789

    computerfr2789 TS Rookie Topic Starter

    Already tried

    I've tried it before, but it only makes the case worse. Then it totally won't install my card anymore. But I believe my problem has to do with this:
    The device instantion id (or something like that, i've got a dutch version of windows xp pro) is PCI\VEN_1039&DEV_0330&SUBSYS_0C651019&REV_01\4&1FEB96E4&2&0008 while the CX_23864.inf file only installs the card if it has this id: PCI\VEN_1002&DEV_5940&SUBSYS_00031002. What i did yesterday was changing in the .inf file the code in the code that stands with my hardware. It installed finally. But now the drivers won't start because windows says:
    "This device doesn't start.(code 10)" I think this problem has to do with the conflict between vgaSafe and Via Cpu to Agp controller. The following resources have already been used by my Via controller, while Vgasave needs it too:

    I/O-reach 03B0-03BB
    I/O-reach 03C0 - 03DF
    memoryreach 000A0000 - 000BFFFF

    I can't change these resource settings. That's my problem. Is there maybe a way trough the register? I don't know, but if anyone knows a solution that can work, don't doubt to reply!


  9. computerfr2789

    computerfr2789 TS Rookie Topic Starter

    new attempt

    Hi guys,
    (if you r still reading this topic)
    I am going to try to reset my bios with the jumper thing on my chipset.(np, i did this before) I hope my bios will redetect all hardware, and that it will give the right device-id to my graphic board (see my message above this one), so I finally can install my card.
    If this doesn't work, then i don't know what to try next. I hope this works so I can close this thread. But if anyone else has an advice, please tell me!

    P.S There's something that is maybe important. My ati card is a build by ati card. B.T.W i checked today some similar threads. (located at the bottom of this page. It seems that the person in this thread: "Problems installing ATI Radeon Drivers and Catalyst Control Panel" had similar problems, i am going to check their solutions too.
  10. doppler

    doppler TS Rookie

    Similar problem solved!

    I had a similar problem after the repair install of XP. There was not possible to install ATI drivers (The XP was not detecting it as a new device). I have tried many things... ATI driver cleaner, Safe mode, VIA 4in1 - different versions, card removal and replacement wih the other one. Finally it was the VIA CPU to Agp 2.0/3.0 driver (VIAAGP1.SYS). I have removed that device, rebooted and voila... System has detected the new hardware - video adapter and then the ATI drivers finally installed smoothly. :grinthumb
  11. hug0

    hug0 TS Rookie

    same problem here... did you find a soulution??
  12. hug0

    hug0 TS Rookie

    well, the omega driver fixed it :)
  13. skinner

    skinner TS Rookie

    reset your bios witch will redetect all your hardware and should solve your probs
  14. computerfr2789

    computerfr2789 TS Rookie Topic Starter

    Hi guys

    Hi guys,

    I know this topic is dead, but my problem wasn't solved yet, but i simply forgot about this thread. I am sorry for letting this thread die like that. Because I still have the same problems, i now want to revive this thread.

    what i did in the meantime:

    - I bought a new Asus motherboard (I first wanted to have one without via chipset, but they hadn't got any in stock)
    I tried my radeon 9200 Se and... it still didn't work. Because the 3d-card doesn't work on 2 motherboards, i don't think that there is something with my motherboards. So i don't think resetting the bios makes any difference. (B.T.W: I had post before that i wanted to try this and i did, but it didn't make any difference)
    - I put my radeon 9000 pci in the computer and it works fine.
    - I tried to install my radeon 9200Se on an older pentium 2 with windows 2000 and it still won't install. The Oem-drivers worked, but when i started a 3d game, it gave for ten seconds fluently graphics (tested with rayman 2 and need for speed 2) but then it froze and i had to restart.
    - I found some small characters on the card itself saying Canadian replicate or something like that. So maybe it's a fake ati card. The Oem-drivers are all of SiS and if I explore the .inf file, I can see that they are ripped from Nvidia.
    because all of the other cards found in the inf file are nvidia's. but the box was ati's. (maybe i'll post a photo of it in a few days)

    -The drivers of the card are not the normal ativexx.dll or something, but sis*something*.dll and serviceM.exe, Runscmpt.exe and some others. I already found out that the last one is for making windows recognise that it's a 128Mb card. And that it eats cpu like if it's chocolate.

    -When i boot, also the bios of the card itself says that it's a ati radeon 9200SE with 128MB ram. And a version of the card bios. But on the other hand the drivers are nvidias and sis'. Ati itself recommends me to use atiuninstall and things like that, but as i said before, i tried those things like cabcleaner, and it only makes the case worse.

    I will try again to use the omega drivers, but last time, my computer froze while installing the drivers, and the installer had a cpu-percentage like 98%

    I think that it's definitly a compatibility problem between ati and via, now that most of the motherboard have a via chipset onboard.

    I don't know what to do next, but i keep trying!

  15. Rage_3K_Moiz

    Rage_3K_Moiz Sith Lord Posts: 5,443   +38

    Thats wierd. My dad's PC has a Shuttle mobo with a VIA chipset and he's got a Radeon 9200SE too, only its from JetWay. But it works fine on his. So I don't think it was an issue with the VIA chipset.
  16. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    I had a lot of problems with my Sapphire Radeon 9550 and VIA chipset mainboard. The card wasn't detected, I had to upgrade AGP driver, install graphics card driver, boot in safe mode, delete graphics card from Device Manager and reboot. Most of the time it worked that way.

    I solved these problems by flashing the graphics card with 9600 bios (of course I set the GPU & memory speeds correctly before flashing).
  17. computerfr2789

    computerfr2789 TS Rookie Topic Starter

    I think it just happens to the "build by ati" version of the radeon 9200SE, not the 3rd party ones

    B.T.W I tried the omega drivers, but Ikernel freezes on my computer. Ati has already sent me a link to the installshield page, but it didn't help.

    (But i didn't tell the ati-guys that i wanted to use the omega-drivers)

    B.T.W 2: Is it possible with the omega drivers, once they work of course, to use the tv-out?

    B.T.W 3: Is it possible, because the small characters on the card itself say that it's a canadian replicate, that I need other drivers then the ati ones?
  18. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    No. I don't know the significance of what it says but ATI's headquarters is in Canada. Perhaps that's where it was made.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...