ATI Radeon 9250 Problems..

By Lunato ยท 4 replies
Sep 10, 2006
  1. Hey guys. Thanks again for the advice.. but, now, I have yet another problem..

    The graphics card doesnt seem to work, or, the computer is just being troublesome.

    I installed my new ATI Radeon 9250 PCI (256 MB) graphics card, that I just bought today (so much easier..) and when I finally got all the installations done, I restarted my computer!

    But, voila, another error message. Except, this one contained the error "ATI Driver not installed, or not working properly, so the ATI Control Panel must close."

    Great. So, after that, I downloaded the necessary drivers, and then, no more error! But, now, another error seems to haunt me.

    When I switch over to my new ATI Radeon from the integrated 845 graphics card thats on my motherboard already, when the monitor boots back up from the change in cards, all it shows is a black screen. No mouse. No icons. Nothing.

    I tried restarting the system at least three times, but to no avail. You guys know what's wrong?

    (And when I try restarting the computer, it gets as far as the Windows Logo, then when it is supposed to go to the Profile select screen, all it shows is a black screen of death. I cant do a single thing..)
  2. MetalX

    MetalX TechSpot Chancellor Posts: 1,388

    Did you disable the integrated graphics in the BIOS? Because if you didn't that may be the problem. If you have disabled them, then the problem may be the card itself. It may be defective or just broken. I had the same problem with my old 9800PRO.
  3. Lunato

    Lunato TS Rookie Topic Starter

    How do I disable the integrated graphics on the BIOS? Thanks in advance.
  4. mailpup

    mailpup TS Special Forces Posts: 7,187   +470

    Don't take this the wrong way, but just checking. Is the monitor plugged into the back of the new card and not left on the old motherboard connection?
  5. Lunato

    Lunato TS Rookie Topic Starter

    Yeah, it is. Well, its working now. I did absolutely nothing, but this morning, it worked! Absolutely nothing changed overnight. (Or at least I hope nothing changed.. because, no one was awake to DO changes.)

    But, all in all, its working now.

    I still have to disable the integrated graphics though. How do I do that?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...