autochk.exe not found

Not open for further replies.
Whenever I boot my computer, it starts to load and then I get the error message:

autochk program not found. skipping autocheck.

Then it just starts to reboot completely.

Anyone got a clue?

I read all those, and I think they still don't apply. The one thing I have is one I run the chkdsk /r, I get the message that I have one or more unrecoverable errors. Does that mean I am beyond the point of no return with fixing this hard drive?

Thanks again for your help.
The more I think about it, the more I think that the drive is still good. It is only about 6 months old, although nowadays that doesn't mean anything. But it sounds like the drive is still spinning up fine and no extra sounds to speak of.

I tried playing around with the Windows Recovery Console last night, but I don't know what needs to be done to try and fix anything. That is where I had tried the chkdsk /r to try and repair what needed fixing and got the error that there was 1 or more unrecoverable errors.

If nothing else, I can repair (or replace) the MBR, but would that lose any of the data I have on the hard drive? I know that I could always reformat the whole hard drive and start from scratch, but I would definitely like to exhaust all options before going that route.

autochk not found

Go to Add/Remove Programs and delete the following Windows XP HotFix: KB824105

Gotta love those hotfixes!


Posts: 2,218   +0
Re: autochk not found

Originally posted by bbrass10
Go to Add/Remove Programs and delete the following Windows XP HotFix: KB824105

Gotta love those hotfixes!

And just how is he supposed to do that when he can't boot into Windows?
If it's rebooting after displaying that message, your system partition is marked as "hidden NTFS". You can download a program called ptedit from PowerQuest for free. Boot to a DOS disk, run PTEdit, and change the "partition type" from hex 0x17 to hex 0x07.

If the message "autochk not found" is displayed but your computer otherwise completes the boot process normally, you need to remove Windows XP HotFix KB824105 in "add/remove programs".
autochk not found

I should add a few more lines. You see, the problem is not that your computer can't find autochk.exe -- the problem is that it cannot find the system partition itself and therefore cannot traverse the directory path to find autochk.exe. This is exactly what happens if the partition is flagged as invisible (ie: "hidden NTFS").

I have not fully researched the problem regarding Windows XP Hotfix KB824105, and Microsoft makes no mention of this problem in their Knowledge Base. However, I just helped someone fix their computer who was receiving the same error message, and this hotfix was the culprit. It took me six hours to identify the problem. It seems to happen only on systems with a certain hardware and software configuration, and might be related to the fact that the computer can look at the network as a boot device. Similarly, it might be related to the fact that the boot partition resides on an OEM partition such as those found on certain Dell, Compaq and IBM products. However, I have not been in a position to test this, as I was assisting this person via telephone. The easy and sure way of resolving the problem is to just remove the hotfix from your system.

Take care,
Brad (aka "Rogue Bolo")

Thanks for your comments.

I had the same error message and reboot but, after realising that the hidden system partition was the problem, it was simple to fix by running Partition Magic 8 again and unhiding the partition.

Just for the record, I had the problem with a 120GB drive onto which I'd copied the two partition of the much smaller original dual-boot drive using PM8.

The program had warned against having two primary partitions and I accepted this warning - and that must have caused the XP partition to be hidden.

Having read this thread, I ran PM8 again and realised that the XP partition was indeed hidden, and so unhid it, and everything was just fine - including 98SE.

Bob C
I am having this same problem however when I checked the partition with ptedit it was flagged as 07 which shouldn't be hidden. I am actually trying to recover my system from the Unmountable boot voulme error. when i run chkdsk /r I get the message that says autochk not found. My computer won't boot to windows even in safe mode so if it is the hotfix causing the problem I have no idea of how to get to it. If anyone has anyother ideas how to fix this I would greatly appriciate it.


autochk not found

Sorry I took so long to respond. I thought this thread was over until someone sent me an email with a few questions today. In certain hardware and software configurations, the MS HotFix that I mentioned does indeed cause the error message "autochk not found" to appear on the display, but it does not cause the computer to reboot afterward like the Hidden NTFS Partition problem.

I was successfully able to emulate the Hidden NTFS issue on my computer by using PTEDIT to mark the partition type as 0x17, and if you're interested in trying it you will find the same repeatable results on any computer running Windows. You can then boot on a floppy and use PTEDIT to switch it back to type 0x07 so that your hard drive boots properly again.

However, the Hotfix is a somewhat different problem. Although it displays the same error message, "autochk not found", it still continues to load Windows and therefore allows you to remove the HotFix. As I mentioned before, the HotFix seems to have problems specific to a particular hardware and/or software configuration, and I should add that it is possibly related to Dell's OEM Partition which is used for diagnostics and reinstallation of Windows on certain models of Dell computers. The XP Disk Management tool refuses to delete OEM Partitions since they contain a Master Boot Record provided by the OEM (see the URL for more details). Since the MBR directly invokes "autochk", it seems likely that the problem lies in their modified boot partition. Any attempt to install Windows from Microsoft's distribution disks on a Dell computer that is configured like this will report that the computer has a "nonstandard MBR". Therefore, I think it's a fairly good guess that the problem with the HotFix problem is specific to Dell's modified MBR. Unfortunately, I was providing tech support via telephone so I was unable to investigate it further. The HotFix works fine in most systems.

If you are running a dual boot, or if your boot drive and your system drive were originally configured for separate partitions, you might want to use PTEDIT to check both the boot partition and the system partition to make sure that neither one is configured as partition type 0x17. If either one is, and it was originally an NTFS Primary Partition, it should be changed to 0x07.

You should probably note the fact that if you ALREADY HAD A PRIMARY DOS PARTITION WHEN INSTALLING XP, the XP installation program automatically configures the Primary DOS partition as your "boot partition". Any new partitions that you add from unallocated space (whether formatted as FAT, FAT32 or NTFS) will be marked as your "system partition". In this case, when you look at your partitions with Disk Manager, one will be marked as "(Boot)" and the other will be marked as "(System)". However, if you use a simplistic DOS tool like FDISK to delete the Primary DOS partition, you are also deleting XP's Boot Partition (with no warning from FDISK.)

If there is more than one Primary DOS Partition (which are created by default whenever a primary partition is added by XP's Disk Management tool or third-party tools like PowerQuest's "Partition Manager"), FDISK will simply get confused.

If you have a partition (or drive) larger than 64G, FDISK will also get entirely confused. Microsoft provides a link which allows you to download a version of FDisk which works with drives and partitions larger than 64G. Please refer to Microsoft Knowledge Base Article 263044 for more information at the following URL:;en-us;263044[/url]

Just to confuse us a little further, when XP creates an "Extended Partition", it actually creates an "Extended DOS Partition", officially known as "ExtendedX", or Partition Type (hexidecimal) 0x0F (or decimal) 15. This is a little proprietary Partition Type that Microsoft made up all on their own and has caused nightmares for innocent users all over the world, especially those who use OS/2 or Linux. XP will gladly allow you to create an Extended Partition larger than 64G. Of course, the distribution copy of FDISK will not recognize it, so you need to download the special version from the link I mentioned earlier.

For instance, if you use XP to create a 67G "Extended DOS Partition" (also called "ExtendedX" or "Extended-LBA"), the distribution copy of FDISK will report it as being only 3G -- because it "rolls over" and starts at ZERO again when it hits the 64G boundary. 67G minus 64G equals 3G. (This is a perfect example of poorly-written, poorly-maintained code similar to the Y2K lack of foresight.) Furthermore, if you have assigned logical drives to the Extended Partition in XP, FDISK will not allow you to delete them. Hence, it will also not allow you to delete the entire "Extended DOS Partition" itself. So why the heck do they call it an "Extended DOS Partition" if the DOS Partition tool doesn't even recognize it?

As if all of this is not bad enough, there is another boundary that gets in the way. In order to use a FAT32 Partition larger than 137G, your BIOS must support 48-bit Logical Block Addressing (LBA), which is applicable only to ATAPI drives, but not to SCSI drives or necessarily to certain SATA drives which "look like SCSI" to XP. XP Service Pack 1 handles this issue itself rather than relying on the BIOS, assuming that you have the latest version of the file ATAPI.SYS. For more information about this, see Microsoft Knowledge Base Article 303013 at the following URL:;en-us;303013

The sad part about all of this is that Microsoft's partitioning tools -- the ones provided with DOS and all the different versions of Windows (3.x/9x/ME/NT/2K/XP) -- have been designed to intentionally cripple the user's ability to configure partitioning options, in order to discourage dual boots with other operating systems.

Personally, I prefer to configure my virtual memory swap file as a fixed-length file, about 2 to 2.5 times the size of my actual RAM, on a dedicated partition of its own. That way it never becomes fragmented and never resizes. With this configuration, it is most efficient to format the "Swap Partition" using FAT32 or FAT16, rather than NTFS. I prefer to use the very beginning of the hard disk as the Swap Partition, because the beginning of the drive is almost always the fastest part of the drive. You can find information on that subject at the following URL and numerous others:

With two identical (or well-matched) hard drives, if you create a Swap File of the same size on both hard drives, it will have the added performance advantage of using RAID0 technology for Virtual Memory even if your drives are not configured for RAID0.

However, the installation utilities for DOS and Windows do not allow this configuration while simultaneously assigning drive letter "C:" to your system/boot drive, so you need to either have a spare drive with XP or Win2K already installed on it or you have to use Linux tools or some other third-party application in order to achieve these results.

Well, enough with my pet peeves... Hope this helps.

Re: autochk not found

Originally posted by bbrass10
With two identical (or well-matched) hard drives, if you create a Swap File of the same size on both hard drives, it will have the added performance advantage of using RAID0 technology for Virtual Memory even if your drives are not configured for RAID0.

No it wont and then some.

Windows will use one drives virtual memory until it is full and only then will the next drives virtual memory be used.

RAID0 implies stripping of the data across the two drives which clearly is not the case in your example as you specifically say "even if your drives are not configured for RAID0".

The only way to have RAID0 performance is to have ??? RAID0 !!!
My Own Perspective... :)

Thank you guys I've fix the problem thanks to you, but there were other hexadecimal values mine way (i'm FAT32)... I've got to DOS thanks to Windows Startup Floppy then run PTEDIT (couldn't use mouse there, so Alt+Keys combinations to change something) and changed the first disk type from 1C (it was Hidden FAT32) to 0B (FAT32)... then Alt+F4, reboot and Windows works as well as previous. Thanks once more. Btw the PTEDIT thing is quite cool tool, I've got it on HD now and won't erase it. :D
Hi, I'm new here. Just wanted to say thanks so very much! :grinthumb
I had this same problem after ghosting my nephew's 15gig drive to an 80. My problem originated, however from Zonelabs System Suite 5.5, in particular the antivirus portion.
I suppose it is the way Zonelabs antivirus functions. For after making the partition unhidden (with ptedit) and finally getting to the desktop, I got a message "antivirus is disabled, would you like to enable it?"
If anyone is using this software, they may do well to disable the antivirus or uninstall it before using any partition or drive copying software. That is, if this was truly the culprit. :suspiciou
I believe I might have the same problem as Trevor. I'm running a Toshiba Satellite notebook and it's been loaded with a Windows XP OEM CD. During boot-up I get the dreaded blue screen of death showing an UNMOUNTABLE_BOOT_VOLUME error. I've downloaded the 6-disk XP boot disk set and managed to run the recovery console, but when I use the "chkdsk /r" command the RC is unable to find the "autochk.exe" file. I also ran PTedit as Brad and found that my NTFS file system is type 0x07 and therefore not hidden. Im just about ready to mount my boot in this thing :unch: , but before I do that, any suggestions??

i've been having the same problem with getting the autochk boot error. the system will restart after that screen and keep going in that cycle until i turn it off. i have checked the boot partition with ptedit and it is listed as 07, so that is not the problem.

this all started when i was overclocking the FSB (i'm running an Athlon 2400, and i was pushing the FSB to 150MHz from 133) as soon as the FSB hit 150, the system totally locked up. upon restart is when this error started coming up. i did a chkdsk /r and it fixed errors, but i still get the same error. once in a while i'll get a blue screen of death right after the autochk error.

i am running a RAID 0 array as my boot disk (2 36GB sata drives) but i dont know if that will have any bearing on this error.

also, i can't get into windows to look into removing the hotfix mentioned. when i try to boot into safe mode, it will also restart when it reaches that point.

if its not possible to restore windows on that array, would it be possible for me to get files off of that array if i install windows on another drive in the machine? or will i be forced to format the array?
Response to Billy Gator

According to materials presented by Microsoft for the Microsoft Certified Software Engineer certification, two swap files of the same size on different drivers offers software RAID0 performance and has done so ever since NT 4.0. The swap file is not a contiguous file; it is paginated in blocks which allows the OS to select a block from whichever drive is not currently busy.
two harddrives

I've been having the same problem with getting the autochk boot error. the system will restart after that screen and keep going in that cycle until i turn it off
At first I had one harddrive with Win98 SE - 40 gigas.
Then I got the second harddrive with WinXP - 40 gigas.
When I got the third harddrive - 80 gigas - I moved the Win98 SE to it. There were still space for WinXP and I tried to move my WinXP from the 40 gigas to 80 gigas. I used the program Ghost. There was now bothe Win98 SE and WinXP in the same - 80 gigas harddisk. When I booted and chose WinXP from the bootmenu, there was an autochk boot error.
I had to unhide the WinXP in the 80 gigas and unhide the WinXP in the 40 gigas. O'kay. The operation works fine with two harddisks. If somebody knows, how it is possible to move WinXP to the 80 gigas disk, welcome with the idea.


Posts: 3,874   +3
You will need to partition the 80gig disk. You won't be able to have them both on the same partition.

:wave:Welcome to TechSpot:wave:
thank you - two hardrives - now one enough

With the 'ptedit.exe' it was possible to change from two disks
operation to one drive operation.
Best wishes


Posts: 16   +0
bquery said:
That is where I had tried the chkdsk /r to try and repair what needed fixing and got the error that there was 1 or more unrecoverable errors.

O.k. this problem happened to me all the sudden when I was trying to run rollercoaster tycoon 3 and for some reason my computer just froze and the sound messed up when loading. I was really scared because a lot of times my computer has been doing these types of weird problems and I would have to save my files by hooking my hardrive up to one of my other computers to save them then reformat and everything (everyone knows how that goes). But I found this site on google and it wasn't the 17/7 invisible partition problem; that was fine (it was already on '07'). (Ptedit was no help in my case) I just ended up using the command: chkdsk /r in the windows xp setup boot program recovery and it took a while and seemed to have fix it. I deleted that one windows update 805124 and hopefully everything goes fine. Had to like reformat like 5X this year or more, really frustrating. The other times I would just run windows media player or be doing something like searching on the web or playing a game and all the sudden it freezes and the sound scratches, very weird. I would have to reformat cause i could not get back into windows. Hopefully everything is ok now...till next time..who knows, so many problems with windows they need a sp3 that doesn't have all those non sence security programs running in your processes that takes up your memory, but that keeps your computer running fine with no problems. :grinthumb
Hi everyone, I'm having the same problem as above, only it started because my PC froze while defragging my hard drive running Windows XP Home SP1.

I'm running a chkdsk /r right now to see if that will help. Originally I couldn't even get a Windows loading screen, I had to fixmbr to get it. Now I'm just stuck with autchk.exe not found. I cannot reinstall Windows on my active (and only) partition.

I downloaded PTEDIT.exe but how do I run this? I tried running at the recovery console and it said invalid command name. Where do I run this, or how do I make the disk bootable to run it?


Posts: 16   +0
I believe you extract ptedit.exe onto a floppy disk then boot up from that a drive and make sure it says '07' in the program when it runs in dos. If not maybe you put the program in your C: and execute it in dos, but you need a floppy disk to boot up ofcourse in that case. One of those should work. chkdsk /r should work it worked for me.. does it not work for u? hope this is helpful
Not open for further replies.