Azureus NAT Error!

By British_Command ยท 8 replies
Oct 7, 2006
  1. This is a fairly common problem and im one of those individuals that have tried everything on froums to opening ports to configurating my router and for some reason i still get the NAT Error when trying to locate an incoming listening connection.

    For some reason what ever i try its always on a yellow smiley, and i think it may be running at a good speed which is from 5kB/s rising up to 20kB/s.

    But whatever i try i always get this NAT Error i want to be able to experience the green smiley lol, but anyway i remember like a year ago using Azureus and the listening port was fine so i reckon it may be something to do with the router settigns, from then i had a period of trying to configure my router for xbox live which then turned out to be a really simple problem. A matter of opening up the wireless game adapter and slotting this card back into place.

    Anyway i think the problem i have is not exactly complicated to fix, but it may be since all the other resolutions worked with other people but not with me.

    Please try to help me, i have experienced many problem with my networking, i would appreciate any input. (please give step by step informationa s im not a computer genius more like an intermediate.)

    Thanks Again,
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Have you tried to reinstall Java. I know this might correct your problem, but I'm no expert by any means
  3. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    'NAT Error' with Azureus is very common. I bet if you use a different client (uTorrent is recommended) the problem goes away.

    Here's a great resource for Azureus users:

    What I've found is both UDP and TCP ports need to be opened - not just TCP. This is probably the most common mistake. So if your router allows TCP/UDP traffic instead of just TCP or UDP, then choose that option.

    Next, you should also specify your own ports in Azureus and forward those ports on your router and open them in firewall software. Don't use the default BT ports of 6881-6999, but specify your own that are ports 50,000-65,535.

    Not that you should do this, but another way to fix it is enabling DMZ on your router for your computer. This is very unsafe (disables your firewall), but this is a good way to troubleshoot whether your firewall is to blame or not. If it works with DMZ enabled, then you know it is a firewall issue. If it doesn't work, then something else is to blame.

    Personally, I don't use Azureus anymore. uTorrent is superior in at least a few ways and far less bloated.
  4. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    There is a work around this problem. To fix it you need to make sure your router does support UPnP and that service is turned on in services.msc when you click on start click on run then type services.msc. Scroll down to you get Universal in XP.

    Make sure you don't use ports 6881 for one thing also causes this problem. Try a different ports. If you don't have UPnp feature in your router then try port forwarding different ports other than 6881 and make sure under options in the Azureus that you tell it what port you want it to use. Also you might want to turn off any third party firewall program that you have running on that PC and use just Peerguardian 2.

    I know what I've mention above does work, you should now get all green.. There are some more tweaks, but see if you this above works for you...
  5. Bluemouse

    Bluemouse TS Rookie Posts: 195

    I get all greens most of the time, but sometimes it decides to give me a nat error for no particlar reason.

    I have port forwarded both on my router and software firewall, but still to no avail. Im using 16881 as my port, Azureus as my client and have windows xp sp2 (windows firewall is disabled).

  6. zazazoom

    zazazoom TS Rookie Posts: 84

    hmm i have a question regarding my wireless networkinging, i have a linksys wrt54gl ...but i have no idea how to set up my connection in regards to letting azureus download! my downloads won't go :p something about port forwarding..or something >_< no clue
  7. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Type in your Internet browser and press enter. Much like a website from the web, your router has an internet configuration page. is the default IP address of most Linksys routers, which is how you access it.

    Once connection, you'll be prompted to enter a login/password. The login is blank, the password is 'admin'... by default. Keep in mind that any of the values could have been changed by the person who installed the router.
  8. dogmorph2

    dogmorph2 TS Rookie

    I I went to the site because i'm having a NAT problem on Azureus and they told me to start setting up port forwarding on my Linksys WRT54G router and i followed all the steps up until when they told me i needed to set up a static Ip address...because one of the final steps for setting up this static IP address is that i need to know my DNS server...they suggested i call my ISP to get that information but when i called (Comcast) they told me that they wont release that information unless i have a business account. Is their any way i can get my DNS server information without them? Or anyway to setup my port forwarding without a static IP address? Or anyway to fix my NAT problem a different way? Please Please can anyone help me? Please any help is much appreciated.
  9. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    Use caution with UPnP; it has opened doors for infections,
    See this
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...