Drivers BAD_POOL_ACCESS with Netscreen VPN on Thinkpad

Not open for further replies.

Since I tried installing the Netscreen Remote VPN Client I get a BAD_POOL_ACCESS blue screen occasionally.

The first time I get it is when the Netscreen setup tries to create the SafeNet VPN adapter. I then get the blue screen on every reboot after loggin in until I reboot into protected mode once. Thereafter, I only get it when I'm trying to perform more advanced network connections for example, using Bluetooth to dial in via my mobile phone.

Any ideas what could be the problem? I suspect that some IBM/Lenovo ThinkVantage software is interfering with the VPN adapter in a bad way. :(

Thanks, KM


    69.7 KB · Views: 12


Posts: 5,451   +7
Do you have the latest version of the VPN software? Maybe it's a bug on the Juniper side?

The only IBM thing that touches any network adapters is the Access Connections program.
Other things you can try disabling/uninstalling are software firewalls or packet sniffers. Could be antivirus too.


Posts: 1,086   +3
All the dumps crash at tvtpktfilter.sys, which does belong to Lenovo - TVT NDIS 5.1 Intermediate Miniport Filter Driver.

BugCheck C2, {7, cd4, 23c0004, 898695e8}
Probably caused by : tvtpktfilter.sys ( tvtpktfilter+1410 )
ba428000 ba42c500 tvtpktfilter tvtpktfilter.sys Mon Jan 16 11:51:11 2006 (43CB0A1F)
Thanks for the info. I'm wondering if that is related to Access Connections because the Netscreen guys told us that they are aware of a problem with the ThinkVantage Resuce & Recovery software. But have no fix for this.

Thanks, KM
NetScreen has problem with 'Rescue and Recovery 3.1'.

(1) Uninstall Rescue and Recovery 3.1
(2) Install NetScreen
(3) Install Rescue and Recovery 3.0
Same problem

I have the same problem. Bleu screen when installing the Netscreen remote VPN client.

Is there a workaround?
Remove Rescue and Recovery

Removing Rescue and Recovery worked for me.
This was on an IBM Thinkpad R61i. This has been a problem for quite awhile with the Adtran NetVanta VPN Client that we use.
This is what i got from Juniper Support

Two scenarios exists when trying to install NSR on IBM/Lenovo laptops; running with and without the Rescue and Recovery software.

If you try to install NetScreen-Remote on IBM/Lenovo laptops running Rescue and Recovery Program the install fails with Blue Screen of Death. The specific laptop in this case is T60 Thinkpad.

The initial install starts and proceeds normally until just after the NSR install begins. The machine will then bluescreen with a "Bad_pool_caller error. Stop code begins with 0x000000c2 (0x00000007, 0x0cd4, )". The BSOD does not remain on the display for very long and then the machine reboots and during login the same BSOD screen reappears. This loop continues until you boot into safe mode and remove the \Program Files\Juniper folder.

Latest IBM/Lenovo T-60 laptops come with a pre-installed driver "TVT packet filter" (tvtpktfilter.sys). This driver has known interoperability issue with NetScreen Remote software ( as of NetScreen Remote 8.7); during installation of NetScreen Remote this driver causes Windows XP to crash with blue screen.

Uninstalled Rescue and Recovery software or applied the Lenovo security update (KB917422) to avoid blue screen and NSR installation was successful, but when NSR client is launched, receive the following error "The application or DLL C:\WINDOWS\system32\NSLDAP32V50.dll is not a valid Windows image." When a repair is done, the following error is reported: "Setup failed to properly install IreIKE service software."


If the Rescue and Recovery software is installed, most likely the TVT packet filter is causing the BSOD issue. Removing the TVT Packet filter should allow this VPN to install correctly with RnR 3.1 and 4.0.

"TVT packet filter" is part of IBM ThinkVantage Rescue and Recovery package. The TVT packet filter allows for an advanced option that most customers do not even use. Basically, if the IT administrator wanted to shut off a PC's networking or to limit it to a domain or single IP address they could do so using an executable that comes with RnR and it uses the TVT Packet filter to control the network flow. "For the average user and the majority of Lenovo's advanced users this feature is never used. In fact, in future versions Lenovo is not going to have it on by default anymore because of some of these incompatibilities as stated by IBM while working this issue with them".

Try the following:
First uninstall TVT Packet Filter from the network device control panel
Then, disable any processes running that include TVT* (there are usually 3 of these)

The way to remove TVT packet filter via a script is the following:

netsvcinst /remove /cid:”lgl_tvtpktfiltermp”
netsvcinst /remove /cid:”lgl_tvtpktfilter”
(netsvcinst is located c:\program files\common files\lenovo\pfdinst\)

Lenovo security update (KB917422) installed on the computer is the root cause for the problem. This update is related to Rescue and Recovery software.

When Rescue and Recovery software was uninstalled, the Lenovo Security update (KB917422) was left behind on the system. This was interfering with the normal operation of the VPN client. Removing this update resolves the issue. But this update cannot be easily removed. A system restore may be necessary to remove this update. Microsoft security update (KB917422) and Lenovo security update (KB917422) share the same KB number, but the problem is only with Lenovo security update. With Microsoft Security update (KB917422) installed, the VPN works fine.
Not open for further replies.