Battlefield 1942 menu problem

By Asmodean989 ยท 4 replies
Sep 4, 2005
  1. Hello, I have recently just purchased the Battlefield 1942 world war 2 anthology and after installing i installed the v1.6 patch. The game starts up and runs good except for the menus have no lables on them most of the time and when I look at the list of servers on the internet none of the information except the icons are displayed, so in short I have no text on my menu screen. I have a geforce 2 ti with the latest drivers from nvidia and the newest directx. I have tried to reinstall both and the game and its the same, even without the patch. Any advice would be welcome.
  2. Spazeman85

    Spazeman85 TS Rookie

    Exact Same Battlefield 1942 Menu Problem

    Hello. I also purchased the BF1942 anthology, and I have had the exact same problem with the text not showing up for menus and server browsing. I have a GeForce4 Ti4200 with the latest drivers installed. I also re-installed my soundcard drivers and my motherboard drivers from the manufacturer. I actually managed to get the menu text to show up at one point, but then the game would crash/reboot my system whenever I tried to enter a game. I had an older version of BF1942 running fine on my computer before I replaced my hard drive, so I'm really kind of puzzled as to what's causing this. Any advice would be nice, but I'll also post here if I manage to find a solution. Thanks.

    ***Update: There's another thread that might be talking about the same problem. It said something about newer nvidia drivers causing problems, and that using older video drivers might help.
    I tried using older drivers myself, and got the text to show up, but then the computer crashed to a black screen or rebooted every time I would try to join in a game. Maybe there's a driver somewhere in between that will work. :-/
  3. Spazeman85

    Spazeman85 TS Rookie

    Fix for BF1942 No Menu Text Problem

    I haven't managed to have any luck with this myself, but the information I have found about fixing this problem suggests using an older Nvidia driver 56.XX or older. Here is a link to another forum discussing this problem:

    I also saw another site suggesting a similar fix of using version 45.23, 56.64, or 61.77_win2kxp_international of the nvidia drivers rather than the newest driver. So, I would try using some older drivers. Whenever I do this, it causes my game to crash instead of not have menu text, but maybe others have more luck with this solution.

    I'll let you know if I find more info.
  4. bushwhacker

    bushwhacker TechSpot Chancellor Posts: 783

    Guy, Guy, Guy

    Do this, Install for nFORCEWARE v56.72, DirectX 9.0C with latest Direct3D patch and have the Battlefield 1942 v1.61 installed same does to DesertCombat Final 0.8

    Spazeman85, the NVIDIA FORCEWARE v56.72 is best for all game with itself fixes. I still not yet upgrade my forceware to newer instead 56.72, work fine! suggesting you should read the information from my signature during the install

  5. Spazeman85

    Spazeman85 TS Rookie

    Fixed the Problem

    The problem I was having was that I was using the recommended video drivers along with the correct versions of directx and direct3d. Instead of the menu problem, here's what was happenning: I would start the game, and the computer would completely freeze on the opening EA games screen. I couldn't even use ctrl+alt+del at that point, and I actually had to use the re-start button.

    However, I have fixed this additional problem I was having. I also tweaked some stuff to make the game start up faster. Here's how:
    There are game files under this directory, "C:\Program Files\EA GAMES\Battlefield 1942\Mods\bf1942\Settings", that can be edited to tweak game performance. First, I opened VideoDefault.con with notepad, and made sure it said "renderer.allowAllRefreshRates 1". This fixes an old refresh rate problem. Then, I opened Default.con with notepad and changed the first line to "Game.setGameLevelPath Bf1942/Levels/Berlin/" which helps the game load faster.

    ***Most importantly, I stopped the intro videos from playing, since that's where the game froze. Here's how: Right click on the BF1942 shortcut and select "Properties". On the "Shortcut" tab, go to the "Target:" field and add a space and "+restart 1" (without the quotes) at the end. Now, when you click the link, the videos will be skipped.

    So, that's it. The game now works. I just had two problems on top of each other. First, the older video drivers had to be used. Then I had to fix my other problem.

    Thanks. :giddy:
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...