Battlefield 2 Multiplayer Only Problem

By sarge1991 ยท 16 replies
Aug 2, 2005
  1. hi i have the full version of battlefield 2 and a computer that can run it for sure. when i load the game everythnig works find when i play single player everything works find but when i try to play in a multiplayer game the mouse doesnt seem to work the pointer just stops moving i installed the patch and it just started to happen what should i do? thanx in advance
  2. sarge1991

    sarge1991 TS Rookie Topic Starter

    sorry for the double post but 10 views and no replys cmon i need help ive came here before and many helped me ive tried everything even emailed tech support
  3. thmandan22

    thmandan22 TS Rookie Posts: 59

    Un-Install game, Re-install game, re-DL patches, re-install patches
  4. sarge1991

    sarge1991 TS Rookie Topic Starter

    ive done this like 2 times already even tried it w/o the patch its only this game too???.......
  5. desisunnyboy

    desisunnyboy TS Rookie

    ok this will help u, i'm sure
    EA is shutting u off, same thing happen to me LOL and fixed yesterday night.
    hears how.
    use "Battlefield 2 [ALL] No-CD/Fixed Image #2" with DAEMON Tools 3.47
    do an google search.
    just do full reinstall for BF2, mount mini-image with daemon tools and play
    i know EA is doing that, i think they really want us to buy this game LOL.
    k c ya , tell me if it worked
  6. sarge1991

    sarge1991 TS Rookie Topic Starter

    ok thanx alot im gonna try and see if it works but why would EA do this to me the game is legit i bought it myself what is there reason for doing this....ill edit back here if it works or not

    [edit] i downloaded the mini image and mounted it but it still didnt work so i just deleted my old account and created a new one i guess ill have to unlock the weapons over again thanx to everyone who tried to help me....i still dont know what ea did to my account i havent done anything to deserve any kind of suspension or account banning o well....
  7. desisunnyboy

    desisunnyboy TS Rookie

    call EA if u bought this game. and start bi*tching, i'm sure it's them or try one more time
    here's the steps
    Install the game - Full Installation.
    Mount the BLH-BF2.MDS CD-Image in Daemon Tools v3.47.
    Play the Game!

    to donwload BlH-BF.MDS go to (2.5 MB)!rar

    ok enjoy c ya
  8. sarge1991

    sarge1991 TS Rookie Topic Starter

    thanx it works now but like i said above i had to make a new account im gonna send an email to EA games and complain because the game is legit and i shouldnt have to deal with this lol
  9. zellyman

    zellyman TS Rookie Posts: 33

    Why would mounting the image via Dameon tools make any difference at all?
  10. desisunnyboy

    desisunnyboy TS Rookie

    u could i think just ritrieve your acount.

    zellyman: it would make if thier was a real bf2 cd in your drive when it's not.
  11. zellyman

    zellyman TS Rookie Posts: 33

    Sure, but why not just put the real CD in there? Unless of course, you didnt buy the game legally.... my point is that isnt going to have any effect on his problem.
  12. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Why would EA just make the mouse not move? That is hardly a "ban" or account lock out. But still, if a new account fixed the problem... very odd indeed...
  13. magiclal ak

    magiclal ak TS Rookie

    problems with multyplayer

    hey guys i'm desperate. Every time i go to the bfhq and press the start thing in the bottom right corner this keeps happening. I can go far enough to start it but then it stops, sends me to the bmhq and it says,"Punkbuster error: inadequate O/S privileges." and when i go to the internet connection and click on a server and connect i can go to were it says verifying client but then it says something about the internet cant connect to the server. please help!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  14. mopar man

    mopar man TechSpot Ambassador Posts: 1,379

    Are you an Admin on your account?
  15. magiclal ak

    magiclal ak TS Rookie

    battlefield2 multiplayer troubleshooting

    yes i am admin. i recently tried to reinstall it but when i start it says i dont have a shader(or something like that) and that i need to sync the shaders i try to reinstall again.
  16. magiclal ak

    magiclal ak TS Rookie

    oh yeah i have the cd and i gonna reinstall and download patch. but if you still know wat to do please tell me so i can play.
  17. Godzaghe

    Godzaghe TS Rookie

    I couldnt get this workin online either but never mind.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...