Battlefield 2 Patching Failed

By harrisdurrani ยท 4 replies
Jul 23, 2005
  1. Hey guys hows it goin .... I have a slight problem with battlefield 2
    patch 1.2...when ever i try to install the patch it says PAtching failed,,

    i checked the registry and everything but everything looked fine..i reinstalled the game twice but still the same error.. how can i fix this ??

    amd athlon 3200+
    512 DDr
    geforce 6800

    any solutions..Thanks
  2. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    Maybe a patch file got corrupted somehow. Can you try downloading another copy, maybe from a different source?
  3. harrisdurrani

    harrisdurrani TS Enthusiast Topic Starter Posts: 159


    i tried downloading it from Gamespot that din work than i tried it from the EA website..din work either

    do u know any good website where i can download it
  4. stompya

    stompya TS Rookie

    Check that you have at least 2 gig free space.

    "most of the files in bf2 are large compressed files, that need to be uncompressed to add or change smaller files in them. It also needs to make sure it patches all the files correctly before it can move them into the game directories to make sure you dont get a half patched version of the game so if you uncompress 1 files 520mb

    uncompressed you looking at already using over a gig of space. then you need another 500mb to recompress it, and then you need to store it while it patches your other files and there is your 2 gig of space. "
  5. harrisdurrani

    harrisdurrani TS Enthusiast Topic Starter Posts: 159


    thanks alot for the help ... any how i installed it on to another drive and now its fine
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...