Battlefield 2 - unable to even get it to install :(

By TBolt
Jan 13, 2006
  1. Okay, I'm a little cheesed...
    I've been playing the BF2 demo for a couple of weeks, love the game, bought the game. Went to install today, the splash screen loaded, install screen started, clicked "next" and it just froze there :hotbounce .

    I could hear my cd rom spooling up, but no activity at all. After about 4 minutes of that an error message of sorts popped up saying (paraphrasing) there was a problem with the CDKey.exe and the install will have to close. It made and I sent the report to Microsoft with no solution as of yet. BTW, about halfway through that process with no activity happening, I brought up the Task Manager and in Applications, the BF2 install was the only thing running, in Processes a BF2 cd code listed.

    I uninstalled the demo prior to the attempted install(s)(tried 3 times), everything on my rig is up to BF2 for me :(

    As I have cruised around this forum for a bit, I read a number of posts relating to problems after installs and patches, I feel pretty comfortable with all the help here if I ever get mine going.

    My rig specs at a glance:

    ASUS mobo, A8 S-X
    AMD Athlon 64 3500+
    1 gig DDR400 / PC 3200 RAM
    12 gig available on Maxtor HDD
    GeForce 6800 GS 256
    standard ATA cd rom
    using onboard Sound Max 6.1 (no speakers, only use headphone/mic :grinthumb )
    Windows Xp Home
    McAfee virus/privacy/firewall protection - disabled for (failed) install

  2. Reformado

    Reformado TS Rookie Posts: 20

    Try to install the game in a Pc of a friend of yours... Maybe it´s a cd/dvd problem. If so go to the store and change for a new one!!!

    Never seen anything like it. When solved post the result please.
    (Now i'm curious) :slurp:
  3. TBolt

    TBolt TS Rookie Topic Starter Posts: 65 it figured out. For some reason, on my particular rig, the install did not like my CD ROM / IDE setting in the DMA mode. Changed it to PIO, installed without a problem. Patched and playing...WOOT!
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...