1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Before Posting Sandisk Cruzer Micro/Mini Problems

By SNGX1275 ยท 33 replies
Oct 11, 2005
  1. It appears people continue to have problems with these drives. Sometimes the drive just goes dead, but many times they can be fixed.

    Here is one way that I know fixed mine, and its fixed several others throughout this forum, but the continued posting the same problem and the lack of people posting this as a solution has made it apparent we need a sticky on it.

    1. Find a computer with Windows98 (I think First Edition will work, but I used SE) and then download and install the driver for it (Windows98 requires a driver to read the drive).
    2. Plug in the your Sandisk Cruzer.
    2b. The drive should appear, try and open it and get all your data off, if the drive doesn't appear there may still be hope (details later).
    3. Format the drive as FAT32.
    4. Recopy your data back, and plug it into an XP machine, its fixed.

    Now if 98 didn't see the drive, there is an HP utility for formatting USB flash drives, do a search on these forums for HP and Sandisk and Format and it will probably come up. Try that, if that doesn't work, I'd say there is a 90% chance your drive is hosed.
  2. Tedster

    Tedster Techspot old timer..... Posts: 5,746   +14

    an alternate solution for XP users is to go into

    Control panel , admin tools, computer management, disk management

    and right click on the letter of the flash drive that is not working

    format it. (this will low level format the drive.) XP views the drive as a hard disk.

    then go to my computer
    right click on your flash drive, format, and high level format. Now your directory information will be loaded.
    You may be able to use some recovery software to retrieve files if you haven't written anything else to the flash drive, but data recovery is not guaranteed.
  3. DragonMaster

    DragonMaster TS Rookie Posts: 323

    Mine works and I never formatted it. Maybe there was a problem with formatting @ the factory?

    The only time I had problems was with a self-powered hub ;)

    Mine runs with a FAT16 partition. It's a 256MB.


    Fixing The Mini Cruzer Format Problem

    I Used The Computer Manager - Storage- Disk Management Utility In Xp. I High Lighted The Removable Drive And Reallocated The Space And Formated The Drive And Is Now Works Fine. Fixdisk Did Not Work Becasue The Drive Was Set During Manufacturing. The Partition Allocation Was Lost And Has To Be Reallocated. I Did Not Try Partion Magic, But That Was My Next Step. Xp Did Fix The Problem.
    As Marther Said "it A Good Thing" Hope This Helps .
  5. Tedster

    Tedster Techspot old timer..... Posts: 5,746   +14

    It's always good for people to come up with as many solutions as possible. Thanks for your input.
  6. dark_destiny

    dark_destiny TS Rookie


    my usb doesn't appear in disk management
    how can i format it??? is there other way to solve this
    N: is my broken usb and I have no driver to this usb stick please help
  7. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,546   +430

    I can only suggest that you try a different USB port on your computer, do other USB devices work?

    Do you have access to another computer preferably not running XP? If so you can try the 98 trick described above.
  8. dark_destiny

    dark_destiny TS Rookie

    I try other port and it didn't work also I might try win 98 but I don't have driver lor
  9. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,546   +430

    You can download the driver from sandisk's website. Just place it on a floppy, or transfer over the network (if applicable), or burn it to a cd :).

    Sandisk's site last time I was there, kind of sucked, so here is another site that has the 98se driver.
  10. dark_destiny

    dark_destiny TS Rookie

    thank for posting site but i'm using sony microvault and have the same problem with you guy so I want to know there is a driver for sony or not???
  11. ixlr8a67

    ixlr8a67 TS Rookie

    I have several SanDisk Cruzer 512mb flash drives that I use regularly, when I plug them into my admin system the drive is acknowledged by Hardware manager and everything says it is ready for use, but when I open up explorer, the drive is not visible. The disk management sees it but does not assign it a drive letter. When I manually assign it a drive letter, right click on the drive in the Disk Management window I can see the contents. Otherwise, it is as if the drive did not exist. The drive can be plugged into other machines with the same configuration and no problems.

    The only thing I remember doing recently that messed with drive settings was installing a virtual drive-mapping program, which I have since removed. I was careful to make sure nothing that seemed important was deleted. I must have missed something.

    I have tried to re-format the drive from within the drive management console, and here is the error I get: "The operation did not complete becuase the partition or volume is not enabled. To enable the partition or volume, restart the computer." After restarting the situation does not change. I can and have reformatted the drive in a dos window and same result.

    If anyone has any ideas as to what I can try, it would be appreciated.
  12. KiwiHawk

    KiwiHawk TS Rookie

    Done that now what?

    Hi All,
    Ok I've done everything you guys have suggested my USB stick is still dead.

    Bit of background for you. Installed a new P4 PC for a client about 1 week ago.
    Plugged in a Sandisk Cruzer Titanium 1GB didn't recognise the device, then plugged into my laptop nothing. Thought it had died so returned is under warranty. Thankfully. Out at same client yesterday and plugged in my Apacer 512MB stick and same thing. I now see a pattern forming....
    Now that Apacer wont be recongised on my old Win98 laptop, Xp laptop , Xp Desktop or Win2000 desktop.

    Loaded driver for win 98 and checked disk Management under XP its not recognised or listed anywhere.

    Any thoughts? Anyone!
  13. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,546   +430

    Did you build that P4 yourself? You may have hooked the usb wrong on the motherboard pins and are over or undervolting the drive and killing them. If its not showing up on multiple computers then the drive is dead, and something about that P4 machine is killing it.
  14. KiwiHawk

    KiwiHawk TS Rookie

    Thanks but its a bought PC.
    Not too fussed about whats going on with the PC as the now owners will not be using USB with it, as its for a security camera system and not used on a day to day basis.
    More concerned if anyone knows howto breathe life into the USB stick.
  15. Tedster

    Tedster Techspot old timer..... Posts: 5,746   +14

  16. Karen

    Karen TS Rookie

    Using a USB flash storage device, I had the same thing happen to me that happened to KiwiHawk in his quote above. The only exception is that I went from a Mac G5 desktop computer to a Mac G3 iBook laptop. This happened twice...once using a USB Lexar 128 MB flash drive and once using a Swissbit 256 MB flash drive. When I safely removed the flash drive from the G5 desktop and later plugged it into the G3 iBook laptop, I just got a message saying the volume (flash drive) was not recognized and asking me if I wanted to format the drive. I tried plugging the drive into my Windows 2000 laptop, and got a similar message saying the flash drive needs to be formatted, even though the drive shows up under "E" in My Computer.

    Does anyone know what is causing these flash drives to not mount on the desktop or to not be recognized? Is there anything that can be done to get the drive to mount or be recognized on a Apple Macintosh computer?

  17. tu1tu

    tu1tu TS Rookie

    Has anyone found a solution to the problem of getting Win98 to usefully recognize a SanDisk Cruzer Micro flash drive? I've downloaded a couple of different 98 drivers and the drive still doesn't appear in "My Computer" though it does appear (with a yellow question mark) in Device Manager. When I try to update the driver from the location I unzipped it to, the "OK" button is grayed out.

    For the record, I'm trying to use the flash drive to transfer files from my old 98 machine to my new XP one, and the XP machine recognizes the drive just fine so I know it's not fried.

    Your help would be most appreciated.
  18. DragonMaster

    DragonMaster TS Rookie Posts: 323

    Do you have Win98 SE or just Win98?
  19. Percell

    Percell TS Rookie

    To all you people having problems with Sandisk Cruzer Titanium

    Hi you guys,

    Are you not fed up with once again buying something that is not what you were promised ?

    And then, when contacting the Vendor to be brushed off knowing full well that you as one person are not gonna do anything about it ?

    Well...what if we could get all the people who have the same problem together and then launch some kind of legal action against SanDisk ?

    From searching the NET there must be thousands of people who have the same problem .....if each person contributed $50 we could get some lawyers to sort them out quickly.

    What do you say ?
  20. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,546   +430

    For $50 you could just buy a new flash drive from another company.
  21. Percell

    Percell TS Rookie

    That means a flash drive that should have cost you $50, actually cost you $100......and everybody else who went out and bought another one. Not to mention the wasted time,energy & resources that went into every one of those drives.
  22. Karen

    Karen TS Rookie

    I agree that something needs to be done to find out why some of these USB flash drives fail, especially when many people are using them to back up their important files.

  23. cmanos

    cmanos TS Rookie

    SanDisk Issues

    Yet another person pooched by SanDisk. I've got a large file on my thumb drive that I hkept on there assuming it was safe from corruption. Now I am being told that I need to reformat. I don't want to reformat if I should try some form of recovery first, and don't know how to go about recovering data off a thumb.

    I will have access to a Win98 machine (non-networked) next weekend and hopefully will be able to deal with the issue down there.

    What I need to know is how to go about recovering the data.

    Thanks in advance.
  24. Percell

    Percell TS Rookie

    I was able to "re-format" my Cruzer once using either the "usb-test-tool" or Computer Management/Disk Management Tool, if I remember correctly. But after a few uses it became titanium toast again and have not been able to resuscitate it since.
    From what I have been reading around the net, you can't recover the data with this problem ? Hence my frustration with Sandisk who offer no solution to what I consider a serious issue....Losing your data!!
    Any ideas what I could use my ex Titanium Cruzer for ?
  25. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,546   +430

    If the 98 machine can't read it you are in trouble. You can attempt to use some data recovery software but I doubt it will work.

    Format the thing in 98, and NEVER format it again. Its just solid state memory, it is completely unnecessary to format the drive in XP, simple deleting of the files is enough. Seems a lot of the problems with these drives occur when someone tries to format them.
Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...