Belking 802.11g Adapter- "This Device Cannot Start"

By thebaronjocelin
Jun 27, 2007
  1. Okay, so I just built this rig with an nForce4 motherboard and spent the last week just trying to get the onboard Ethernet working. It never did, so I stuck a USB connection to the modem in, and fired up the driver CD, and it all worked for a bit.

    Then, my card started to overheat because I had the computer in a cabinet, so I moved it to a desk and plugged in an 802.11g Belkin 54mbps adapter (Model F5D7050). Then, I downloaded the updated drivers on another computer, put them on a 1GB flash drive, and installed them on the rig in question.

    However, during the installation (at the end, really), I got the error message "This device cannot start", so I unplugged the adapter, plugged it back in, uninstalled the drivers, and attempted to reinstall.

    Only to get the same error message. Any ideas? Help would be much appreciated :D .
  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415


    A long time ago my brother bought a PCMCIA card made by Belkin for his laptop, at some point I had to reinstall his OS and he didnt give me the driver disk for it, well talk about a struggle to find a working driver for it..... from what I can gather Belkin changed the chipsets on the cards at some point and never updated the drivers for them on their website.

    It gave the same error as yours "the device cannot start" when I tried the wrong drivers, fortunately he still had the driver disk for it and the problem cleared with the right drivers,

    Then he bought his son a desktop PC and added (rather foolishly) a PCI Belkin card, once again not long after he came to me as it was bluescreening and he asked me to reinstall the OS, and again I hit the same problem only this time we didnt have the driver CD for it (his son lost it somewhere), I must have tried a dozen different drivers with no the end we had to go and buy a new NIC....

    I now stay away from Belkin NICS, im not saying they arent any good, in fact they are one of the better NICS around, its just that the drivers are a pain to find....

    If its of any help I do have the drivers for the f5d7000 card I had, its about 10 megs and I can upload it to my site for you to try...

  3. thebaronjocelin

    thebaronjocelin TS Enthusiast Topic Starter Posts: 158

    Well, I'm using an F5D7050, but the two drivers and the two chipsets are probably somewhat similar- if I can't find the driver disk I'll post on here and you or anyone that has F5D7050 (or 7000, as the case may be) drivers can upload or send them.

    But I'd just like to know, do I have to reinstall the OS to install these particular drivers, or is that just because you were getting a BSOD?
  4. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415

    No i just had an OS issue, all you need to do is remove the old drivers and install with the new ones.

    I uploaded the drivers I had here.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...