1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Best way to delete a dir thats not able to be deleted?  (ntfs)

By SNGX1275 ยท 21 replies
Jun 16, 2003
  1. I used this dvd2svcd program to rip a movie and well I had it not delete anything so it would be easy to go back or something if there was an error somewhere. Well basically I have a 22 gig partition and 9.97 gigs of it are this rip. I can't delete it through windows somethign about "Access Denied" and make sure its not in use. Well the thing is NTFS so I can't easily do it from a dos prompt, I was told about NTFS4DOS but I hear it has issues with Windows XP's NTFS. So I guess what I'm asking is how do I delete it? and yes I am administrator.

    I really hate this file system and see absolutely no reason to use it if you aren't supremely concerned about security.
  2. acidosmosis

    acidosmosis TechSpot Chancellor Posts: 1,350

    I'm not sure about XP's dos prompt, but I remember in DOS I would get a message about "access denied" when I tried to delete a file and you could do something to fix that but I can't remember what the command was.

    I think it was something like "del [filename] -r", or some parameter of the ATTRIB command that fixed the problem.

    That might give you some ideas of what you can do.
  3. Nic

    Nic TechSpot Paladin Posts: 1,549

    Try disabling system restore before deleting it. If that doesn't work, then you can try booting to your windows CD and deleting the file from the recovery console.

    NTFS volumes are a right pain in the but, and I've had the same problem as you're experiencing now. Luckily I have a bootable Windows XP CD that allows me to do anything I want to my other XP file system when I am running XP from my CD. Hope the above works for you, though I have to say that I haven't tried it myself, but it should work.
  4. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    That sucks SNGX, one thing I can tell you from experience you can allow it to delete files. Anything you would need to use after it is done for anything it leaves behind. I think it just doesn't delete a few system files that it needs or sth like that. Try deleting a few files at a time as well. THen you can narrow it down to which one is giving you the problems and maybe boot into safe mode, or restart and then delete it. I know that restarting then deleteing first thing might help.
  5. iss

    iss TechSpot Chancellor Posts: 1,994

    I had a problem like you describe trying to delete some files on my wifes machine that she had downloaded. I found I could boot into safe mode and delete the files I couldnt delete under a normal windows boot.
  6. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,729   +409

    It actually wont' let me touch anything in that dir. (well I can see files and stuff like that, but can't delete.) I will reboot into safe mode and try that like you and others have suggested.

    Edit: ok I tried the safe mode thing with the identical error, which basically amounts to its either in use or write protected.

    Edit 2: Actually this is relavent I think, but may not help solve the problem: I was playing around with file sharing when I had my roommate connected to me, and I did share that directory, so if anyone knows the complexeties of NTFS and windows XP maybe you could walk me through undoing whatever I did.
  7. JackieChanIsGOD

    JackieChanIsGOD TS Rookie Posts: 61

    Format the partition?
    I haven't used Partition magic to a great extent, so i don't know if you'd be able to do this, but try and partition the partition... or something...
    Maybe if you change the structure, it might unlock the file or something...

    *shrugs shoulders*
  8. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,729   +409

    ok you are on to somethign there Jackie, I was actually just discussing this in the IRC channel - I can delete it right now under at least 2 options:
    1. Move the other data on that partition to another partition/drive. then Format the partition.
    2. Use Partition Magic to convert to Fat32 and then delete it that way.

    I will do one of those options if it comes to it, but honestly NTFS can't be as terrible as I think it is, there has to be a real way to delete these, I mean I"m Administrator on this system, I should be able to do what I want.
  9. Nic

    Nic TechSpot Paladin Posts: 1,549

    Unshare the directory first, then delete it.
  10. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,729   +409

    its unshared currently
  11. Nic

    Nic TechSpot Paladin Posts: 1,549

    Open up dvd2svcd program (and any media players you used), and make sure that none of these has any reference to the files or directory you are trying to delete.
  12. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,729   +409

    Nic - I know what you are saying, but I don't think thats the problem. I may try it, but I'm almost certain its a result of the NTFS file sharing.
  13. Justin

    Justin TS Rookie Posts: 942

    File sharing is filesystem transparent. At least, what windows does, utilizing netbios, in XP, is completely transparent to partition filesystem. Security permissions don't come until later after sharing authentication.

    I have had this problem before, but it was a problem related to XP, not NTFS. I was able to delete it in linux, but you have to have write supported enabled for NTFS partitions, which is potentially unstable.

    Note this is often caused by a program not releasing file handles, but it doesn't sound like that in this case. It could be that a program wrote bad stream data to the file which is preventing its removal. Stream data is additional tag data that can be put onto any file inside NTFS, it is one of the big differences that few people know about.

    And why use NTFS? Journaling. Logging. Write verification / WRite Rollback. Large partitions. Faster index searching of large filecounts. Better scalability. Faster access on large disks. Cluster size flexibility.

    et cetera.
  14. StormBringer

    StormBringer TS Rookie Posts: 2,244

    SNGX, have you tried using something like Norton's Wipe Info. I don't recall trying it on a directory but it will usually delete files that don't want to be deleted. I have had problems in the past where a file would decide that it is being used by another app or user, but nothing and no one is using it. Wipe info doesn't tend to care whether anything is using it. It has been know not to work, but I've been around 95% successful at ridding myself of stubborn files by using it.

    *Note: if it doesn't work, try it again, if it still doesn't work, it probably won't. That has been my experience anyway.
  15. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,729   +409

    Just tried Wipe Info - Error - "access is denied" on all of the files in that dir.
  16. Justin

    Justin TS Rookie Posts: 942

    Do you have linux installed, or are able to get the knoppix CD? I can't recall if knoppix comes with a kernel that has NTFS write support but it's worth a try.
  17. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Take ownership of that directory and delete other users.

    Right-click the directory, select Security tab, then Advanced, Owner, change owner to whoever you are (you need to have administrative rights), then go back to permissions tab and disallow / delete other users.
  18. LNCPapa

    LNCPapa TS Special Forces Posts: 4,247   +448

    I doubt it's an ownership issue but if it is then Mict's suggestion SHOULD work. I am willing to be that there is a rogue process running that is holding those files. Check your taskman process tab for any oddities.

  19. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,729   +409

    That was it! for some reason there was Deny for SNGX1275. I'm not even logged in under that name, I'm logged in as "Dave" and have administrative rights.
  20. acidosmosis

    acidosmosis TechSpot Chancellor Posts: 1,350

    Glad you got that worked out SNGX. Now we all learned something!
  21. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    I bet it's nice to have that space back, huh?
  22. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,729   +409

    yeh man it was virtually 10 gigs just gone, really makes shifting things from a larger partition for various reasons, defragging, moving from the incorrect partition, ect. a lot easier.

    I was pretty sure it had somethign to do with the stuff I "tweaked" when I was trying to use advanced file sharing with a Windows98 machine.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...